Why is my WD Elements SE Portable 500GB Hard Drive not detected on any computer?

Raspal Seni March 2, 2012
Ads by Google

I bought a WD Elements SE Portable 500GB (2.5 Inch / USB 2.0) WDBABV5000ABK external hard drive in 2010. In January this year, some of the partitions started vanishing all of a sudden. A few days later, the drive stopped getting detected at all when inserted. I’ve tried using a new microUSB WD cable. No detection. It’s full of data and I don’t want to send it to WD before getting the data. I also don’t want to spend on data recovery services.

Here’s some more info –
Since many months the WD USB cable seemed to cause the drive to stop spinning and turning / twisting the cable and moving the drive a little would make it start spinning again. I guess it wasn’t the cable doing this problem but the micro USB connector on the drive.

I’ve carefully opened the drive after seeing a few videos on YouTube on how to open it from its casing. There’s no attaching connector like on most external hard drives. There’s just the USB connector directly soldered on to the drive PCB. Along with, there’s another 12-pin (6 + 6) connector. I wonder whether some kind of cable can be connected to this 12-pin connector to retrieve the data. I’ve never heard of or seen such a connector before so it’s not a standard one.

Any help greatly appreciated.

Kind Regards,

  1. candra simbolon
    March 13, 2012 at 7:51 am

    i have the same problem here. WD element can not read any laptop or PC. The connentor inside the cover is 12 pin. i'm very confused. is there anything any connector that can i use for? Please help me.My data insde is importent to me. any idea ?
    Thanks before..

  2. Erebes11
    March 9, 2012 at 5:19 am

    I wouldn't be surprised if they reject your warranty, as you stated you opened it up yourself.  Usually that's a bad idea, no matter your technical expertise, because pretty much every electronic warranty stipulates you cannot open it yourself.

  3. Joffe Family
    March 4, 2012 at 11:37 pm

    With an ordinary (ATA/SATA) drive in this situation, you would replace the controller (the PCB) with an identical one from another drive. I guess you could do the same with this if you can find an identical drive... Note that the controllers need to be absolutely identical, including their firmware version.

    Of course course, this is not free, but the price of another drive (preferably a used one) is likely to be much lower than sending it to a data recovery company, and the procedure is surprisingly simple.

  4. Raspal Seni
    March 3, 2012 at 8:42 pm

    Here are a few pictures. You can see the micro USB connector along with the 12-pin one.

    • James Bruce
      March 4, 2012 at 8:19 am

      I see what you mean. I'm afraid I've never seen anything like that Raspal. I suspect it's proprietary, unique to WD Elements drive, and doubt anyone here will know what to do with it. I would try a hardware specific forum with more in depth knowledge… sorry. 

  5. Mike
    March 3, 2012 at 12:36 pm

    According to this guide the Hard Drive within should have a standard SATA interface at the back of it.

    However, a bad connection usually triggers the device to be constantly detached and reattached to the computer ~ resulting in ALL partitions being gone sometimes.

    In order to display contents of the drive both the partition table and file system must be readable. When you say that some of them are gone it is more likely a problem with the partition table or file system.

    Personally I suggest to clone the entire drive to an image or a secondary free hard disk and attempt recovery only on the imaged media. When working with bad file systems or partition tables any attempt of recovery can also do more harm than good.

    For example you could boot up using Parted Magic and use Clonezilla which comes preinstalled with it to image the entire drive. Then use TestDisk (and it's Step-by-Step guide) which is also shipped within Parted Magic to try recovering the contents.

    • Raspal Seni
      March 3, 2012 at 8:47 pm

      Well, I can't image it unless it shows at lease in the Drive Management or under Linux.


      • Mike
        March 4, 2012 at 4:27 am

        Clonezilla should be able to image the entire drive like it does with unsupported file system doing a sector-to-sector clone.

        But yes, generally speaking you can skip over Clonezilla and issue the "dd" command to create a diskdump yourself.

        for example:
        dd   if=/dev/sda   of=/tmp/sda_clone.img

        or better if "ddrescue" is present (like in Parted Magic)
        ddrescue   /dev/sda   /tmp/sda_clone.img /tmp/logfile

        * drive and location references may be different for you

        • Raspal Seni
          March 4, 2012 at 4:10 pm

          Alas it doesn't even get detected under the BIOS so there's no way to recover data! It's still under warranty so I'll send it back to WD for a replacement.
          Even after replacement, it would be useless to use as a backup drive, just as I've been using it since 2 years. I guess I should get two identical sized drives for the backup. I had got this USB hard drive because someone told me to get it when my Kingston 4 GB full of data failed to work.

          Same thing happened to the USB hard drive so even USB hard drives are unreliable for use as a backup.

          Thanks for your solution and seems very easy and simple - just a single command and the image is done

          Kind Regards,

  6. justblue5ft3
    March 3, 2012 at 11:08 am

    When that happened to mine even a data rescue service could not retrieve any of my backup data on it, it was just fried. 

  7. Anonymous
    March 3, 2012 at 8:49 am

    perhaps there is a virus in WD that cause this problem. did you scanned WD when the problem started?

    you can try HDD regenerator
    it is a shareware

    • Raspal Seni
      March 3, 2012 at 8:45 pm

      Hmm ... how do you scan it when it just doesn't detect at all - no error messages or warnings that a USB device was connected to the computer? Same thing on all computers whichiver I tried it on. Same thing booting with Linux.


      • Anonymous
        March 3, 2012 at 9:16 pm

        HDD Regenerator first should be installed on pc then to create a bootable cd which is fast. Probably the soft  works independently of windows (BIOS must detect the hard drive) so if its the case then perhaps you can recover back the hard drive by fixing the errors on the hard drive surface.

        In the future if you start having the same problems then HDD Regenerator can be a way to solve the issu before out of reach.

        May be the problem is not the connector but the hard drive itself?

  8. Anonymous
    March 3, 2012 at 3:56 am

    You should be able to slide the pcb from the hard disk and the 2 connectors are SATA and a SATA power.
    After which you just need to connect it to a desktop or another external hard disk pcb.

    If it doesn't read after connecting it is probably the harddisk which failed.
    If it gets stuck at the BIOS screen, disable SMART.

    • Raspal Seni
      March 3, 2012 at 6:32 am

      Kagnon,As on most other external hard drives, there's no such PCB that slides on to a SATA connector. As I said, there's just a USB connector directly soldered on to the drive's PCB and it can't be removed.

      Another 12 pin connector exists on the drive ... is that a SATA connector? But it has pins like the 40-pin IDE connectors on motherboards. It's not like the SATA connectors on motherboards. What connector is this?

      Kind Regards,

      • James Bruce
        March 3, 2012 at 8:40 am

        That's very strange. Perhaps posting a picture might help. You can attach one to the comments.

Ads by Google