USB pen drives crash when attempting to copy large files.

Samol February 1, 2010
Ads by Google

All of a sudden my pen drives keep crashing. One crashed while copying to and couldn’t be formatted so was replaced and now the other 3 I have will only copy small text files okay but will crash when I try to copy larger files and folders, i.e. movie files – copying only about 20% before crashing.

I have updated the USB drivers but the problem will not go away.

This makes my Pen drives practically useless for me if I want to watch a movie on my TV off of the Pen drive. Googling tells me that I’m not the only one with pen drive problems.

My system is Windows 7 Home Premium.

Your help would certainly be appreciated.

Thank you…Dave

  1. Abhilashkudva
    April 16, 2011 at 8:47 am

    i am having a 4 gb sandisk pendrive doesnt format in NTFSmode and doest copy larger files as of 300 or 700 mb ..could u help

  2. Obscurity
    December 20, 2010 at 5:43 am

    I am having this same problem with two new drives (4 GB PNY & an 8 GB HP), but not my old flash drive (2 GB Kingston). They all worked fine on another computer with Windows 7, too. Seems to be something with NVidia drivers, Win7 and having 4+ GB of RAM installed.

    If you or anyone else is still having this problem. I don't know if it will fix it, but try looking at this microsoft discussion for more info.

  3. Fake_Loki
    April 22, 2010 at 9:53 am

    1. "Could not find this item
    This is no longer located in Computer. Verify the item's location and try again"
    At that the USB also unmounts itself.
    2. In my experience, yes or very close to. This is the same on atleast one other windows 7 pc I have tried this with that's running a 32bit instead of my 64bit.
    3. Stuff copies off it about 20 times faster and doesn't crash.
    Any idea?

  4. Fake_Loki
    April 21, 2010 at 3:06 am

    I've got the same problem with a Kingston drive. It's a 16 gig one. I can't copy anything over a hundred meg or so. It works fine with XP and Linux and always has. It also takes forever to copy anything.

    • Aibek
      April 22, 2010 at 8:41 am

      1- What error messages do you get?

      2- When attempting to copy the same file, does it always stuck at the same place?

      3- Can you confirm that you're not able to copy both to and from the thumbdrive or is it only one way?

  5. ænon1mus
    February 2, 2010 at 5:44 am

    What brand is your pendrive?

  6. Aibek
    February 1, 2010 at 7:18 pm

    Can you please tell me what is the size of those large files are you referring to? How big are they? For instance, certain file system like FAT doesn't support files larger then 4GBs. In such cases formatting the thumbdrive with NTFS does the trick.

    More on this: //

    • ARPIT
      April 15, 2011 at 6:16 am

      man u make my day...i was facing the similar problem as mention by samol but its solved with NTFS trick...many thanx!
      actually i was trying a 6gb file to copy in pendrive but at that time the error was making me in trouble but now problem solved!

Ads by Google