How can I upgrade my iPhone from version 4.2.1 to 4.3.3?

tadasp October 6, 2011
Whatsapp Pinterest
Ads by Google

I couldn’t upgrade my official (not jailbroken, not unlocked) iPhone 4 to 4.3.3 from 4.2.1 in any way, except by running with Tiny Umbrella.

If I don’t use Tiny Umbrella, I always get an error message (3149). I tried to modify the host file in every way, but 3149 was always there.

So I placed my phone in DFU mode, launched TinyUmbrella and ungraded it with iTunes. After an upgrade my screen stayed BLACK and I used FixRecovery 4.3 to try to get out of DFU mode.

I could not get it out of DFU mode in any other way. Holding power, then releasig it etc. etc. The only way I found to boot it, is to boot it via redsn0w_win_0.9.8b7b (asking to boot it tethered).

When it boots, the phone asks to register SIM card etc. However, when I power it off again, the phone is in the DARK again and I can’t power on again normally. I tried everything, but no luck.

My question:
Is there any other solution to get rid of that stupid 3194 error, except modifying the host file, which does not work? Or is there any way to make it boot normally again? My phone is not unlocked, it’s just an official phone!

Thanks for any help in advance!

  1. ray
    April 26, 2012 at 4:15 pm

    hi, it happened to me as well, the only way to get out of there is to restore with itunes with latest version. you will not see any thing on iphone untill its finished restoring.i hope i was helpfull. byeee

  2. Rima Sunchani
    October 7, 2011 at 12:25 pm

    just use don't doing zigzag

  3. Mike
    October 7, 2011 at 9:38 am

    Although I don't have an official description of Error 3194 it is usually related to firmware signing.

    The problem you basically have is that Apple has stopped signing Firmware 4.3.3 via the official servers. That means if you want to upgrade your iPhone officially you will have to upgrade to iOS 4.3.5

    This way you will also be able to (re)boot your iPhone normally without any tool or USB connection required.

    As for your redsn0w problem the answer is already in there:
    It is a tethered jailbreak that means it only works until you shutdown or reboot the device at which point you will have to connect it via USB and do another tethered boot.