How can I unlock items in the trash on my Mac?

Richard Steiner May 14, 2011

To lighten my Mac, I often empty the Trash. Easy and a nice noise of puffed trash. But now I’m getting the message that I have locked items in the trash, and I cannot unlock them.

How do I get to these items, where are they, why do I have them? When I do try to trash, only one item disappears; am left with the remainder. What can I do?

  1. Ddijin
    April 8, 2012 at 7:20 am

    thank you Ha14

  2. Anonymous
    May 15, 2011 at 8:30 am

    Navigate to /Applications/Utilities and double-click on Terminal

    By pressing CMD-Spacebar then typing in "terminal". Arrow down to "terminal" in the list and press Return

    Disk Utility is a disk tool bundled with Mac OS X. It is located in the Utilities Folder
    Disk Utility performs a variety of functions, including:
    Repairing permissions
    Repairing disks
    Creating disk images
    Disk formatting, partitioning and RAID
    Burning disk images
    Restoring a disk from a disk image
    Disk Formatting

    cache cleaning utilities: MacCleanse 2

    Clean My Mac
    [Broken Link Removed]

    [Broken Link Removed]

  3. Richard
    May 15, 2011 at 7:32 am

    Mike, thank you for the list above. I tried the Disk Verify and the Repair Permission options, and got a long list of repaired items. But I also got this: "ACL found but not expected on....". Not sure what this means. Also got: "Warning: SUID file '.......' has been modifies and will not be repaired." then some things are written including ARD Agent. 
    Anyway, tried again to empty the trash, and got nowhere. Seems one item at a time is begin removed from Trash; with over 1,000 items waiting destruction, this could take months.
    What do I do? By the way, what is a new terminal window? 

    • Mike
      May 15, 2011 at 10:10 am

      Repair Permission as the name suggests repairs permission of all system files and most other things installed via Apple Installer Package. Both errors mentioned by you ("ACL found but ...", "Warning: SUID...") are normal and can safely be ignored.

      Have you tried the Secure Empty Trash option already? You can find it in the top menu when you click on Finder.

      As for the Terminal ha14 already gave the answer: It can be found within the Utilities.

  4. Mike
    May 14, 2011 at 11:02 pm

    There are various possibilities why and how files could be locked
    - the files are in use
    - the files or folders have the locked flag
    - permission issues
    - Hard Drive issues

    First I would try the secure empty trash on Finder > Secure empty trash

    If files are being in use a simple reboot should do the job and enable you to delete them.

    If this doesn't help open the Trash and look if one or more of the items in the trash have a lock symbol on their icon. If that is the case you can unlock them by:
    1. right-click > Information (cmd + i)
    2. uncheck Locked

    This can sometimes be a bit disturbing if there are tons of files or invisible ones so it might be easier doing it via the Terminal:
    1. open a new Terminal window
    2. type sudo chmod -R 777 ~/.Trash/* /.Trashes/* and hit enter
    3. confirm by entering your password
    3. type sudo chflags -R nouchg ~/.Trash/* /.Trashes/*
    4. hit enter

    The first Trash folder is the users trash in the home directory. The second one is the Hard Drives trash folder in the root

    Now you can try to empty your Trash again.

    If it still fails I suggest to open up Disk Utility and check your drives permissions:
    1. open Disk Utility
    2. select your Hard Drive (e.g. "Macintosh HD")
    3. click on Repair Permission

    It's a good idea to run it twice but don't bother with it too much. Some permissions will never be repaired because Apple forgot to update the reference list.

    It is also a good idea to check your file systems health:
    1. open Disk Utility
    2. select your Hard Drive (e.g. "Macintosh HD")
    3. click on Verify Disk

    If there are errors reported you will have to boot from your Mac OS X Install DVD and repair it from there (or use single-user boot). You can read more about it at the following link

    *** Information ***
    The above may sound a bit of an overkill considering that the rm -rf option mentioned by ha14 would do the job. The problem is as follows: 
    If there are permission issues a simple rm -rf won't be able to delete the files. Instead you will have to use sudo rm -rf. THIS IS DANGEROUS. One typo and you could delete crucial System Files without being warned or stopped.

    Another thing to consider is that deleting the Trash folder can result in a different problem where files are being directly deleted instead of moved to the Trash. Basically you trade one problem for another.

    • Mike
      May 14, 2011 at 11:04 pm

      Looks like I missed a line break at the beginning

      (...)First I would try the secure empty trash on Finder > Secure empty trash(...)

      • Tina
        May 15, 2011 at 1:13 pm


  5. Anonymous
    May 14, 2011 at 3:23 pm

    Possible they are used in some applications, if a reboot dont help as in safe mode.

    try holding the Option key as you choose Empty Trash from the Finder's File menu. press the Option and Shift keys when you choose Empty Trash to delete it."

    Solving Trash Problems

    pull up a terminal, type "rm -r .Trash/"

    and if that doesn't work, add the f flag:
    rm -rf .Trash

    freeware Trashiy!

    [Broken Link Removed]

    • Richard
      May 16, 2011 at 2:14 pm

       Very nice. Your suggestion today, to hold Option, choose Empty Trash in the Finder, worked like a charm. My trash can is empty. I did like Mike's suggestions a lot, but some of them were over my unlearned head. Also, I just do not know the terminology or shortcuts of the computer world. Anyway, I am trashless, and very thankful to ha14 and Mike. 

      • Johnson Magnet School
        January 4, 2012 at 11:48 am

        Thank you so much for this post.  I have also read a bunch of solutions for throwing away locked folders  Your Hold Option choose Empty suggestion.  WORKED LIKE A CHARM.  Two seconds and Poof- Be Gone.  Thanks.

    • Macdueces24
      December 11, 2011 at 10:28 pm

      THank you so much ha 14 u r the man or woman but thank you

      • Anonymous
        December 12, 2011 at 1:07 am

        glad that worked for you

Ads by Google