How do I unfreeze my iPhone 5S, upgraded to iOS 8?

Zvone11 October 5, 2014

My iPhone 5S, iOS 8.0.2 has frozen. Now the black screen with the Apple logo appeared and it doesn’t do anything.

Now I’d have restored it, but iTunes doesn’t let me do that — I have to turn off some settings on my phone, which obviously isn’t an option as it doesn’t respond to anything.

I’ve tried to hold buttons but nothing happened.

Help please, I’m desperate.

  1. Jan F.
    October 6, 2014 at 7:31 am

    Depending on various factors it can easily take 10-15 minutes on the "Apple logo screen" for the update to be applied. Did you see any progress bar there?

    Usually holding the Sleep/Wake button plus the home button for 10 seconds should restart your device regardless of it's "state". So this is something you should try if you haven't.

    Finally you can try getting your iPhone into recovery mode and restore it via iTunes

    • Zvone11
      October 6, 2014 at 7:09 pm

      I've tried all those things you've mentioned, and nothing work. I couldn't restore it because I had to turn off an iCloud option 'Find my iPhone'. I couldn't do that because iPhone didn't respond to anything.
      After day waiting, finally my battery run out and after charging it, everything works well.

      Thanks for your replay!

    • Jan F.
      October 6, 2014 at 10:23 pm

      If iTunes is signed in with the same Apple ID used on the device Find my iPhone should not cause issues. I would assume that the firmware update went wrong and was stuck somewhere half-way through.

      If Find my iPhone does cause issues you can always remove the device from your Apple ID via the iCloud homepage. See last option at the following link

      Glad you could sort it regardless.