Why can I only type numbers instead of letters on my Windows 7 Starter Acer netbook?

Justjoan May 5, 2011

I’m quoting another person here. I’m having the same problem he is:

OK, I am having the same problem, but mine is a Acer netbook and it is only one day old! OS: Windows 7 Starter. Every key I hit is showing up a number. If I type “over” it is comes up as “2345”. I have unlocked the number lock, I have uninstalled the keyboard and still no luck.

  1. Lj22red
    April 19, 2012 at 11:06 pm

    Go to options on Constant Guard
    Click configure my Anti-Keyloggin protection
    Enter pin number
    Disable anti-keylogging

  2. Tritha71
    April 8, 2012 at 3:02 am

    Ok so my problem is similar.. But a bit different i have a Desk Top. And when i am trying to type in A new Web address in the search bar only number pop up but everything else is working fine. Just browsing the internet is impossible. I restore the computer. I aslo back dated it.. still same problem... Please help

  3. stefi
    April 3, 2012 at 1:24 am

    Had the same problem with ccg but disabling the anti keylogger solved my problem.

  4. guest
    April 1, 2012 at 4:47 am

    very glad to have found this. It was indeed the Constant Guard that I downloaded through Comcast. So glad it was not a virus or problem with my computer. 

    • ed286
      April 30, 2012 at 10:31 pm

      constant guard was the problem/

    • ed286
      April 30, 2012 at 10:32 pm

      constant guard: caused number problem on win 7 laptop. browsers

  5. Ehayden73
    April 1, 2012 at 1:11 am

    what do I use to compose a letter and print it out, on windows 7

  6. Anishacharya
    March 31, 2012 at 8:12 pm

    when i type in note pad it types correct letters but when i try it on google it types number pleas help me

  7. Angelo Mancha
    March 25, 2012 at 2:07 pm

    tanx for the information...

  8. Andrew_mil@live.com
    March 9, 2012 at 1:00 am

    FIDELIS, it worked thanks alot. I couldn't find the the number lock symbol on my laptop. It's so fine.

  9. Dre Songz
    February 21, 2012 at 10:46 pm

    i have this problem on my computer hp pavillion... what is this? it only happens sometimes

      February 22, 2012 at 1:21 am

      Hello, check that scroll lock and number lock is is not enabled.  If you enable number lock, you are able to use the number pad.  If it is not, you will not.

  10. Guest
    February 17, 2012 at 11:17 am

     my laptop is having the same problem, but mine doesn't have comcast any ideas

      February 22, 2012 at 1:21 am

      Hello, check that scroll lock and number lock is is not enabled.  If you
      enable number lock, you are able to use the number pad.  If it is not,
      you will not

  11. Renevie Dewadio
    February 15, 2012 at 9:32 am

    some letter of my keyboard not appears when i typing it.   when i press m,n,d,k,also my space bar not functioning. yesterday i change keyboard setting because i can only type numbers instead of letters. what should i do now to used those missing letters.

    • Butterfly
      February 15, 2012 at 10:23 pm

      Do you have Comcast Constant Guard? Most people on here have gotten rid of the program, which is not necessary. You can go to options within CG and click on Configure my "Anti-Keylogging" Protection. Just disable this feature and this should fix the problem. I had the same issue. That is, of course, if your problem is with CG, which in most, if not all, cases here, this has been the issue. 

      Hope this helps :-)

  12. Erinbrockett@yahoo.com
    February 13, 2012 at 6:27 am

    Thanks justjoanjm I had the same acer note same problem ;) it worked ..

  13. Merrideth713
    January 23, 2012 at 10:02 pm

    Thank you so much for all the info on this page. I took my gateway netbook in for a clean up and I also installed CCG as something new once I got it back. It started doing the number thing and I took it back to OD computer repair and they just kept restoring it. The numbers was only happening once in a while but I decided to take things into my own hands and here I am, happy with all the advice I got here. And computer is back to normal. Thanks again!

  14. Butterfly86
    January 23, 2012 at 6:33 am

    I had the same problem. And thanks to you all, esp Jenpierce7177 I figured out that it is Constant Guard, but I dont think you need to uninstall it to get rid of the problem. You can disable the the keylogging protection. Go to options and to configure my "Anti-keylogging" protection. After clicking this you should have the option to disable completely or temporarilty etc. I  disabled it and it took away that problem with typing the keyboard and only having numbers show up instead of letters.

  15. Emmamattson55
    January 14, 2012 at 7:11 am

    I have the same netbook and mines doing the same exact thing, its stressing me out!

  16. Guest
    November 22, 2011 at 12:00 am

    thank you all, no longer banging my head against the wall.

  17. wehateyoucomcast
    November 1, 2011 at 8:19 pm

    this helped alot! i was going to bring it to the shop, hope comcast gets this straightend up! 

  18. Dan
    September 17, 2011 at 8:56 pm

    I had this happen on my Acer and I brought up the on screen keyboard, it worked, but a real pain in the hiney.

  19. Hawkman1031
    September 9, 2011 at 3:49 am

    Fidelis, your first comment worked for me.  Touching the fn and numlock together made my acer laptop quit writing numbers for letters on the right half of the keyboard.  I've had this before but forgot how to remedy.  Thanks,

  20. JW
    September 9, 2011 at 1:47 am

    I have been battling this problem for a while. It was sometimes remedied when I would go into task manager and start closing every process I could tell was not critical. I narrowed it down to somewhere between G and J, but it was so frustrating that I would usually close several processes before I checked again. Then after reading this post I thought I would target security processes specifically. I found one called GuardedID in my installed programs and uninstalled it -- PROBLEM SOLVED! So maybe it's more than just Comcast Constant Guard (which I also have), maybe it's something with Windows 7 Starter and these programs, etc... just thought I'd pass it along.

  21. 1roadee
    September 7, 2011 at 12:06 am

    My computer had the same problem. All I had to do is uninstall Constant Guard from Comcast and the problem was fixed!!!

  22. Akanke22
    August 8, 2011 at 12:44 am

    My Acer is doing the same thing.  Thank God I have another computer in the house to look it up on and found this!   Yep I have Comcast and installed Constant Guard.  Uninstalling now.  Grrr!

  23. Ran4days
    July 29, 2011 at 11:59 am

    CCG=PROBLEMS :(  Boo Comcast!

  24. tuxdude98
    July 21, 2011 at 12:15 pm

    I had the same issue this morning, removed Comcast Constant Guard, the survey offered me the online survey, guess what one of the options was "Only numeric characters (0-9) were displayed when I typed" lol they know about it :p

  25. Logan2611
    July 19, 2011 at 2:12 am

    Still sometimes types numbers after uninstall

  26. Pluti
    July 9, 2011 at 12:40 pm

    Thank you all I almost replaced my perfectly good PC with a Mac because of this issue, I uninstalled the Comcast Constant Guard and the keyboard is working fine again

  27. Madbunnie
    June 17, 2011 at 3:45 am

    I uninstalled CCG and everything works fine.  I found it amusing that CCG had an unistall survey for me to take, asking why I was uninstalling.  One of the options was because it only typed numbers, so I checked that box, and then it insisted on details.  Um, hello, remember, it ONLY TYPES NUMBERS.  IT WOULD BE IMPOSSIBLE FOR ME TO PROVIDE DETAILS. 

    • Tina
      June 17, 2011 at 5:59 pm

      Thanks for the update!

    • WTF Comcast
      June 23, 2011 at 12:01 pm

      Exactly what i was thinking!! Haha! For the comment, i put, "1234567890"! But you just read my mind lol!

  28. Lucillekellogg1
    June 13, 2011 at 5:36 pm

    can make my numbers to work even with numlk. the number just below the function keys work but the one to the right of the keyboard do now.

  29. PCman
    June 7, 2011 at 4:35 pm

    Yes, the Comcast Constant Guard is the culprit.   So, install Constant Guard and Norton, then, go to ADD/remove programs and remove Constant Guard.   It worked for me.

  30. Mkwilson8
    May 25, 2011 at 2:15 am

    I just had the same problem with my Gateway netbook (with Windows 7 starter).  I had installed Constant Guard earlier today so I suspected that was the problem.  I googled it on my desktop and found this forum to confirm it, thanks!  I am using Constant Guard on my desktop (Windows 7) and not having that problem.  I wonder if it is just a problem with Windows 7 starter?!?

  31. Acer_Guest
    May 22, 2011 at 8:17 pm

     Thanks for the info.  Just got new Acer laptop.  Everything was working fine.  Installed another set of Windows updates.  Laptop rebooted after updates, then the keyboard started just typing numbers.  Removed only the Comcast Constant Guard, and the problem was fixed.

  32. Turnerck
    May 21, 2011 at 9:54 pm

    thanks for your help! My sister had the same problem with her new acer and you solved the problem. Comcast was the problem!!

  33. Private
    May 14, 2011 at 2:50 am

    if you installed constant guard from comcast... thats why. issue with guard id

  34. nusalt
    May 14, 2011 at 1:57 am

    I too had the same problems.  Fn + F11 did not work. I unistalled Comcast CG and the problem disapeared.  Left free Norton installed and now all is fine.   

    • Tina
      May 14, 2011 at 10:35 am

      Thanks for sharing your solution, nusalt!

    • 91b
      February 9, 2012 at 4:32 am

      Thank you all for the help, I had the same problem with my window 7. Just by reading all this, I went back and uninstalled
      CG and the problem is gone.

      • Tina
        February 9, 2012 at 10:21 pm

        Glad it worked for you and thanks for the feedback!

  35. Blackrockrider
    May 10, 2011 at 6:32 pm

    Thanks guys...I just bought a Gateway Netbook and had the same problem. Any word from Comcast on a fix?

  36. Cj2restore
    May 8, 2011 at 9:49 pm

    I had the same problem, but now it is fixed.

    I bought an Acer Netbook yesterday, it started fine but then started typing only consecutive numbers. Got a replacement machine, did only one thing at a time until it happened again. I have a Comcast account and get Norton Security Suite (NSS) for free so I installed that and that's when the problem reappeared.

    I got a Norton tech on the phone, I uninstalled NSS, problem still there. I uninstalled the Comcast Constant Guard Protection Suite (necessary to get to the NSS) and problem disappeared. The Norton Tech put NSS on my netbook and now everything seems to be working fine.

    Hope this helps someone else.

    • Justjoanjm
      May 9, 2011 at 9:38 pm


      That's EXACTLY what happened --I installed the Constant Guard Protection Suite. I'll have to reinstall Norton...

      Thanks for letting me know. I thought that might be what happened.

    • Brigitte Parot
      August 30, 2011 at 7:24 pm

      Thank you so much - I am able to write this now only after uninstalling CCGS... Told them that they should warn customers - not fair to makes us waste time like this. Thanks to you!

    May 5, 2011 at 11:21 pm

    Hello, did you use the Fn key combo or just numlock. In order for you to unlock your laptop's keyboard you have to use Fn + numlock keys at same time. Just making sure..

    • Justjoanjm
      May 6, 2011 at 3:03 am

      I did try that, thanks. I'm using a different computer now to try and find a solution...I wish it was just the numlock. Thanks for suggesting it.

      • Srobinson404
        May 7, 2011 at 3:49 pm

        Did u find the problem cause im having the same issue but i have a inspiron netbook

        • Justjoanjm
          May 7, 2011 at 3:53 pm

          Well, I set it back to factory settings without losing my personal files. It types letters again, but the mouse won't move and the touchpad is not working. the readings all say the touchpad is working perfectly as well as the mouse. I'm going to try to access it from another computer on my home network. *sigh* let me know how you do.

        • Justjoanjm
          May 7, 2011 at 3:56 pm

          Srobinson404: I don't know if you got my last post, but I said setting it back to default while saving my data worked--but now the touchpad is on the blink. I'm still working on it.

        • William Branzell
          May 8, 2011 at 5:57 pm

          I have the same problem. How did you "setting it back to default while saving my data"?

        • Justjoanjm
          May 8, 2011 at 6:25 pm

          William Branzell:
          (my touchpad problem WAS a function key issue, just in case you're wondering)

          To restore my use of text and not only numbers, I did the following:

          If it's an Acer, you can go to Programs>Acer >Acer eRecovery Management

          A box pops up and you choose "yes" then, you'll bet a window that allows you to choose Backup, Restore, Settings, or Help. Click on Restore. This will give you a choice of Completely Restore System to Factory Defaults, Restore Operating System and Retain User Data, or Reinstall Drivers or Applications.

          I went straight to Operating System and Retain User Data. Just follow instructions from there. I'm sure the Reinstall Drivers choice is worth a look, but I wanted guaranteed results.

          Good Luck!
          Good luck.

    • xen
      August 13, 2011 at 9:54 am

      it really works..:)

    • Duckyboo97
      September 9, 2011 at 12:43 am

      HOLY cow your a lifesaver! <3 thanks a million!

      • Jenpierce7177
        November 27, 2011 at 1:53 pm

        Thanks I had the same problem

        • Jenpierce7177
          November 27, 2011 at 1:57 pm

          My post was supposed to be to Cj2restore, I had installed the same Comcast constant guard and that is when my problem happened after I unistalled it computer ran fine typing letters again instead of numbers.

        • Toni
          November 29, 2011 at 1:37 am

          Yes, thank you I had Constant Guard on mine from Comcast, I was typing numbers instead of letters on my ebay web page only. I uninstalled constant guard and everything is fine. Thank you!!

        • Jamivj1283
          December 28, 2011 at 12:13 am

          thanks i am having same problem my keys was working fine before constand guard was on laptop now im deleteing it as i type this on my other computer now problem is i need a virus protection

        • DDLJ1023
          January 11, 2012 at 6:01 pm

          Thanks, Removing Comcast Constant Guard did the trick.

        • Crispattyler
          January 17, 2012 at 11:13 pm

          Thank you so much, two days ago i had the same problem because i installed ccg. I uninstalled it and now i can type normally. You are a life saver. Jenpierce7177

        • Aaron S.
          April 15, 2012 at 2:01 am


          That's around when mine started!!!
          I was worried b/c the "fn+key" fixes weren't working. Now I can stop using ths on-screen keyboard.
          Thanks a bunch!!!

          I'll see if i can tell them about the problem (should they not already know) so they'll fix their code.

    • Alicerox14
      February 11, 2012 at 10:57 pm

      did that. get letters in all other programs but have problems on internet only!!!!!

      • FIDELIS
        February 12, 2012 at 7:55 pm

        Hello, can you describe what is happening in your case?  Does it happen all the time when in the internet? or only in certain circumstances? Have you tried using the on screen keyboard when online to check if it happens there too?

    • Alicerox14
      February 11, 2012 at 10:57 pm

      did that. get letters in all other programs but have problems on internet only!!!!!

    • pepay gonzales
      February 22, 2012 at 1:15 am

      thanks for the solution.. my keyboard is now working good.. your a genius :)

      • FIDELIS
        February 22, 2012 at 1:18 am

        Hola, estoy contento que la solution le ayudo a resolver su problema

    • Binybas
      March 25, 2012 at 8:14 pm

      Thank you so much  both to you and Google. I solve my problem. God bless you. Biny.

      • FIDELIS
        March 26, 2012 at 6:26 am

         I am glad it helped

Ads by Google