Why did my TV stop reading a USB drive suddenly?

Praveen Raj Kumar January 19, 2015
Ads by Google

I am really surprised to know that I am not the only person having the problem with connectivity between Sony Bravia & USB HDD Drives. But my problem is a bit different. I bought the Sony Bravia LED TV (KDL-48W605B) on 27/12/2014 and after bringing it home a day later, I tried connecting my Transcend Hard Disk (32GB) and was happy that I was able to watch my movies from the HDD in my big TV screen.

But this didn’t last long. Since yesterday, my TV is not detecting the HDD drives, for some reason. When I tried restarting my TV, I was getting the error:

‘Some applications are not available due to a Boot Error.’

I am not sure whether this error has anything to do with the HDD connectivity to the TV.

Also I read about the other question & answers related to this problem. Most of the answers led to the topic of Formatting the Hard Disk to FAT32 system. But in my case, I was watching the movies with my hard disk until yesterday. Why, all of a sudden, do we have this problem popping up?

Meanwhile, I also cross-checked that my Transcend Hard Disk is already in FAT32 file system. So what’s wrong in my case?

Any suggestion/assistance will be very helpful and I would really appreciate it.

Thanks in advance!

  1. Granite Setts
    January 19, 2015 at 3:49 pm

    Thanks, works for me

  2. ha14
    January 19, 2015 at 10:16 am

    Restoring factory settings

    TV firmware update to v2263
    Improve the performance of network apps and recording features

  3. Jan F.
    January 19, 2015 at 7:17 am

    That is an error message of the underlying firmware.

    Try disconnecting all external devices and restart the TV.
    Try resetting the TV to factory defaults.
    See if there is a firmware/software update available for the TV, consult it's manual.
    Other than that contact Sony support.

    If you manage to get it running again I still suggest to reformat your external USB drive. There still is a good chance that it had something to do with your TV running into that error.