Why is the touchpad of my Asus Eee PC not working?

najeeeeeeeee October 22, 2011

I have an Asus Eee PC and its toochpad is not working.

  1. nikhil chaurasia
    June 2, 2012 at 7:12 am

    my new asus notebook....i bougth before 3 day....the touchpad is not working properly...only cursor is moving no click buttons are working...plzzz solve my problem??

  2. nyajoe
    May 4, 2012 at 3:48 am

    Going insane over this issue - I eventually uninstalled the driver and *deleted driver files* through control panel. When my 1005HAB restarts, it goes to some default microsoft driver that works fine, but apparently doesn't have some hotkey functionality. Who cares...it works now! I get an error message about Missing TouchPad Driver, but I just click OK and the touchpad works fine.

    FYI, I have 3 of these same netbooks. The other two work fine. In fact, this one worked fine for 4-5 months and then developed this touchpad problem. When I install new drivers from the Asus site, it works for one restart, and then stops working on the second restart.

  3. TheSputnik
    March 31, 2012 at 7:31 pm

    My ASUS G53JW had the same problem, then I noticed all I had to do was hit Fn+F9 b/c i accidentally disabled it

    • Thanks
      May 8, 2012 at 11:36 am


    • Thanks
      May 8, 2012 at 11:37 am


    • Steve
      May 12, 2012 at 10:08 pm

      YES! But on mine it's Fn + F3

      On mine, Fn + F9 shows the Windows Task Manager.

    • DC Metro Mom
      May 25, 2012 at 1:20 am

      You are awesome that is all it was.... After 3 hours of checking forums all I needed was hit fn + f9. Thank you!!!!

  4. Jeanjowett
    March 19, 2012 at 3:28 pm

    This is my laptop machine and I want my Touchpad restored

    • Basai
      June 1, 2012 at 12:27 am

      Hey Thanks! Fn+F9 did the trick!

    October 23, 2011 at 6:29 am

    Hello, have you checked under device manager to see if your touchpad is recognized?  If it is, is there any question mark beside it?  Have you checked the properties to see if it tells you about any problem/conflict with it?  It seems to be a very common problem for those netbooks. 

    Go to the following site to check/download new drivers.  Make sure to download the drivers that match your model/operating system specs:


    While you are there, make sure to check for updates to your BIOS.

    Has this netbook been open recently?  If it has, check to see if the touchpad is connected to the right socket.  Do you use a usb mouse?  If you do, you might want to check that your touchpad is not turned off when using an external mouse.  Also you might want to check that is not disabled.  To do so, go into device manager, and check for the properties of the touchpad.  Also, check on the software provided for the touchpad like sypnaptics, alps, etc, to see if it has settings to disable/enable touchpad.

  6. M.S. Smith
    October 23, 2011 at 1:26 am

    The answer might simply be - because it's broken.

    I have heard of common issues with Eee PC touchpads in the Eee PC 1215N and 1215B models. Other models may or may not have problems. If you're still under warranty, call ASUS. Maybe they need to fix it. 

  7. Anonymous
    October 22, 2011 at 1:18 pm

    The cable from the touchpad to the motherboard is not connected properly? maybe The touchpad was plugged in the wrong place on the MOBO

Ads by Google