Why does SuperOneClick hang while trying to root my Samsung GT-S7500?

Anjum Meer August 13, 2012

I am trying to root my Samsung GT-S7500 (Ace Plus) using SuperOneClick. The rooting process runs fine upto Step #7, where it hangs and stops responding indefinitely. Nothing seems to resolve the issue. Anyone have any ideas?

  1. jazza
    February 6, 2013 at 6:49 am

    exact Same thing happens with me, iv tried evry other rooting software out there...

  2. Harold
    November 4, 2012 at 6:25 am

    I'm not sure if you've resolved this, but set the exploit type to psneuter (not auto) and try again.

  3. Anjum Meer
    October 5, 2012 at 1:16 pm

    Thank you all. Will try your solutions and see what happens.

  4. Jimbo
    September 29, 2012 at 8:44 pm

    I had the same issue, over and over. I restarted my computer and it worked on the very next try.

  5. Kannon Y
    August 14, 2012 at 5:35 pm

    The biggest reason for a failed root exploit attempt is because you are using a version that's incompatible with your version of Android. With Gingerbread, there are multiple versions of the operating system - 2.3.7, 2.3.6 and 2.3.3, the last digit indicates the variation within Gingerbread. I believe you have 2.3 installed... Although this may be in error.

    Take a close look at your particular version of Android in Settings -> About Phone -> Android Version. Then make sure that the exploit (SuperOneClick, Gingerbreak, etc) is compatible with your particular version of Android, through the developer's primary thread. However, both Susendeep and Dalsan linked to better root processes.

    It's important to mention that the root exploit used in the XDA thread Dalsan linked to is quite different from installing an APK, and should be far superior to the method you are likely using. Be sure to read the directions carefully and rehearse the steps before actually attempting the exploit.

  6. susendeep dutta
    August 13, 2012 at 4:21 pm

    If your phone gets stuck while rooting,then try another method of rooting mentioned in the link below -


  7. Dalsan
    August 13, 2012 at 4:27 am

    Not all phones root correctly or as easily as other phones, even if they are the same make, model, and Android version. Sometimes it can be an issue with your computer processor compatibility or even operating system version. Try another computer if possible, try another USB port, check to make sure USB debugging mode is turned on on your phone, etc. If it still does not work, you may have to try another method like Odin.


  8. Burhan Ahmed
    August 13, 2012 at 12:50 am

    try running it as Administrator. Right click and "Run As Administrator".

    If you fail try flashing a rooted kernel using ODIN.

Ads by Google