Why am I having these strange problems with the MakeUseOf Login?

Reý Aetar September 30, 2012
Ads by Google

Until recently everything was fine. But now…
1 Login options are not showing sometimes
2 Unable to log in to this site using my Facebook account and sometimes when I am able to log in it shows “Thanks for your comment. If you’re a new user, your comment may be held for moderation first.” when I post something and after this my posts are never posted, though I am a long time user and everything was working fine until now.
These things are not happening when I am able to log in using my Twitter or Google account. Then my posts are posted as usual and all works fine until the next time I restart my browser.

3 I am unable to connect my Windows Live account with MakeUseOf. A pop up shows after logging in, but nothing happens after that.

4 Sometimes I am unable to log out. I have to restart my browser.
Currently using Firefox 18 and Opera.

[Editor’s note: Rest of message trimmed since written in ALL CAPS and not necessarily relevant. Feel free to add information in comment. Please do not use ALL CAPS!]

  1. Indronil Mondal
    October 13, 2012 at 6:58 pm

    seems many are having similar prob but no solution
    i am unable to comment for many days

  2. Anonymous
    October 10, 2012 at 3:44 pm

    I had had login problems before I changed my Facebook name (which was in Russian characters) into the name in strictly English characters. To spot this problem (unconventional characters) I had to exchange a number of messages with the support team. Also tried to shut off AdBlock, Avast WebRip. Didn't work though.

  3. VS Vishnu
    October 9, 2012 at 5:58 am

    it never lets me logout of chrome
    in firefox it works fine..

  4. amb_78
    October 2, 2012 at 6:42 pm

    Never mind, I just found the solution, thanks to GrrGrr.

  5. amb_78
    October 2, 2012 at 6:39 pm

    I've also been having problems for a couple of weeks now.
    I can login just fine, but the social buttons are all gone.

    I tried disabling AdBlock and Ghostery, clearing my cache and cookies, I even went a step further and disabled my antivirus, firewall, web protection (Avira IS 2012). Nothing worked.

    The weird thing is that this only happens on the MUO site, no matter what browser I'm using. I even downloaded portable versions of Maxthon and Avant Browser to test this site, but no change...

  6. salim benhouhou
    October 2, 2012 at 1:57 pm

    just clear your cache and login again . it works for me and i hope it works for you too .

  7. Rayon
    October 1, 2012 at 6:04 am

    I had that problem with #4 . I . used uPad 2 , it will let me log in but not out . I went to my mail unit and look for muo , it show I am log in . then i logoff it seen to do the job . I check the iPad _ it is fine .

  8. Tug Ricks
    October 1, 2012 at 4:30 am

    I'm not sure why this is a problem, but I seemingly go through it every time I want to post something to MUO. Hopefully it'll get fixed because it's becoming a bit of a hassle to say anything here. :/

  9. GrrGrrr
    September 30, 2012 at 12:00 pm

    My observations:

    1. yes there are still login/logout issues. Using Chrome. Only option is to clear cache/cookies everytime.
    2. When adblock is enabled social share option is not shown. The complete strip vanishes

    3. on>>when I am able to log in it shows “Thanks for your comment. If you’re a new user, your comment may be held for moderation first.” when I post something and after this my posts are never posted

    It means that though you see urself as logedin, you're actually NOT. The option to verify if you one is logged-in or not is to open your profile page and see if it lists your comments. If yes, you are actually logged-in.

    • Reý Aetar
      October 1, 2012 at 8:05 am

      yes and after moderation it doesnnt shows up..

  10. Rob Hindle
    September 30, 2012 at 11:35 am

    I see #3 genius of the week has added his usual zero value comments for admin to delete - but he still gets the profile upgrades - why should anyone else make any effort?

    Anyway, on to the question.
    Point 2. I occasionally get the same issue. Top right of screen shows me as logged in but sometimes when I post the system thinks I'm not logged in (BTW: I use Google login).
    I've not worked out why. I thought it may be related to what I'd been doing with my Gmail account - sometimes logged in on another tab, if I close that does it confuse MakeUseOf? Don't think that's it.

    When I use Firefox web developer toolbar to view cookies what I'm seeing looks wrong, or at least unusual - over 40kb of cookie data. The 20 makeuseof cookies seem to be repeated. I think the developers might find some clues in there.

    My fix is before I post I click "Profile", if it shows my profile: fine. If not it gets tricky. Click logout and nothing changes, I'm still shown as logged in and there's login option. I think closing the browser or at least the tab works, I'll pay more attention next time! Maybe clearing cookies wuld help.

    • muotechguy
      October 1, 2012 at 7:41 am

      Yes, we have a cookie mismatch I'm on. Clearing cookies and relogging in should fix it.

      • Reý Aetar
        October 1, 2012 at 8:01 am

        only ie was working mut now it takes too long (the automatic redirect is not hapening after the pop up window shows off

    • Reý Aetar
      October 1, 2012 at 8:06 am

      he got to #3 by doing these non sense anyway why these problems not strike him... :p
      i got his comment in my email but ddnt find it here maybe its moved

    • dragonmouth
      February 1, 2013 at 11:07 pm

      Like you I use my Google signon to access MUO. I have AdBlockPlus and Ghostery enabled and I am NOT having problems with MUO. Well, just one. I can't see the Genius List but I don't think that is any great loss.

  11. muotechguy
    September 30, 2012 at 8:36 am

    Do you have any plugins running? Anything that blocks "trackers" or third party scripts , or ads, will break the login system.

    • Tug Ricks
      October 1, 2012 at 4:32 am

      I have this same issue when I have Adblock/Ghostery disabled. Any other ideas as to what's causing this problem?

      • muotechguy
        October 1, 2012 at 7:40 am

        Two things:

        1. Are they actualy *disabled* or have you just whitelisted MUO? Whitelisting doesn't work, the plugin must actually be disabled, as it still interferes.

        2. Any other plugins of a similar nature? Do not track, noscript etc...

        • Reý Aetar
          October 1, 2012 at 7:58 am

          i had no addons it was a fresh install as no browser was working so i tried this alpha version
          but yes now i have only greasy monkey omnibar grease fire and download helper enabled (but none blocks scripts)
          and unfortunately the page is oening too slow in ie 9

        • muotechguy
          October 1, 2012 at 8:02 am

          Opening too slow isnt really something I can fix. How fast is your connection? Also, first opening will also be slow, as it needs to build your browswer cache. Subsequent loads should be significantly faster.

        • Tug Ricks
          October 1, 2012 at 7:59 am

          That makes sense. I've been whitelisting MUO, not completely disabling Ghostery. Thanks.

        • Reý Aetar
          October 1, 2012 at 8:19 am

          no no my connectoin is fast like for now i am using the same connection (after clearing all the cookies and cache it works fine in firefox ) the problem will happen next time

  12. HLJonnalagadda
    September 30, 2012 at 7:09 am

    I am also having a similar issue. I have linked my Twitter account, and every time I browse to the website, I get that same message. The solution I have found is to use incognito mode in the browser when using makeuseof. Saves the hassle of clearing the cache, and it seems to work effectively for me.

  13. Anay Chaubal
    September 30, 2012 at 5:37 am

    the new system links your social account with makeuseof, instead of having to sign up for and remember one more password. This does not always work as desired. Do you allow outside website login on your live account? do you have apps enabled on your facebook account? if yes, have you allowed makeuseof? there are a number of things that might go wrong with this universal login.

    for example, if you have no script addon installed on firefox, then it might have blocked the script for that particular page, and thus you will only see a blank pop up and nothing happening. many such universal logins do not work through the turbo mode of opera.
    for me, i login using my facebook account and firefox as my main browser, and thus allow the scripts (since I do use no script addon) for gigya (social login), makeuseof, facebook.com (not facebook.net sicne that causes a blank screen), etc.
    in case you have issues with login even after this, login to which ever account you wish to use on makeuseof, for ex: if you wis to use ur live id, then login to you live mail account and then another tab, open makeuseof answers, and then try logging in, most probably, it will work instantly.
    related to your comments not being shown, have you verified your account after signing up for makeuseof?

Ads by Google