Why is my Seagate Go Flex external hard drive not recognized?

Mike April 28, 2011

I have a Seagate Go Flex 500 GB, external. Device is not recognized in my DVD USB port. I need it to read like a pen drive. Any suggestions? Can I format it to Fat32?

  1. Huntiri
    March 30, 2012 at 12:37 pm

    Thank you very much for your help "ha14". This is a very good tutorial for me.

  2. Dan47
    December 30, 2011 at 12:52 am

    Samsung 6500 and PS3 both separate do not play movies from my new seagate 3TB USB 2 & 3 external hard drive.
    Note: I formated it to FAT32, No luck, Next I had it partitioned 1.44 and 1.28 TB

  3. website development
    May 11, 2011 at 6:34 pm

    It's not a driver issue. Check your DVD player specifications.

    April 29, 2011 at 6:05 am

    Hello, first thing you should do is test with another flash drive on the same usb port to see what happens. If the other device is not recognized, there is a problem with your usb port. Try connecting your drive to another usb port, it would be better if you try connecting it on a usb port on the back of your tower. A second thing you can try, is connecting your external drive to another computer and check if it is recognized there. If it is recognized on another computer, there is something wrong with your usb ports. Is this external drive new? If none of the other steps work, you might want to try and return it. As a last option, you can try reformatting and see if it works for you.

  5. Anonymous
    April 28, 2011 at 8:12 pm

    Probably you are missing a driver.
    In run give the command, devmgmt.msc
    It wil open the device manager. Does it show anything related to your device with a yellow colored exclamatory mark??

    Right click on My Computer and select Manage. On the following screen,
    click on Disk Management. It should show up on the right hand side of the
    screen. Assign it a drive letter.

    Seagate Troubleshooting Assistance

    if its not under Disk Drives or Removable Storage, it can be listed under USB controllers. It can have a little x on the icon. Upon right clicking it you can found that it had somehow becomed disabled on your computer. Re-enable

    • daniel s.
      May 11, 2011 at 5:16 am

      Thanks, that solved my problem. I have 2 seagate external drives and I connected both of them at the same time, that might have had something to do. Now they're both working!

    • electrical contractor
      June 13, 2011 at 6:54 am

      Solved my problem! Thanks!!

Ads by Google