Why has my Seagate external hard drive become inaccessible and how can I fix it?

Corey Haertel February 23, 2012
Whatsapp Pinterest
Ads by Google

I bought a 2 TB Seagate external herd drive from Fry’s Electronics. I put music, videos, pictures, and backed up some files from my computer. I only used it for about a month – casual usage, I hadn’t gotten into my major transferring, which I had bought the 2 TBs for.

It started going very slow. Taking several minutes just to open it up and view the files inside, then it started freezing every time I would select a file or open a folder. Then it got to the point that if I plugged it in via USB it would slow my entire computer and I would not be able to disconnect the external hard drive. It says generic volume is in use and cannot disconnect.

Now I can’t even see the driver path, find it in “My Computer”. It does not show up in computer management, under disk management. I tried running diskpart, but I cannot even start the diskpart, it tells me “the disk management services could not complete the operation” and I can’t even list the volumes.

I heard that this happens a bit with Seagate external hard drives, but I couldn’t find any help forums. Also, I could not format the drive, so I think I will have to go to the extreme of re-flashing it.

Is this something that I will have to re-flash and format to make work? Does anyone have any re-flashing tools for a 2TB external hard drives? If anyone has other suggestions I would love a solution that I don’t lose the files I have on there currently.

Someone told me they could write a driver for it, instead of the one Seagate comes with, and that should solve my problem, but I could never get the hard drive to him. Is this something I could figure out how to do myself with a sufficient guide?

  1. dhananjayan
    October 7, 2012 at 4:18 pm

    i have 1tb seagate external hard disk..... have the data for 487 gb..... now i cant able to access my file and folder...... it shows hidden..... but actually i given show hidden files and folders....eventhough it is hidden.....tell me the reason and solution..

  2. The photo guy
    September 27, 2012 at 9:43 pm

    Ok so i have a 500gb seagate drive and recently it has been freezing and making the computer slow (toshiba laptop), very frustrating when you are a photographer and you dont want to have to continuously go to your secondary backup methods because its just a pain. So here is what worked perfectly for me, and its a stretch for anyone who doesnt have the program. Open adobe bridge (i use cs6) from there open your hard drive if it shows up, cut and paste all your shit from there to either another drive or your desktop. Took my computer 5 hours to do 367gigs but everything is fine. I would recommend scanning your harddrive or computer that you transfer files to just to double check that it wasnt a corrupt file on the bad drive. Hope this helps someone!

  3. GabrielNar
    September 23, 2012 at 12:31 pm

    here's a simple fix for your problem:
    that Long Path Tool helped me in my similar situation.

  4. Maya
    August 31, 2012 at 12:37 am

    I have a seagate external hard drive too, i have an imac computer which is i can also switch it to windows the thing is when i plug my external on imac program its working as my back up time machine and i can open my forlder inside, but when i used to switch on windows there's an eject icon showing but i cannot even view my folder even i use the other computer which has a windows program my external also not working, im lost and i dont know why it happenned suddenly, Basically i need to open it using by windows program Is anyone there knows what to do and why it happened could you give me some idea on what i supposed to do? please need a help.

  5. skimran
    August 14, 2012 at 1:07 pm

    Serial Number: 2GHY4Z8E
    Model Number: ST910004EXM101-RK

    i have an external hard disk and i have bymistake formate it now its not working plzz help

    • fwh
      August 19, 2012 at 2:27 pm

      Here is my simple solution

      - Disk Management
      - Change Drive Letter
      - Click Offline (left side)
      - Click Online (left side)
      - It worked!

  6. dan
    August 6, 2012 at 6:35 pm

    i have a 320GB Seagate external HD. I formated to my Bell Expressview. Now i can't access the drive through my computer. Can someone help

  7. Jonathon Sueppel
    August 5, 2012 at 6:57 pm

    ok i have a friend who just bought a new Seagate external hard drive, she was able to use it for a week, then her computer stopped recognizing it. what should she do?

  8. nishant
    August 4, 2012 at 8:00 pm

    i also go through a step i.e
    1.right click on my computer then go to manage & then disk management.
    after then whatever condition required i also tried but nothing happened ..

    so please give me another solution which benefited me ...please

  9. nishant
    August 4, 2012 at 7:54 pm

    My external harddisk does not working properly i.e it doesn't show anything files,folders & sub-folders.

    Situation - when i attached my harddisk with my pc it does't show anything.the drive is invisible.

  10. guy
    August 3, 2012 at 4:49 pm

    re: Rpcman's comment helped me out.
    I had (have?) similar problems with a 1 TB external Hard Drive (the device manager says it's mitsubishi hardware). Windows would complain about partially written files even during reads, then the drive would fail and disconnect while exploring sub-directories, after taking a really long time to *try* and read them. I couldn't even browse to pull files off of it.

    I disconnected the drive as Rpcman suggested, and restarted everything at the same time. It seems to have worked, even though, like him, I can't imagine why. The same directories that reported read errors seem fine, at least enough to pull some important data onto another drive before the external one get's worse.

  11. robert
    July 28, 2012 at 2:51 pm

    hi it may be unsigned after a fault or virus
    go to start, Control Panel\All Control Panel Items\Administrative Tools\computer management\storage\disk management click the drive then the partition and right click change drive letter once you have done that apply the drive letter and exit and it should appear

  12. Rcpman
    March 1, 2012 at 3:10 pm

    I realize this sounds crazy but it has worked for me several times. Disconnect the drive from power and from the system for a couple hours or a day, thenpower off, reconnect and restart. Worked with my WD external HD.

    • G3kgailtje
      August 15, 2012 at 12:52 pm

      I've tried that with my WD external drive but it's not working!! I keep getting the pop-up to unlock my external drive but when I do my laptop won't read it

  13. James Bruce
    February 24, 2012 at 10:35 am

    The hard disk is dead. The driver has nothing to do with it. Sorry this isn't what you want to hear, but hard drives will very often fail within the first few months. There is very little chance of file recovery, but try CHKDSK if you want. 

    Chalk this one up to experience - always take backups. 

    • Ian Cook
      June 6, 2012 at 9:42 pm

      I agree. Plug in your HDD power and USB, then put your ear to the drive (close up against it so you block out any other sounds) and listen very carefully. Under normal circumstances, you should hear the drive motor start up and an irregular ticking sound of the head seeking. If instead, you hear a rhythmic "ticking" (frequency about two ticks per second) then your HDD is knackered. The sound you are hearing is the head trying to seek but it can't, probably because the drive motor is seized. This is probably why Rcpman had some success in disconnecting and leaving off for a period of time. If the motor is overheating then cooling it can sometimes fix the problem but its only temporary. There is one thing you could try. It worked for me once, and I was able to get some data back. Plug in your HDD power and USB cables. If it starts ticking, leave it for at least 10 minutes, then have another listen. If the ticking has stopped and you can hear the motor running, unplug the power cable and quickly plug it back in again. This will start the "seek" cycle again with the motor already running and you computer may detect your drive. If you are able to get it going again, get all your data off quickly, and dump it. Good luck!

    • Prat
      July 13, 2012 at 7:14 pm

      I'm experiencing the same problems and I am running chkdsk. So far it's been on for more than 24 hours and it doesn't look like it's in any hurry. (201 out of 7000 odd files scanned, it says). I don't intend on pulling the plug on a chkdsk. Heard that could be fatal, but it looks like this might take weeks. And I'm not even working on a PC.
      What would you suggest? There is some stuff on there which I would like to save, but some of it backed up.

    February 24, 2012 at 7:56 am

    Hello, have you tried accessing drive when in safemode?  Whenever you loose the icons and taskbar is because there is something causing trouble with explorer.  When that happens, try to see if this fixes your screen and/or let you access drive:

    -- click ctrl + shift + esc
    -- click on process tab
    -- find explorer.exe entry
    -- if entry is there, right click on in an kill the process
    -- if explorer.exe entry is not there, click on File tab
    -- click on new task(run)
    -- type explorer.exe and click on ok

  15. Corey Haertel
    February 23, 2012 at 11:50 pm

    I just checked, and there was no, "NoDrive" Policy. I Haven't been able to un-install the driver as well. My computer freezes whenever I try, then my start bar dissapears when I am forced to end the process. I am only able to view the folders when I am running a program from seagate that is supposed to scan and fix my external. I have run all the test but it says the driver works fine. If I try to copy a file into my external it says, "Cannot copy: The path is too deep." When I try to open a folder within it, I get the error, "E:/(folder) is not accessible. The semaphore timeout perios has expired." When I try to delete one of the folders it says, "Cannot delete file: Cannot read from the source file or disk."

    • Anonymous
      February 24, 2012 at 9:51 am

      is there any enough empty space left on your 
      Do you want to recover the files on seagate or formatting is also an option for you. in case try Easeus partition master.

      Can't Access This Folder. Path Is Too Long" Error

      try CHKDSK /R
      this can take sometime depending on the size of your hard drive, will fix if file has corrupt/bad clusters

      perhaps you have read and write problems on the hard drive
      USB Disks Access Manager

      now if your hard drive is infected with virus?
      1. Go to control Panel, Folder Options -- select VIEW--- select Show hidden
      files and folders and uncheck Hide protected operating system files
      (recommended)  click APPLY
      2. go to your external hard drive  delete the virus and all the shortcut folders that have
      no data in them. create new folders (give the same name as your normal non infected hidden folders) and copy the data from YOUR hidden folders
      into them. once that is done delete the old hidden folders.
      3. enter task manager--- find the virus program that is still running which will
      have the same name as the one you just deleted off the hard drive
      4. go back to control panel, Folder options select view- select DO
      NOT show hidden files and folders and recheck Hide protected operating system
      files (recommended).

    February 23, 2012 at 9:53 pm

    SIDE NOTE: This problem happens on any computer I plug it into. It began running slow while using Vista and finally froze altogether while using Windows 7. So I know the problem is in the external hard drive, not my computer.

    • LogicMind
      October 29, 2012 at 7:16 am

      Same here,I was a student DBA for a while in my school. .

  17. Anonymous
    February 23, 2012 at 8:26 pm

    look in device manager and see if there is a yellow mark concerning the seagate, if ues right click on it and reinstall, reboot and let windows to install new driver.

    if its not under Disk Drives or Removable Storage, it can be listed under USB controllers. It can have a little x on the icon. Upon right clicking it you can found that it had somehow becomed disabled on your computer. Re-enable

    Troubleshooting Assistance

    Windows may be configured to hide drives from Explorer and My Computer ?Click Start->Run, enter regedit to open the Registry Editor
    ?Navigate to key HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersion
    ?find value named NoDrives. right click NoDrives then delete it and reboot to unhide all drives

    Run ServiWin
    1) Click View->Drivers
    2) Scroll to USBSTOR. Verify StartupType=Manual and Status=Started
    3) If StartupType= Disabled, rt click to change it to Manual. Reboot

    perhaps usb port blocked in BIOS
    1. Reboot your computer
    2. Enter BIOS
    3. Select Advanced
    4. Select USB Configuration and press enter
    5. Select the option to enable USB ports

    from device manager. right click to usb and toggle disable/enable, you can also choose uninstal, reboot and let windows to redetect and instal drivers.

      February 23, 2012 at 9:51 pm

      I found the driver in device manager, but it did not say it was disabled. It also had the most up to date driver and would not up-date or re-install. I got diskpart to work, just a little, but if I attempt anything after selecting the volume it tells me that the operation could not be completed because the data may not be recoverable.
      The main problem is that if I attempt to do ANYTHING concerning the drive (exploring, formatting, ejecting, ect.) my computer freezes and I have to use task manager to end the process. Which in turn makes my desktop and start bar dissapear, one of those times permanetly and I had to re boot my computer to get it back. I was able to open the driver and view the folders inside, (the first time in about a year I have gotten that far) but it said no files were inside the folders and I could not open the folders because of a very strange error. I'll update with the error when I am back at that computer.

    • VINOD
      September 11, 2012 at 10:30 am

      can you please do me a favour.
      I cannot see my harddisk in my computer but if i go to device manager i can see it. so now i want to take back up can someone help me.

Ads by Google