Why can’t I “Safely Remove” my external hard drive?

Phil V July 7, 2010
Ads by Google

I recently purchased a Hitachi Simple Tough 320g external hard drive. I wanted it to store my music, videos, pictures, documents etc. and hoped to use it like a gigantic flash drive.

After I moved all my stuff, I tried using Windows “Safely Remove” feature, but I keep getting an error message that the drive is “in use” and to stop any programs that may be using the drive and try again. I’ve looked & looked, but I can’t seem to find anything that is “using” the drive. HELP!

Also, how come the properties for this drive show only 298 GB of space? I realize the drive needs some allocation space, but 22 GB?

  1. IceMan59
    March 14, 2012 at 3:18 am

    Try stopping the Windows Media Player Network Sharing Service. Worked for me. Microsoft needs to fix this.

    • Lieks
      April 25, 2012 at 3:44 am

      Thank you :) been searching for a while for a solution to this. Very neat!

  2. Minos Daedalus
    August 12, 2011 at 5:24 pm

    I bumped into this thread and read about the disk space giving by the manufacture and the attempted explanation. The explanation of Tina missed something. if you want to calculate in one unit such as kB (B for byte and lower case b for bit) that stands for kilo bytes whereas kilo stands for 10³. So 1 giga byte (giga = 10^9) are 1,000 mega bytes (mega = 10^6) are 1,000,000 kilo bytes are 1,000,000,000 bytes. The failure goes to the operating system which suggerate you have for example a 596 giga byte hdd instead of a 640 giga byte hdd which is acutally untrue. The unit is simply wrong; there 1 gigi byte that is 1024^3 bytes (1 gi * 1024 = 1024 mibi bytes; 1024 mi * 1024 =  1.048.576 kibi bytes; 1.048.576 ki * 1024 = 1.073.741.824 bytes). And here comes the point where Tina is right: calculate from gigi byte to giga byte (kilo = 1000; kibi = 1024). So you have to do (640 * 1000^3) / (1024^3). That is equal to 596,05. So 640 giga bytes are 596,05 gigi bytes (the 0.05 difference is a physical matter of producing hard drives). The industries producing hard disk drives use the International System of Units (SI) so kilo is 10^3, mega is 10^6 and giga 10^9. Just the operating systems like Windows don't use that system and is telling you that a 640GB hard drive is a 596GB (giga byte) hard drive.

    For further information check out on wikipedia with the keywords "binary prefix" and "decimal prefix".

  3. Kerryyap
    July 31, 2011 at 2:19 am

    Thanks to jdpage, your solution work for me ^^

    By the person had the same problem

    • Sarmayee2010
      January 3, 2012 at 10:06 pm

      how to disable indexing on the drive?

  4. jdpage
    June 29, 2011 at 5:38 pm

    I found that if I disable indexing on the drive, I can go from not being able to remove to being able to remove.

    • Sarmayee2010
      January 3, 2012 at 10:05 pm

      how to do disable indexing on the drive jdpage?

  5. Philv01226
    May 28, 2011 at 6:14 pm

    First of all, I want to thank everyone for their in-put. MUO & forums like this are always so helpful.
    I have found the ULTIMATE answer to this and many more of my computer problems.
    I stopped using Windows!
    I switched my operating system to Ubuntu (on the recommendation of MUO - THANK YOU VERY MUCH!), and I have had nearly zero issues since.
    Don't be afraid. Walk toward the light. You'll be happy you did. I am.

  6. Belfastian
    May 28, 2011 at 2:37 am

    Hello, using Windows7 & just bought a 80GB external HDD (Core by CNM & powered by USB), formatted to exFAT (choice of this or NTFS only and noticed no difference [so far] and has a folder of films at 23.6GB) and same problem - "cannot remove, blah, blah..."   so ran Task Manager but no sign of 'Crypserv.exe' [mentioned above] or anything being used, so; Right-click the External HDD/PROPERTIES/HARDWARE [choose drive but should already be 'highlighted']/PROPERTIES/CHANGE SETTINGS [another window pops up]/POLICIES - then choose your option. I already had the 1st (QUICK REMOVAL) and changed to 2nd (SAFELY REMOVE feature), Rebooted computer but made no difference - same message. So, as it was set as 'QUICK REMOVAL' (back to 1st choice again), unplugged the HDD, REBOOTED [again] then connected it back to check and films still there and tried the 'SAFELY REMOVE'  feature and it worked! Could have been a fluke or just changing the settings over but just thought to post my experience. If you try this, hope it works for you.

    • Tina
      May 28, 2011 at 5:21 pm

      Thanks for sharing your experience, Belfastian!

  7. Trangen
    September 1, 2010 at 7:56 pm

    I tried this, it did not help.
    "decided to delete a RECYCLE BIN hidden folder that appears in my External HDD basic folder!!!! then the system perfectly removes the drive!!!! GOOD LUCK!!!! "

  8. Jimkazas
    August 30, 2010 at 9:22 pm

    hi! I had the same problem and I just found the solution!!! the problem was that i could only safely remove my HDD if I would connect the USB cable and safely remove without doing anything. I read all the comments here and decided to delete a RECYCLE BIN hidden folder that appears in my External HDD basic folder!!!! then the system perfectly removes the drive!!!! GOOD LUCK!!!!

  9. Thug_ashes
    August 10, 2010 at 8:43 pm

    This is very simple... If anyone else will encounter something like this, just log off your PC and log back on. Then you can safety remove your flash drive or Eternal HDD... harharhar

  10. Ryan Dube
    July 15, 2010 at 6:19 pm

    Phil - You will always get this error whenever even just a single app is accessing the drive. You can even just have Windows Explorer open with the drive directory displayed and Windows will tell you that the drive is in use. It may be possible that one of those shortcuts you removed from your external drive were open and connected to the directory on your PC? Anyway glad to see it cleared up! I just wanted to mention that I see this all the time and it always comes down to an app accessing the external drive, sometimes in ways that aren't very obvious.

    • Maga1
      March 24, 2012 at 2:04 am

      Sounds like the culprit, i shut down my system with the on/off computer casing button when the screen had frozen up, ever since I've had problems with my external harddrive.  First I wasnt allowed access so had to give full permissions all round, next i found recyclers (similar to recycle bin) in it, next windows files appeared in it, 2 failed saves and now im having the same problems, cannot disconnect it even when gamebooster 3 has shut down all unnecessary programs and processes.  I've put some games on it and the update services of 2 may be causing my problems, but at least i can still use it

  11. Anonymous
    July 14, 2010 at 6:09 am

    I believe Tina's explanation is the best regarding the lost hard drive space. Regarding your drive being in use, it can be because of a multitude of reasons, ranging from Virus Scans, Viruses and Trojans, Backup Apps, Open Applications, etc. The list could go on. Make sure you use the Task Manager to kill any process that might be using the drive before you try ejecting it.Also, in case your drive doesn't use "Write Caching", you can just unplug the drive without actually "Safely Removing" it first. The explanation is in the linked screenshot below.http://a.imageshack.us/img132/6192/140720101135...In order to find out whether or not your drive uses Write Caching, go to Device Manager by going to Start > Run and typing devmgmt.msc Then, open up the properties for your drive under Disk Drives, and click the Policies tab to check its status. I have directly unplugging my devices for ages without any damage to them (of course, write caching is disabled on all my devices).

  12. Phil V
    July 8, 2010 at 4:22 pm

    Thanks for the HDD math lesson, Tina. If that's how they figure disk space, then they should have called it a 300g drive... I'm just sayin'...
    I've spent a LOT of time in Windows Task Manager (Yes... with the "show processes from all users" option activated...) and I just can't seem to figure-out which process is gumming-up the works. I don't have the process you mentioned in my list, Saikat, but thanks for the tip.
    I am one of those users who doesn't like to power-down my machine. I REALLY don't want to shut-down just to remove my external hard drive. Alas... if I don't figure anything else out soon, I may have no other option...

    • Tina
      July 8, 2010 at 11:06 pm


      the manufacturer should have called it a 298 GB drive, 300 GB would be completely wrong.

      Back to removing your hard drive. So you tried rebooting your computer and every time you connect the external hard drive and try to remove it safely it's the same issue?

      Does this happen even if you do not read / write / copy any files to or from it?

      It must be a program accessing the drive. Did it come with pre-installed backup or security software of its own? Could it be the virus scanner on your computer?

      • Phil V
        July 9, 2010 at 4:41 pm

        It came with some proprietary software... they a;so wanted me to purchase a compatible back-up and file transfer program. I figured Windows did those things well enough for me. I did a "complete" format of drive (twice) and there didn't seem to be anything left on it but "space".
        I have my scheduled Windows back-up going to the drive.
        I have several layers of anti-virus/malware/spyware/firewall running.
        There could be other "behind-the-scenes" programs running that need access to it, I suppose...
        I WAS able to "safely remove" the drive in "Safe Mode".
        At this point it is hard to say what the culprit is, but I'm continuing to look...

        • Phil V
          July 11, 2010 at 3:11 pm

          I changed my folder view to include hidden files & went through the folders on my external drive. I found several called "Desktop" as well as a few others, and deleted them, then ran a C-Cleaner cycle. It appears that there is nothing there but the music, pics, videos, etc that I want and nothing that I normally wouldn't "see".
          I can now "Safely Remove" my drive.
          THANK YOU to everyone who tried to help with my problem.

      • Bigtonka75
        April 19, 2011 at 12:12 am

        the 320 to 298 arguement is misleading to the consumer. its that simple whether the nuts and bolts of the manufactures math make it true is still....misleading to the consumer.

        • danwat1234
          January 21, 2012 at 8:43 am

          No, it's NOT misleading to the consumer. They bought a 320GB hard drive, plain and simple. It just sohappens that that translates to 298GiB. But the consumer DID buy a 320GB drive as advertised.

  13. Saikat Basu
    July 8, 2010 at 5:44 am

    I have the same problem with my Seagate and Transcend external HDD. Their is a process called Crypserv.exe in my processes list. I stop the process in the Task Manager with a CTRL+ALT+ALT, and then I manage to safely remove the HDD. Is their a similar process in your task manager list? Could be worth a shot.

    • NT
      February 23, 2011 at 2:28 pm

      You are right. Thanks!

  14. Tina
    July 7, 2010 at 9:28 pm

    The reason your 320 GB hard drive is shown as only having 298 GB is easy.

    1 GB is 1 073 741 824 bytes, but hard drive manufacturers calculate with 1 000 000 000 bytes. So if you multiply 320 GB with 1 000 000 000 bytes and divide the result with 1 073 741 824 bytes, the result is almost exactly 298 GB.

    As for safely removing the drive, you can also shut down your computer and remove it.

    • Anubhav
      August 20, 2010 at 2:43 pm

      the part which u suggested to mr. hdd problem was very effevtive and true but even some people don't understand the basics of it ....
      anywazz i really liked u ans ..

  15. Anonymous
    July 7, 2010 at 9:14 pm

    Safely remove function may not work because of activity in your external hard drive because of various reasons like Anti-virus scan, spy-ware bot, files accessed by you etc. Press CTRL+ALT+DEL and terminate all functions what might possibly access your HDD and then do safely remove.

    Regarding hard drive size, for 320GB hdd, 22gb loss of space is no surprise. It happens! I got a 1TB hdd which was way less than 1tb.

Ads by Google