How can I restore the Facebook app on my HTC Sensation?

Tracy Riggs August 22, 2012
Whatsapp Pinterest

I have lost the ability to take a pic and send directly to Facebook. My Facebook icon is gone, I tried to download from Google Play.
I get error message “Unfortunately, Google Play Store has stopped”.
I downloaded the Facebook album app. But it doesn’t allow sending pics straight to Facebook. What can I do?

  1. kenneth calfee
    February 19, 2013 at 9:35 pm

    Please help me restore my Facebook account on my sensation its my original one

  2. Ilkka
    October 12, 2012 at 7:23 pm

    I have the same question, but the problem is a little different.

    In my HTC Sensation, Facebook doesn't show in the app list. When I go to Google Play Store and look for Facebook, it says "Not in use". EVERY time I click this and choose "allow", the Google Play stops.

    I don't remember how I managaed to uninstall Facebook in the first place. But looks there is no way to get it back. Any help is much appreciated!

    • alina
      December 29, 2012 at 9:35 am

      I had the same problem, very frustrating. This is a very convoluted way of solving it, but this is the only thing that worked for me because the Facebook app wasn't even showing up for me in the app list.

      1. Go to google play store online ( and search for Facebook for Android app and Trigger the Install from there. It should shortly show up in your play store as installed.
      2. It still did not show up in my APP list however. So i went to the play store and searched for Facebook, it gave me the options to "Uninstall" or to "Enable". If I clicked enable, google play store would stop. So I clicked Uninstall. All this did was uninstall the updates to it.
      3. After the app uninstalled, instead of the "Enable" option it gave me the "Open" option... Which was weird.. but i clicked it.. and then it opened the App for me.
      4. Once I signed in there was an "update" button right through the app and that downloaded the latest version of FB and now it's working fine and shows up in my App list too.

      Too many bugs in this new ICS OS update!!! Very disappointing... :(

    • YahLi
      March 10, 2013 at 8:31 am

      Wau, i experience the same thing... and after uninstalled it working normal... Thanks Alina...

  3. Dalsan
    August 24, 2012 at 7:46 am

    Just to let you know, Facebook changed the security settings again without telling anyone and disabled the sharing of pictures through third party apps or through the Facebook app. You would need to go to your Facebook apps through your main Facebook page and find the Facebook for Android or whatever app, then change the security settings for it to share with everyone. Facebook was very stupid for doing this as thousands if not millions of users thought their apps were broken when it was Facebook's fault for the security change. This talks about Friendcaster, but is similar to what happened with many other apps. [Broken Link Removed]

  4. Kannon Y
    August 23, 2012 at 11:14 pm

    This sounds like a cache issue. That can be resolved by wiping your cache.

    Here's what it looks like (and I don't have Facebook on my phone, unfortunately):

    1. Go to settings and choose "applications".
    2. Select manage applications.
    3. From the all tab, find the Facebook App.
    4. Clear both data and cache, if you can.

    Normally, I would suggest uninstalling and reinstalling the app, but unfortunately, many handset manufacturers have special deals with Facebook that prevent its uninstallation. Basically, we don't have any freedom over the apps on our phones.

    You may as well attempt uninstallation, though, in case your handset manufacturer didn't make Facebook a mandatory app. Hope this helps!

  5. susendeep dutta
    August 23, 2012 at 4:26 pm

    If you are comfortable installing apps from third party sources and want to upload pictures using Facebook app only,then -

    [Broken Link Removed]

    Friendcaster app is alternative app for Facebook app -

    [Broken Link Removed]

Ads by Google