How to restore my corrupted write-protected 512GB flash drive?

Jenny S December 24, 2013

Basically I tried to format my 512GB (FAT32) flash drive then it was interrupted multiple times.
Now when I tried to format it the write protect error comes up.

I tried cmd, regedit, computer manager, but to no avail. Is there any other way I can manually fix it?

  1. Oron J
    December 25, 2013 at 3:50 pm

    First of all, try to re-partition it. You can do this from the command line as Hovsep explains, or through the Windows interface as follows:

    1. Run "Computer Management"
    2. Expand the "Storage" branch and click on "Disk Management"
    3. Identify your USB drive (Disk 0 is usually your hard drive, other drives will be called Disk 1, Disk 2 etc. Use the drive size to identify the USB drive).
    4. RIGHT-click on the rectangle representing the content of the drive (that is, the white area with the blue bar at the top) and choose to Format... the drive. You will probably be told there's no partition, and be given the option to create one. Do so.

    When the partition has been created, format it as FAT32. Given the problems you had with the drive, I suggest you do the "slow" format, which will also check your drive into the bargain.

    If "drive is protected" faults prevent you from doing this, you can follow Susendeep's suggestion (I've never heard of this software, but will try it now!), or you can follow the instructions at

    • Jenny S
      December 26, 2013 at 3:29 am

      I can not format ... the area when I right click my flash drive is gray so I can not activate, even when going to my properties it still is a issue.

    • Oron J
      December 26, 2013 at 10:06 am

      Sounds like a write-protection issue, see the second half of my comment.

    • Jenny S
      January 5, 2014 at 7:43 am

      I tried that I guess it became faulty because I move my computer around while it was formatting.

  2. Susendeep D
    December 25, 2013 at 11:23 am

    Try Repair_Neo2.9 [Broken Link Removed] tool to remove write protection.

    • Jenny S
      December 26, 2013 at 3:55 am

      It tells me

      It in correctly and the computer sees it but not this program.

    • Susendeep D
      December 26, 2013 at 4:06 pm

      Try the suggestions listed in the below article -

      How To Fix Write Protection Errors On a USB Stick

  3. Hovsep A
    December 25, 2013 at 9:59 am

    open cld with admnistrative rights
    1.Type: diskpart and hit enter
    2. Type: list disk and hit enter
    3. Type: select disk and hit enter
    (enter the number that corresponds to your USB drive)
    4.Type: clean and hit enter
    5. Type: create partition primary and hit enter
    6. Type: select partition 1 and hit enter
    7. Type: active and hit enter
    8. Type: format fs=fat32 and hit enter
    9. Type: exit

    • Jenny S
      December 26, 2013 at 3:24 am

      after I click clean the message was
      disk part encounter error: the media is write protected
      see system event log for more information

      even with create partition primary
      it respond no useable free extent.....

    • Jenny S
      December 26, 2013 at 3:48 am

      though this seemed to work for my smaller 126gb flash drive and I just need to reformat it and see what happens.

    • Hovsep A
      December 26, 2013 at 7:57 am

      if it is write protected then try the following
      1. Open CMD with administrative rights
      2.On the black screen type: diskpart and hit enter
      3. type: list disk and hit enter
      4. type: select disk # (# is the number of the USB key) and hit enter
      5. type: attributes disk clear readonly and hit enter

      if you want try to format again

    • Jenny S
      January 5, 2014 at 7:42 am

      I tried that I guess it became faulty because I move my computer around while it was formatting.

    • Jenny S
      January 5, 2014 at 7:45 am

      but my smaller flash drive was fixed thanks, everyone.

    • Hovsep A
      January 5, 2014 at 12:34 pm

      perhaps you need testdisk to repair corrupted USB Key

Ads by Google