How can I repair and format a RAW Memory Stick Pro Duo Card?

incognito27 June 22, 2011

I have a 8 GB Pro Duo Memory Stick. It is damaged and it won’t format. When viewed under Disk Management, the file system shows up as RAW.
CHKDSK doesn’t seem to run on that memory card.

I was able to use a software named “Zero Assumption Recovery” to recover the files. Now, how do I repair the memory stick from RAW to FAT32 or NTFS?

  1. Anonymous
    June 23, 2011 at 9:06 am
    • Anonymous
      June 23, 2011 at 1:05 pm

      Thanks for the reply. but,
      iCare Format Recovery wont even detect my Memory stick (I am using a memory card reader BTW).
      I have already tried Memory stick formatter from sony it also failed to detect my drive.
      Wasnt much help at all.
      I tried linux (ubuntu "the trial thingy from the Pendrive and the ISO" ), which also failed to detect the card.
      This may sound like a "detection problem" but it is not. I've tried several other softwares on windows. However, they all did the function of only recovering the files but not fixing the card from RAW to FAT/NTFS.

      Any other ideas?

      • Anonymous
        June 23, 2011 at 2:57 pm

        Try the following:
        Hope you memory stick is not locked?

        1) Use GParted to change
        the type from RAW to NTFS/HPFS and see if that fixes the problem.
        2) Grab yourself a copy of testdisk from
        CG security and see if it can find and recover your partition.

        choose your drive that is RAW then Analyze then proceed the search then rechoose the drive and do search then rechoose the Raw and do write then quit and reboot pc.


        Just go to the Command Prompt and execute the command:

        D:> CONVERT D: /fs:ntfs

        Where D: is a name of the drive you want to convert. And yes, the correct number of spaces is necessary, so just copy n paste that line into your CMD prompt.

        if still dont function the grab the ubuntu boot disk and type the following

        sudo mount -t ntfs-3g /dev/* /media/**/ -o force
        *is your drive in question
        ** is destination directory MYDATA ntfs-3g

        • Tina
          June 29, 2011 at 3:49 pm


          were you able to repair your memory stick in the meantime? And if so, what method worked for you?

        • Anonymous
          July 1, 2011 at 11:28 am

          I am sorry for the late response, but none of the methods seem to be working for me. I am going to assume that it must be a physical problem and that it cannot be repaired.
          But anyways, thanks for all your help and support. They were very quick replies too. :)

        • Tina
          July 2, 2011 at 10:52 pm

          Too bad! Sometimes hardware is simply broken beyond repair.

Ads by Google