How can I repair disk errors found with ChkFlsh?

Prempal Singh March 30, 2010

How to repair the errors that are found when a disk is examined in ChkFlsh?

  1. Prempal Singh
    April 3, 2010 at 11:54 am

    No this is not the cause.

    • Aibek
      April 3, 2010 at 12:30 pm

      OK, we can post this as a "hard question" next week and see if any of
      the readers can help you with that.


  2. Prempal Singh
    April 2, 2010 at 12:26 pm

    @Aibek - It doesn't shows any error.It just stops the copying process.
    @Taty - No its NTFS.

    • Aibek
      April 3, 2010 at 11:45 am


      By any chance when copying files to your USB drive, do you attempt to put more than 512 files in the root of the drive? If that's the case that may be the cause of the problem. To avoid this try copying files into multiple folders.

  3. Taty
    April 1, 2010 at 5:55 am

    What error do you get? And is your drive Fat32?

  4. Prempal Singh
    March 31, 2010 at 4:31 am

    I have tried to format the drive and even tried to delete the partition and recreate it but I am still facing problems.
    The main problem I am facing is that whenever I try to copy something to the drive it interrupts in between and I am not able to copy and sometimes I am successful.

    • Aibek
      March 31, 2010 at 11:12 am

      When it interrupts, what error(s) does it show?

  5. Aibek
    March 30, 2010 at 12:29 pm

    Hi Prempal,

    I assume you read about the ChkFlsh here, //

    The thing is, that utility only checks, not fixes anything. I guess the best thing to fix the drive is to format it (My Comouter -> Ricgh Ckick on the drive -> Format). If you have stored the information on the drive that needs to be recovered then try tips recommended in the following articles.

    - How To Make Corrupt USB Jump Drives Work Again
    - How to Recover Data from a Corrupt Memory Card or USB Drive

Ads by Google