How can I remove write protection from a USB drive?

Romaine B. March 6, 2011

I copied two files on my USB without any problems but got a write protection message for the third one.

Tried to create a new key and modify DWORD values in Regedit but “key” option is deselected. Typing the “cmd” command in Regedit and following the procedure is not working either.

I am using Windows XP SP2. Thanks in advance for your help.

  1. Mohd Arif689
    March 19, 2012 at 7:52 am

    hello ..
    my pendrive shows write protected even after performing the regedit format.....and i tried it in other two to three systems, plz me.....

  2. Romaine B
    March 8, 2011 at 10:55 pm

    I think my computer has a problem because I used the same key on another computer and it worked just fine. Thanks to all of you.

    • Tina
      March 8, 2011 at 11:14 pm

      Thanks for the feedback Romaine!

  3. Anonymous
    March 7, 2011 at 10:30 am

    Neo 9 tool able to get past the write protection and format the pen drive

    JetFlash OnlinE Recovery from Transcend

    • Romaine B.
      March 7, 2011 at 11:18 am

      Thanks a million
      I will try and keep you informed.

      Have a nice day.

  4. Jack Cola
    March 7, 2011 at 12:59 am

    Maybe the third file you are copying is in use by another program is is locked?

    • Romaine B.
      March 7, 2011 at 9:02 am

      Hi Jack
      Thanks for your reply. I tried again after restarting the computer, but same problem.

  5. Mike
    March 6, 2011 at 8:00 pm

    If you successfully copied two files to the USB drive there cannot be a write protection on it. Otherwise you would have gotten the message at the first file.

    Is it possible you are trying to copy a file larger then 4Gb to a FAT32 formated USB Drive? In that case you will have to reformat your USB Drive using a File System that supports larger files e.g. NTFS.

    Other possible options would be your USB Drive is out of space or the remaining space is corrupted. For the latter I also suggest to reformat the drive (don not use Quick Format)

    • Romaine B.
      March 7, 2011 at 9:00 am

      Dear Mike
      Thanks for your response. I did get the write protection message after successfully copying the first 2 files. The 3rd file is very small (word documents) and I have used only a small fraction of the (new) USB space so far. I tried using Regedit to "create" a new key with modified specifications but this function is deselected.
      Thanks for your help.

      • Mike
        March 7, 2011 at 10:49 pm

        It's a lame workaround but you could try opening the Word document and use Save as ... to save it directly to the USB Drive.

Ads by Google