How to remove write protection from a Toshiba USB drive?

mango wodzak October 14, 2012
Ads by Google

I have a 16GB Toshiba USB thumb drive which has suddenly for no apparent reason become write protected. I was in the middle of copying some files over to it, when suddenly I got the message saying disk was write protected. I am unable to format it as I am told it is write protected too.

I have tried setting HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies to make it writable, and I have tried running diskpart to clear the read only, I have also tried runningmUSBfixer to reformat the drive. None of the above appear to have made any difference, my drive is still read only. There is no external switch to write protect the device. Any other ideas on how to restore writability?

  1. mango wodzak
    December 24, 2012 at 8:11 pm

    This didn't work for me.. says the disk is still write protected..

  2. Tama Keane
    December 24, 2012 at 12:22 pm

    Probably a bit late now but try using the 'Safely remove hardware and eject media' option while the drive is in, wait about 10 secs, then remove the drive and put back in.
    This sorted the problem out for me straight away and no need to format drive and lose data.

    • mango wodzak
      December 24, 2012 at 8:15 pm

      thanks for the suggestion.. I gave it a shot, but it still says write protected.. The only suggestion I have still yet to try is using Linux to format the drive.. Still haven't got hold of a Linux machine to try that one yet.. If that doesn't work, I'm going to give up with it and hit it with a hammer. (I'm hoping that the mere threat will frighten the drive into becoming writable again!!).

  3. Ramswroop Siyota
    November 7, 2012 at 8:22 am

    I have try this path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies but storage device policies no shown. Please help me.

  4. sameh moheb
    October 18, 2012 at 10:29 am

    i need software remove the write protection from my SanDisk pen drive i do all u said to remove it but i can't
    my flash is 4 gb format with NTSF

  5. Adrian Rea
    October 15, 2012 at 11:31 am

    It is a long shot but some drives have a tiny switch on them (like old 3.25in disks) that you could use to write protect the whole disk. Have a look it may have one :)

    • mango wodzak
      October 15, 2012 at 8:21 pm

      As stated in the question.. the device does not have an external switch for write protection.. thanks for the suggestion though..

      • Harish Jonnalagadda
        October 15, 2012 at 8:25 pm

        Ok have you tried using Linux to format it?

        • mango wodzak
          October 15, 2012 at 8:29 pm

          no.. good suggestion though.. I think I have an old copy of ubuntu on CD somewhere, not sure how to use it, but I guess if I boot from it, it should let me format the USB stick.. Is it easy to format a drive with ubuntu, or to change the device to writable?

        • Joe Webb
          October 17, 2012 at 11:14 pm

          Do you have the nasty program Bitlocker enabled? It seems to hose USB drives whenever it desires. Thanks Microsoft.

    • Shashi
      April 5, 2013 at 8:40 am

      linux is also not able to format the drive i tried it.

  6. kumar raja
    October 15, 2012 at 11:22 am

    Use any Software to resolve the problem or follow the below link for more

    • mango wodzak
      October 15, 2012 at 8:18 pm

      The suggestion for reformatting the drive using the HP utility was mentioned by Drew Butler.. unfortunately it never worked.. just threw back the message that the disk was write protected..

  7. Imesh Chandrasiri
    October 15, 2012 at 9:04 am

    I think there is something wrong with the flash drive firmware. you won't be able to fix, it unless you have tool to read the firmware. the best option is to take the drive to the vendor so that they can fix it!.

  8. susendeep dutta
    October 15, 2012 at 5:57 am

    You can also use neo9 tool -

    [Broken Link Removed]

    Check whether it can be helpful or not.

  9. ha14
    October 14, 2012 at 8:53 pm
    • mango wodzak
      October 15, 2012 at 7:34 am

      thanks for the suggestion, but when I run this too, it says it can't format it because the device is write protected..

    • mango wodzak
      October 15, 2012 at 7:37 am

      I tried this, and get the error message: preformat not supports this IC! so still no luck.. :(

      • ha14
        October 15, 2012 at 10:24 am

        a) Right-click on usb drive and select properties in the explorer windows.
        b) In the properties window, select the security tab.
        c) Select the ‘user’ under user name and click on ‘Edit’.
        d) Check if you have Write permissions. If you don’t, check the option “Full” for full permissions or “Write” for write permissions.

        Diskpart-Removing Readonly flag from Volume

        [Broken Link Removed]
        click the green button to download

        if you have windows cd, first insert usb key and then boot on windows cd, then act like you will install windows but on usb key and choose format usb key.

        perhaps EaseUS Partition Master can delete volume and partitionthen to format?

        • mango wodzak
          October 15, 2012 at 7:44 pm

          When I select properties on the USB drive, I cannot see any "security" tab.. there is a "general" "tools" Hardware" "Sharing" "ReadyBoost" and "Customize", but no "security".

          As stated in the question, I have already tried removing the readonly flag with diskpart, but that didn't help either..

          and when running the UFix tool, it seems to be unable to find the USB drive, as the "Control disk" dropdoiwn menu is empty..

          Thanks for the suggestion with EasUS Partition manager.. I'll see if I can get a copy from somewhere..


        • abhi
          October 24, 2012 at 6:46 pm

          Sane thing happened with my 8gb toshiba pendrive

  10. Drew Butler
    October 14, 2012 at 8:28 pm

    Try HP USB Disk Storage Format Tool. This tool is not specific to HP only. Also works on other brands

    Read more: HP USB Disk Storage Format Tool - CNET

    Good Luck :)

    • mango wodzak
      October 15, 2012 at 7:33 am

      thanks for the suggestion, but when I run this it says it can't format it because the device is write protected..

Ads by Google