How do I remove the write protection from my FAT32 formatted external hard drive?

Norman Conley August 28, 2012
Ads by Google

I have a Toshiba 750 GB external hard drive, my PC has stopped recognizing it, so I hooked it to my Macbook Pro. It took a couple of hours but it mounted. I tried to format it to FAT32 using my Mac, it said it formatted the hard drive successfully, but my then my Mac stopped recognising it.

I tried it with my PC again, Windows 7 recognized it, but said it needed to be formatted before it could be used. When I tried to format it with Windows 7, it said the hard drive was write protected. How do I remove the write protection? Can I force the MacBook to mount the hard drive and remove the write protection? Any help would be greatly appreciated.


  1. Anish Parameshwaran
    February 11, 2013 at 8:42 pm

    I'd recommend reformatting the hard drive to NTFS, since it has been known to be more stable.

    • Norman Conley
      February 17, 2013 at 5:52 pm

      I did format it for NTFS. Thank you.

  2. bright awotwe
    January 12, 2013 at 8:36 am

    I was firstly using my 4gb pendrive which was working effectively .i use to plug it in my my playstation 3 and my pc and do some installation but within a few days later, any time i want instal any file, it says there is right protecting and with this right i cant even formate because any time i try it still displays this right.please i am pleeding please help me.

    • susendeep dutta
      February 2, 2013 at 10:50 am

      Did you tried above listed solutions?

      • Norman Conley
        February 7, 2013 at 12:53 pm

        I was able to delete the volume, create a new one and reformat the drive. I lost a lot of files, but the drive works now...... Thanks

  3. Norman Conley
    October 16, 2012 at 3:30 pm

    Many thanks to all those who left comments, and suggested ways for me to recover my external hard drive. I was able to solve my problem. I right clicked on My Computer, and selected Manage, then I selected Disk Management. I wasn't able to format the hard drive, so I right clicked on it and selected Delete Volume. Then I created a new volume, and was able to format it. Thanks again everyone for helping me find a solution.

  4. Bodi Hemanth
    October 11, 2012 at 2:45 pm

    You can format your external hard disk for Mac and Window. To format hard disk that usable for Mac and Windows, you need to select “MS DOS File System” for formating your hard disk.

    To format your hard disk for Mac and Windows on Mac follow the steps below:-

    Go to Finder -> Application -> Utilities
    Double click for Disk Utility
    Select the external Hard Disk you wish to format at the left column
    Click on the Erase tab
    At the “Volume Format” select “MS-DOS File System”
    If you confirm to format your hard disk for mac and windows, Click on “Erase” button.
    Pop up window will ask to verify the erase procedure. Click the erase button again in the window to start the erase process.
    * All the data in the external hard disk will be permanently removed after this steps.
    Once the erase process finish, your external hard disk may be able to use in Mac and Windows.
    P/S: This tutorial is also suitable for format thumb drive to be used on Mac and Window.

  5. Kavita
    October 6, 2012 at 11:21 am

    format it again using disk utility....

  6. vivek yadav
    October 2, 2012 at 1:23 pm

    format it again...

  7. Ashok Sundar
    August 30, 2012 at 11:29 am

    You have to go back to FAT32 filesystem, I mean to say use previous version Windows & remove the write protection and backup your data to NTFS version.

  8. Tony Batty
    August 30, 2012 at 3:18 am

    Norman, right click My Computer, go to Manage, in the Computer Management Screen, go to Disk Management, look for the drive in the right pane windows and do what Ben says format in the NTFS format, by right clicking on the drive and choosing format, you will see other options there too.

    August 28, 2012 at 8:58 pm

    Hello, you could also try clearing the write protection on the registry. If you want to try by using the registry option, I would recommend to backup registry first. Here are the steps:

    -- click on start and then type regedit in search box:
    -- once registry open, navigato to the following entry:


    If for some reason the StorageDevicePolicies entry does not appear, make sure to create a new entry for one

    -- click on storageDevicePolicies to hightlight it and then create a new DWORD (32-bit) Value named as WriteProtect.
    -- Once WriteProtect entry is created, double click on WriteProtect key in the right hand side window and set the value to 0 in the Value Data Box and press OK button
    -- restart your system
    -- try to copy/delete files in your external drive

  10. Benjamin Glass
    August 28, 2012 at 2:21 pm

    Don't use FAT32; use NTFS. This might solve some of your problems.

  11. Bruce Epper
    August 28, 2012 at 3:45 am

    Try this one: open an administrative command prompt and type 'diskpart' and press Enter. Next, type 'list volume' and press Enter. This will list all volumes attached to the system. Find your external drive and note the number, you need it for the next command. Now, type 'select volume #' replacing the # with the number you got from the previous step. It should respond with 'Volume # is the selected volume'. Next, type 'attributes disk clear readonly'. This will clear the read-only attribute for the disk (if it is set). You could also just type 'attributes disk' to see the current state of all attributes for the disk (the top 2 are the ones you are concerned with). If they are set (have a value of 'Yes'), you need to run the clear command to remove that setting. Type 'exit' to close the diskpart tool, then 'exit' again to close the command prompt. Reboot your system to force a remount of the drive with the new settings and you should be able to fully access the drive.

  12. ferdinan Sitohang
    August 28, 2012 at 1:55 am

    Please Follow this step techiecorner

Ads by Google