Why can I not re-install Windows 7 from my upgrade DVD?

Ray Nelson August 13, 2011
Ads by Google

I started a re-install of Windows to build it from scratch and in process get things into order so it will install updates. 1 hr into copying files it says: “Windows cannot copy files required for installation. The files may be corrupt or missing. Make sure all the files required for installation are available, and restart the installation. Error Code: 0x80070017″It is an install from my original W7 disk…

This is my original Windows 7 install (upgrade) disk that has only been used once.

I am trying to re-install because Windows 7 refuses to update Service Pack 1, saying “The component store has been corrupted. ]02:29.184: ERROR: Neutral MSU installation failed (exit code = 0x00003712 (14098))”

Keep in mind, this is a re-install to a Windows 7 system from the Windows 7 upgrade disk (which could be the problem?).

Any help would be appreciated.

  1. Tina
    August 18, 2011 at 4:49 pm

    Thanks everyone for helping to solve this complex issue! Glad it worked out for you, Ray.

    • RayLNelson
      August 18, 2011 at 6:01 pm

      Thank you Tina....

  2. Ray Nelson
    August 15, 2011 at 6:04 pm

    One more update so no one wastes time with more recommendations:   

    1.)   Windows 7 re-install from the DVD worked and SP1 installed.   
    2.)   IE9 (original problem from many months ago) installed.

    Proceeding to create users and install software, hoping for no glitches...

    • Ray Nelson
      August 15, 2011 at 10:25 pm

      So we have a fully functional Windows with IE9 working.    

      This was not easy and I can't imagine a normal user going through it.

      If you do re-install, I'd recommend a 3rd party migration tool.   I purchased one when I initially updated from Vista to w7 because it was my daughters PC and I had no idea about all the apps she has on it.   It worked flawlessly moving everything including installed application programs.   To bad I don't remember the name anymore.   MS has a free one, but I forgot to do it, so I can not comment on whether it works.   The MicrosoftFixit50582 copies files but not much else and that you can do by drag and drop.

      Now my daughter gets to put all her programs on... (she wants back to her MacBook, but new ones are way to expensive).

      • FIDELIS
        August 16, 2011 at 12:14 am

        I am glad you could fix your problem

        • RayLNelson
          August 16, 2011 at 5:26 pm

          I started this when IE9 originally came out... Such is the Fun of it...  That program I used was written by the LapLink people.   It really worked good.  I was going to back this system up, and retry this process using the Microsoft tool, but from the notes I have found the MS tool does not restore programs including registry settings...  

          Good luck all...

  3. Ray Nelson
    August 15, 2011 at 4:18 pm

    After finally typing "Net stop wuauserv" correctly, it would not stop.

    I figured there were updates were in que so looked and disabled those that had arrived in the short time I was on this morning.   Then it stopped, found the software distribution directory in c:windows and deleted it (after making copy)

    After running for about 23 minutes (from c:windowslogscbs.log) this error was logged.

    2011-08-15 08:48:47, Error                 CSI    00000232@2011/8/15:15:48:47.851 (F) d:win7sp1_gdrbasewcpcomponentstorestorelayout.cpp(11690): Store corruption detected in function ComponentStore::CRawStoreLayout::CheckFamilyIndexForDeadWinnerComponent expression: (null)
      MissingWinningComponentKey on resource [96]"x86_microsoft-windows-photobasicdeployment_31bf3856ad364e35_6.0.6000.16386_none_3ce3bd051d0ba8a7"[gle=0x80004005]

    Where is d: mapped?  (wow) just noticed the "Recovery" partition is left mounted.  But there is no win7sp1_gdr directory on it.  I do have an image backup of this partition, but don't know if that will be of any help since the error points to a file that was probably copied from the sp1 distribution file and deleted during cleanup when sp1 install failed. (just guessing)

    I just ran a chkdsk on d: and it found no issues.   

    I logged this as it happened so anyone else might be able to move forward.

    Wondering if this can be fixed before I start re-install...

    • Ray Nelson
      August 15, 2011 at 4:31 pm

      One more note, using Macrium Reflect I was able to mount the Image and do a file compare using PureSync.    There were no differences.   That makes me wonder why the Update would even be looking there if there were no changes.

      I think I am chasing a dead end...

    August 14, 2011 at 8:35 am

    Hello, the link shows an article about troubleshooting problems with service pack installations:

    tutorial on how to install windows 7 service pack 1:

    steps to follow before installing windows 7 service pack 1:

    how to install windows 7 service pack 1, with windows update, online and/or offline

    Have you tried cleaning the windows update cache files?

    -- click on start
    -- click on run
    -- type the following command on the run box:

    net stop wuauserv

    -- open root folder and look for the SoftwareDistribution folder
    -- once you find the SoftwareDistribution folder, make sure to delete it
    -- go to command prompt and type the following command:

    net start wuauserv

    -- to recreate cache, navigate to windows Update and press check for updates. 
    -- restart computer and try to install service pack 1

  5. Mike
    August 14, 2011 at 7:26 am

    Ray, I tried to follow all conversations ~ correct me if I'm wrong:
    You tried installing SP1 [in order to get IE9] and got a CRC or File/Directory missing error. Then you tried a re-installation of Windows and again, encountered a similar error (the 0x80070017)?

    Now, this is a far fetched guess but maybe your drive has some bad sectors and it's controller somehow missed out marking them as such.

    If you do have a running Windows on your computer (on the Hard Drive)
    Go to Start menu > All Programs > Accessories, right-click the command prompt and select "Start as administrator"

    In the elevated command prompt type the following: fsutil dirty query C:
    If your disk is reported "dirty" issue the following command chkdsk C: /r. This will tell the Check Disk program to scan your drive and try to repair any bad blocks or data.

  6. Bruce Epper
    August 14, 2011 at 7:08 am

    If you are attempting to install SP1 through Windows Update, have you tried downloading SP1 and doing the update locally?  I have yet to have any problems doing it that way.  (I never install Service Packs through Windows Update since I have encountered MANY issues trying it that way.)

  7. Anonymous
    August 14, 2011 at 6:54 am

    How do I reset Windows Update Components? 

    Set the computer in clean boot, and then try to install SP1 upgrade.To set the computer in clean boot follow the steps from the below mentioned link:

    Starting Windows 7 with a Clean Boot is easy. You simply temporarily turn off
    all non-Microsoft services and restart your PC. When it boots up, only Microsoft
    services will be running, allowing you to step through turning on different
    services until you find the problem.

    Different from Safe Mode, a Clean Boot lets you disable all non-Microsoft
    background applications and services to troubleshoot a PC running Windows 7.
    Once disabled, you can begin turning third-party services back on to diagnose
    your computer.

    Just be sure to hide all Microsoft services before you use the
    Disable All button. Otherwise, you may encounter boot up errors when you reboot your PC.

    How to Perform Clean Boot in Windows 7

    August 14, 2011 at 1:00 am

    Hello, do you have a functioning system now? Or it is not working at all?  You know that after a failed installation there should be a few temporary files on your system.  If you have a functioning system, try cleaning your cache and temporary files.  Also make sure to check your disk for errors.  Before inserting the installation disk, make sure there are no smudges, fingerprintes, etc., on your disk.

    • Ray Nelson
      August 14, 2011 at 1:30 am

      Thank you... Tried all that...

    • Ray Nelson
      August 14, 2011 at 1:41 am

      and yes I restored from my backup, system works fine, just back at point of not being able to use IE9.    I like Chrome and Firefox too, but there are many sites where you have to be in IE.   My daughter works with one such site.   I wanted to keep her laptop current.  So I am using my time to get this working.   Eventually I will find a way, but i have to admit that MS is making it difficult...

  9. Jeffery Fabish
    August 13, 2011 at 10:45 pm

    When you chose how to install, are you choosing "Upgrade" or "custom"? Inplace upgrades never go well on a Windows box, go find competency in Microsoft :P.

    If it's not too late, you don't need to re-install the OS to fix the upgrade failure. You could run a sfc /scannow in CMD (start -> search: "cmd.exe" without quotes) to check your installation and compare it to what it should be (will require the disk). 

    A common cause of your upgrade failure is Firewall and anti-malware software blocking the installation. Try temporarily disabling security software and trying again. If that fails, manually download the service pack yourself and install it since it could be Windows Update not properly downloading & installing it.

    • Ray Nelson
      August 13, 2011 at 11:04 pm

      Thanks Jeffery, this issue arose because originally I could not install IE9.  In that resolution I found I needed to install SP1.   During those I ran sfc/scannow and found nothing, also ran another preparation program recommended by MS which did nothing.  I have disabled AVG (even uninstalled it) and tried the processes in Safe mode.   Step by step for weeks there has been no resolution on this, and your comment to "go find competency in Microsoft? is something less than helpful."  I'd suggest if your goal is to insult the yahoo blogs are good.  If I have mis-interpreted your comment, then I appologize.  

      • Jeffery Fabish
        August 13, 2011 at 11:18 pm

        Didn't mean to offend, I was taking a swing at Microsoft for being incompetent.

        I can't get SP1 to install on my Windows 7 (virtual box) either. I haven't tried installing IE9 as I use Google Chrome & Firefox.

        • Ray Nelson
          August 14, 2011 at 1:32 am

          Thanks Jeffery, I can't tell anymore...   LOL...   Posting an update in a separate comment.

  10. Mike
    August 13, 2011 at 10:04 pm

    0x80070017 is a CRC Error (file verification)
    Either the DVD is damaged or your optical drive is having problems reading the contents (dirty lens, weak or damaged laser, ...)

    You could try to copy the DVD and install with the new disk or create a USB Installation media.

    • Ray Nelson
      August 13, 2011 at 11:07 pm

      Thank you Mike, will happily try that.   But I think there is something else behind the error and it is being reported incorrectly.  I say that because I tried it a 2nd time with a different error result (something about a directory being missing).  

      Sorry, but I was at that point quite frustrated and restored from backup loosing the detail....

      • Bruce Epper
        August 14, 2011 at 6:57 am

        A CRC error can also be reported as pretty much any other kind of filesystem error as well.  It all depends on what it is trying to access at the time.  A CRC error when reading a directory will commonly be reported as a missing file or directory error.  About the only time you will get the generic CRC error is when it happens when reading the contents of a file and sometime in the filesystem metadata.  That being said, I also believe it is a problem with damaged/dirty media or an issue with your optical drive.

Ads by Google