How do I reconnect to my WiFi network after forgetting it?

Nahla D March 19, 2014
Ads by Google

I was once connected to a WiFi network at work. Due to circumstances, I had to “forget” the network and tried to reconnect again. I tried the same password, but I always get this infinite loop with “Authentication problem.”

My co-workers can use the same network with no problem and with the same password even. I thought this will resolve on its own but it did not. I tried to reconnect again after a few days but still it won’t budge. I need help with this issue.

Other Info: My phone is NOT ROOTED and it’s Android Ice Cream Sandwich. I tried WiFi Fixer like everyone says but it doesn’t work. Please don’t advise me to do something about the adapter/router, since I have NO ACCESS or control over it since it’s at work, not in my house.

Also, even if I have access to it, it’s in a different language so no can do. I am considering of doing a hard reset or rooting it but I have too many files in my phone to back up, so I wonder if you guys have any suggestions first. Thanks.

  1. Shalom I
    March 21, 2014 at 10:10 am

    Hi i think this was very tough to connect the wifi after forgetting the password.

    • Nahla D
      March 22, 2014 at 6:31 am

      Hi , Shalom. I did not forget the password. The password is still correct, but the problem is about "Authentication problem" loop issue. No, thanks.

  2. Hovsep A
    March 19, 2014 at 7:54 pm

    maybe there is a wifi application on your phone just uninstall and reboot.

    1) turn off the Wi-Fi and mobile data on your Android Phone
    2) turn ON the airplane mode, while airplane mode is ON active turn the Wi-Fi ON and try to connect to the network again.
    3) Once the Wi-Fi is connected turn airplane mode off.

    • Nahla D
      March 20, 2014 at 6:29 am

      "Maybe there is a wifi application on your phone just uninstall and reboot."
      =Nope, I uninstalled every WIFI application in my phone, unless you consider ES File Explorer a WIFI app (which I think it's not) since I didn't uninstall that.

      Also, I did steps 1-3 already many times. To be sure, I just did it now before replying here, but it still doesn't work. Any more ideas?

    • Hovsep A
      March 20, 2014 at 8:33 am

      maybe they shutdown SSID broadcast on your network?

    • Nahla D
      March 20, 2014 at 8:48 am

      Sorry, but what does "SSID broadcast" exactly mean?

      Anyway, I am not sure with that, but I can assure that my co-workers can access the same WIFI network with no problem at all. If this SSID broadcast was shutdown, then why do my co-workers can access the network? I think this is not the case.

    • Nahla D
      March 20, 2014 at 11:39 am

      About your question, I don't think they've ever done that. Even if I ask them to do that, I'm pretty sure they won't do it since they might not reconnect.

      Thanks for sharing the link. It's very useful. I think there are solutions here too and I've tried some of them but they still didn't work..

    • Hovsep A
      March 20, 2014 at 4:27 pm

      well if you coworkers cant try this and your administrator do not inform you then it is a lost track...

      maybe something is left from your previous connection which is not erased so your phone is little in circle...
      see if you can clear wifi settings, like cache...

      THE "RIGHT" WAY (USING ADB): adb shell rm -rf /data/misc/wifi && reboot
      (this will remove the settings and then force a reboot)
      From the Terminal app.
      # rm -rf /data/misc/wifi && reboot

      FXR WiFi fix and rescue

    • Nahla D
      March 21, 2014 at 1:15 pm

      "if you can clear wifi settings, like cache…" I downloaded WIFI Fixer to clear my cache but it didn't. Is there other ways I can do to clear cache without rooting my phone? I'll try FXR WIFI in a bit and I'll let you know.

      Btw, When I used WIFI Fixer, I got a message like this:

      Supplicant State: SCANNING
      Supplicant State: ASSOCIATING
      Supplicant State: ASSOCIATED
      Supplicant State: FOUR_WAY_HANDSHAKE
      Supplicant State: DISCONNECTED
      Supplicant State: INACTIVE
      Authentication Error

      What's FOUR_WAY_HANDSHAKE? And this always happens in a loop in WIFI Fixer--in a circle like you just said. I want to try the ADB stuff (which I don't understand yet) but my phone is not rooted, as indicated above already.

      Hey, I think I can access the router settings in my PC, although it's in a different language. There's no password surprisingly! I'll use G-Translate for a while. Do I need to tweak some settings in it? Nothing too serious I hope.

    • Nahla D
      March 22, 2014 at 6:34 am

      Hovsep, I tried FXR WIFI fix Rescue and unfortunately it didn't work. Stubborn WIFI setting!

    • Hovsep A
      March 22, 2014 at 9:36 am

      well if you can access the router settings maybe you can change wifi channel, but this will affect your coworkers...
      check if somehow they added your MAC address in exclusion so that to forbid you connection?
      you cant reset the router? unplugging/plugging the cable again?
      are you able to connect to other networks?

      Supplicant State: FOUR_WAY_HANDSHAKE
      WPA 4-Way Key Handshake in progress.

      Supplicant State: DISCONNECTED
      This state indicates that client is not associated, but is likely to start looking for an access point.

      Supplicant State: INACTIVE
      Inactive state (wpa_supplicant disabled).

      you can remove the battery for a while until no more electricty left in the phone and put the battery again (do backup your phone files)

    • Nahla D
      March 24, 2014 at 1:08 pm

      Thanks for replying, Hovsep!

      …you can change wifi channel, but this will affect your coworkers.
      =This sounds too risky.

      Check if somehow they added your MAC address in exclusion so that to forbid you connection?
      =How do I know if they excluded my MAC address? Which panel/settings should I check or change? If I was included, how exactly do I remove my address from the setting/network?

      You can’t reset the router?
      =I’m pretty sure there is a password in the router, but surprisingly I can access the settings on the browser (or so I think). So I hope you can help me in this area.

      Unplugging/plugging the cable again?
      =If I do this unplugging/plugging thing (not pressing any button, only pulling the cable, right?), what exactly will happen next? Does it ask for a password afterwards in the router? Buffering mode? Or change/reset settings and networks?

      Are you able to connect to other networks?
      =There are other networks at work but I don’t know the passwords, except this one. However, I can connect with public networks like those in a restaurant, and connect to the net via limited mobile data plan.

      "You can remove the battery for a while until no more electricity left in the phone and put the battery again (do backup your phone files)"
      =What do you mean by this? Are you referring to a reset to connect? This doesn't work for me, unfortunately.

    • Hovsep A
      March 24, 2014 at 4:47 pm

      Best Ways to Reset a Home Network Router
      Power cycles do not erase saved passwords, security keys, or other settings saved via the router's console

      If you encounter authentication errors while connecting your Android™ tablet to the network, ensure the following:
      1) SSID broadcast must be enabled
      2) Wireless MAC Filter feature must include (allow/permit) or exclude (deny/prevent) the MAC address of the tablet
      3) Correct wireless network name (SSID) and password must be selected

      1.From the main settings screen upon logging into your router Select "Wireless" and then the "Wireless MAC Filter" sub tab.

    • Nahla D
      March 27, 2014 at 1:37 pm

      Thanks, Hovsep for your responses and links.

      I am considering of doing this power cycle method, of course when there's no one around. By the way, does soft resetting change any router settings? The About link you posted didn't specify anything about that. It only says that it's "instantaneous." I will get back to you when I'm done.

    • Hovsep A
      March 28, 2014 at 6:10 pm

      nope simple unplugging/plugging cable should not change router settings

Ads by Google