Why am I getting a “Can’t read from the source file or disk” error when trying to move files I can open fine?

yanto milo November 3, 2012

I’m having trouble copying some files, but not all files, from one location to another. The files are not corrupt as the image or video file opens and plays OK in the original location, but any attempt to move it triggers the error message “Can’t read from the source file or disk”. I’m also getting CRC error when unpacking some archive files files.

I’m running 64bit Windows 7 with admin permissions.

I’d appreciate any help on how do I fix this.

Thanks in advance,

  1. Yanto Milo
    November 8, 2012 at 6:58 am

    Recently I posted a query seeking help on how to solve "Can't read from source file or disk" file copy problem.

    This is the first time I posted a query on MakeUseOf.com and for a while I was wondering why there were no response until I found a link on the WordPres email which showed all your responses. Sorry guys for my apparent silence and for not responding earlier.
    I would like to thank everyone who responded with possible solutions. It is very comforting to know that there are techies in the computing community who are generous and willing to help and that you are not alone.

    Here are my summary.

    I had no success copying or moving the errant files when I tried rebooting, (Tks Vishal Mishra, Boni Oloff) shortening file path (Tks Jim Chambers) or unlocking (Tks Peter Gruender). The cable connections were fine (Tks Lisa Santika Onggrid). I had no success either when I invoked Microsoft maintenance solution or taking ownership (Tks ha). These solutions may have worked for other situations but not in this instance. Douglas Mutay, I hope your file copy problem is dissimilar.

    Bruce Epper may have a point when he suggested that there could be inherent problems (dropped frames, missing data) with my files even though they can be opened, viewed, played and renamed but not copied. I shall take up his suggestion (tks) to run checkdisk on the drive. Perhaps there are bad clusters on my hard drive. But before I do, I'm going to salvage what I can and accept that some of my files may be terminal.

    It would be nice if there's a program that can display a more meaningful error message and take the guesswork of why you cannot perform certain file operation (eg.locked, needs privilege, corrupted etc). It would be even better if it can attempt to fix the problem on the same session instance.

  2. Aakash Kothari
    November 5, 2012 at 3:17 pm

    the file is corrupt or not properly downloaded

  3. Douglas Mutay
    November 5, 2012 at 1:55 pm

    I do have the same probleme with 3 movies files inside a folder. I have never been able to copy them out of their folder because everytime I have tried it, it has given me the same "Can’t read from the source file or disk" error. I can open and watch them but will never be able to move or copy them. Still trying...

  4. Jim Chambers
    November 5, 2012 at 4:49 am

    Try Long Path Tool available here for download http://longpathtool.com/Downloads.html

  5. Vishal Mishra
    November 4, 2012 at 7:10 am

    sometimes restarting the computer fix things :D. Try restarting the computer.

    • Boni Oloff
      November 4, 2012 at 9:49 am

      Yeah, sometimes there are errors in the system. And restarting the system can solve the problem.

  6. Peter Gruender
    November 3, 2012 at 5:51 pm

    Try this, it worked for me = http://www.emptyloop.com/unlocker/#download

    But, be careful, the installer for Unlocker installs other junk - unless you opt out of those extras.

  7. Lisa Santika Onggrid
    November 3, 2012 at 4:16 pm

    If you're copying it to removable medias, make sure the cable/USB is working properly and not too loose. That error commonly happens because the directory it'll be copied to is unreadable (connection is unstable, connecting and disconnecting because of loose cable).

    Or sometimes it means the files are already moved/erased so they're not in their original location anymore. Try refreshing explorer.

    If you have problem with CRC, try to download it again, because that means the archive doesn't match the original copy. Maybe the download was cut halfway.

  8. ha14
    November 3, 2012 at 2:46 pm

    try this microsoft solution

    Take Ownership and copy (from where you are copying files)

    CRC error means that archive files are corrupted this can be done while the archive file was formed, when was copied to other destination, or corrupted during download from internet.

  9. Boni Oloff
    November 3, 2012 at 2:19 pm

    Maybe that's only an error, you must try it again. Since you can play the files well, then that just miss calculation.

  10. Anonymous
    November 3, 2012 at 12:27 pm

    Run checkdisk on the drive in question. Just because an image or video file opens without issue does not necessarily mean that there is not a problem with it. Frames can be dropped from video without noticable effect from the viewer's perspective just as there can be damaged or missing data in an image file that is not noticed by viewing it. The CRC errors in archive files can have 2 possible sources: it could be a problem with the compressed file itself having a bad CRC in the archive or it can be a problem when writing the file to the destination which can generate a CRC error (less likely). In any case, a full checkdisk scan of the affected drive is warranted and it may be able to address some of the issues you are seeing. If the issue continues after the drive is given a clean bill of health, you may need to delete the original files and restore from backup. You do have backups, right?

Ads by Google