Problem with wireless networks: difficulty finding available networks and connecting

Lisa O October 4, 2013
Ads by Google

I have an Asus A43E which have difficulty finding wireless networks (mainly WiFi hotspots) even though I know there are several networks available. My friends’ laptops detect these networks but mine can only detect one or not at all. When trying to connect, more often than not it will fail. Even when connected, it’s very slow.

I don’t have the same problem with wired networks. I have checked my power options to set wireless capability to ‘maximum performance’ even in battery mode, but it doesn’t seem to affect the situation. How can I fix this?
I use Windows 7 x64 Home Premium, but the problem with detecting wireless networks persist even when booting elementary, puppy, porteus, and mint. Any chance this is a hardware problem?

  1. Susendeep D
    October 31, 2013 at 10:05 am


    Kindly select the best answer so that it can be helpful for other people with same problem to get their issue solved.

    • Lisa O
      October 31, 2013 at 3:38 pm

      Done. Thanks for reminding. I actually think I've done it before.

  2. Arron W
    October 6, 2013 at 6:49 am

    Do you have a home network you can do more thorough tests on?

    I would suggest completely uninstalling and reinstalling your wireless drivers, the post above gave you a link. If this doesn't solve the issue, it's quite likely that it is indeed a hardware issue, and you'll need to take it back to the store, or to a repair shop. If it's not under warranty, you can pick up a USB wireless adapter for less than £10 on Amazon, and they're still pretty good. I'd suggest the nano size ones, no chance of knocking it and breaking it.

    • Lisa O
      October 6, 2013 at 10:36 pm

      Thanks for your help. I tried Oron's suggestion to update the driver and it now works smoothly. Will remember your advice next time I'm out shopping, though.

  3. Hovsep A
    October 4, 2013 at 11:53 am

    How to Enable Wi-Fi for an Asus Netbook

    open control panel and go to WINDOWS MOBILITY CENTER see if you xan turn wifi ON

    try to reset router

    • Lisa O
      October 4, 2013 at 12:14 pm

      Thanks, but this is different from my situation. I *can* connect to the internet (my WiFi is properly enabled) and the routers aren't mine to reset.

    • Hovsep A
      October 4, 2013 at 4:00 pm

      1) go to run and type cmd, right click on it and choose run as administrator
      2) A black window will open. Type in: sfc /scannow and hit enter, wait for the scan to complete
      3) Then type: chkdsk /f and hit enter, wait the scan to complete
      4) reboot and see if this will solve the problem.

      1) Open the cmd with administrative rights, type each of the command lines below, one line at a time, and press the Enter key each time:
      netsh winsock reset
      ipconfig /release
      ipconfig /flushdns
      netsh int ip reset netshlog.txt

    • Lisa O
      October 6, 2013 at 5:20 am


    • Hovsep A
      October 6, 2013 at 4:49 pm

      have you tried and got results?

    • Lisa O
      October 6, 2013 at 10:35 pm

      Yes, problem solved. I updated the driver.

  4. Oron J
    October 4, 2013 at 10:48 am

    I assume your WiFi card is working properly (i.e. light is on and the system reports it as working). In this case, it could simply be a simple hardware problem, such as a loose aerial or bad WiFi card.
    It could also be a driver problem. Try downloading an update (for Windows 7) and installing it, and see if that helps.

    • Lisa O
      October 4, 2013 at 12:17 pm

      Yes, it's supposed to be working properly. It's likely that you're right; however, can you suggest which one to download? ASUS' download menu for W7 x64 have 9 items down the 'wireless' section, none of them has proper description.

    • Oron J
      October 5, 2013 at 10:59 am

      You'll need to check the make of your WiFi card and find the newest driver on the list for that make. For example, if your card WiFi is Intel-based, you'd choose the version dated 2011.06.02 .

    • Lisa O
      October 6, 2013 at 5:20 am

      Thanks! Everything's alright now.

    • Chris M
      October 7, 2013 at 4:49 pm

      The simple way to update any drivers is to go to Computer(right click)>Manage>Device Manager>Network Adapters>Right click what you are trying to update and choose Update Driver Software...

      Or, choose anything you want to check for updates. After you hit the Update driver software you just follow the directs to search automatically...unless you have the newest drivers on a disk.

Ads by Google