How can I get my printer to communicate with my Ubuntu 10.04 machine?

Frowny November 25, 2010

I have a Lexmark DV5600-6600 printer and a laptop running Linux Ubuntu 10.04. Whatever I do, they just refuse to communicate, even over USB. There does not seem to be drivers for Ubuntu. I tried several drivers for similar printers and was able to get it to recognize the printer, but not to print.

  1. Anonymous
    November 28, 2010 at 9:06 am

    Glad that worked for you, well if ubuntu didnt changed much in newer version, then should work, but only experience can verify this, so you have to try.

  2. Frowny
    November 27, 2010 at 9:24 am

    Thanks! worked just about perfectly. If at some point I where to upgrade to 10.10 or some other hypothetical release, would the process remain the same?

  3. Anonymous
    November 26, 2010 at 8:02 pm

    Hi log in as root Download the driver (the procedure is written for z600 but should work), save it to a desktop folder such as `lexmark`then this, exclude the comments to the right of the hash (#) marks$ mkdir lexmark$ mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark # move the package to a folder. optional, but recommended. $ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz # extract the driver.$ tail -n +143 > install.tar.gz # the sh script is broken for newer systems. use `tail` to extract the binary portion of the script.$ tar -xvzf install.tar.gz # extract the contents produced by tail$ alien -t z600cups-1.0-1.i386.rpm # convert unusable rpm packages to tgz.$ alien -t z600llpddk-2.0-1.i386.rpm # convert unusable rpm packages to tgz.$ sudo tar xvzf z600llpddk-2.0.tgz -C / # extract the tgz's to / putting the files in their right place$ sudo tar xvzf z600cups-1.0.tgz -C / # extract the tgz's to / putting the files in their right place$ sudo ldconfig # DO NOT SKIP THIS STEP or your printer backend won't find required libraries$ cd /usr/share/cups/model$ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz # unzip the ppd, which should _not_ be gzippedThe driver is now installed. Restart the cups daemon:/etc/rc2.d/S19cupsys restartCheck whether the printer backend works;$ cd /usr/lib/cups/backend$ ./z600The output of the above command should be _similar_ to this:direct z600:/dev/usb/lp0 "Lexmark Lexmark Z600 Series" "Lexmark Printer" If you get no output, mount the usb filesystem.Add this to your /etc/fstab file:usbfs /proc/bus/usb usbfs devgid=14,devmode=0660 0 0Then just type: sudo mount usbfs. That should fix it.Now simply set up your printer through the System->Administration->Printing in gnome. Make sure you select the z600 driver, and you're golden.

    z35 driver to have the Z35 driver file: CJLZ35LE-CUPS-1.0-1.TAR.gz

    HOW TO Install printer Lexmark X1270 on (K/L/X)Ubuntu 10.04

    #--- Install alien
    sudo apt-get install alien

    #--- Install
    cd ~/Downloads
    mkdir lexmark
    cd lexmark
    dpkg-deb -x ia32-libs_2.7ubuntu6.1_amd64.deb ia32-libs
    sudo cp ia32-libs/usr/lib32/ /usr/lib/
    sudo ln -s /usr/lib/ /usr/lib/

    #--- Download the drivers from one of the below links (they are mirrors to same file):
    # You will need to manually download the file in firefox, and wait a minute for the download button to appear. Save it in your lexmark folder.
    # or
    # Another location where same file was uploaded in 10/11/2010

    #--- Extract the contents of the downloaded file Z617.tar.gz - it will create a directory "Z617" with 4 "deb" files
    tar -zxvf Z617.tar.gz

    #--- Install each of the 4 "deb" files, in the following order (the order is important):
    sudo dpkg -i Z617/libcupsys2_1.3.9-17ubuntu3.1_all.deb
    sudo dpkg -i Z617/libstdc++5_3.3.6-17ubuntu1_i386.deb
    sudo dpkg -i Z617/z600cups_1.0-2_i386.deb
    sudo dpkg -i Z617/z600llpddk_2.0-2_i386.deb

    #--- Uncompress the file /usr/share/cups/model/Lexmark-Z600-lxz600cj-cups.ppd.gz
    sudo gunzip /usr/share/cups/model/Lexmark-Z600-lxz600cj-cups.ppd.gz

    #--- Now the drivers are installed, but we need to tell cups to use them for your Lexmark printer.
    # - Startup your printer and connect it (by usb in my case) to the computer
    # - Go to System-> Administration-> Printing and click Add.
    # - In the list there should appear a Lexmark option - select it and click Forward. Wait while the computer automatically searches for drivers
    # - Once it has found the drivers, they will appear. Select Lexmark and click Forward, then Z600 (at the end), Forward. Then click Apply on the next screen.
    # If the drivers where not automatically found, as it happend to me in (K)ubuntu 10.04, then it will ask you to "Choose the Drivers" -> click "Provide PPD file", and select the file "/usr/share/cups/model/Lexmark-Z600-lxz600cj-cups.ppd". Then click "Forward" and "Apply" on the next screen
    # - Turn your printer off, wait a few seconds and turn it back on again (this is just to make sure there's nothing in the buffer to cause problems).
    # - Select the printer, right-click -> "Properties" -> "Printer options", and configure the "Media size" (to A4 in my case), the "Media Type" (to Plain Paper=normal paper, in my case) and any other option you see fit. Configure at least the "Media size" or the printings may get out distorted.

    #--- And it should be all done and working now!
    # Try to print a test-page in the CUPS options, or open OpenOffice Writter to write something in a blank sheet and click "Print" :)
    # From now on, you only need to plug the printer to the computer, and you can "Print" normally to it :)

    #--- NOTES:
    #PS. if you get an error message saying that the "printer could not execute a filter" then execute:
    sudo chown -hR root:root /usr/lib/cups/filter
    sudo chown -hR root:root /usr/lib/cups/backendTested and working with:
    Ubuntu 10.04 + Lexmark X1270 printer
    Ubuntu 10.04 + Lexmark Z517 printer
    Kubuntu & Ubuntu 10.04 + Lexmark X1170 printer