How can I make my Print Spooler Service start automatically in Windows 7?

Sam Ford December 6, 2010

My Print Spooler Service will not start, manually or automatically and I cannot print or install a printer. No virus is detected. I am using Windows 7. How can I clear this problem? Microsoft knowledge base did not help.

  1. Fidgety_sam
    December 16, 2010 at 8:07 pm

    Another great suggestion! Thanks. But, you guessed it: it failed. The response was
    Windows Resource Protection could not start the repair service. I'm beginning to think a fresh install will be required. I tried to do a restore but it said the service is not running! It's a wonder I get any display at all!

    P.S. I got snowed in also to the tune of 16 inches. I hope you didn't have to shovel it. (I live in an apartment so I didn't shovel a single flake!)

    • Anonymous
      December 17, 2010 at 2:45 pm

      The last thing I can think of is to do a system repair. It is pretty easy to do with Windows 7, because it has a repair built-in to the OS.

      1. Shutdown your Computer

      2. Press F8 after the BIOS screen.

      3. You should get a text menu, at the menu select "Repair Your Computer"

      4. After to loads up, Just follow the prompts.

      5. There is no Step 5 (sorry, could not help it)

      If this fails, your do not have alot of options. I am reluctant to say it, but a reinstall is the quickest fix, probably.

      • Fidgety_sam
        December 17, 2010 at 5:49 pm

        Thank you so much for your patience and diligence. I really do appreciate your time and effort. Happy Holidays!


  2. Richard Carpenter
    December 15, 2010 at 1:35 pm

    I would run a SFC, you proably have a corrupt system file. Here is how:

    1. Click the Start Orb

    2. Type CMD in the search bar at the bottom of the Menu

    3. In CMD type "SFC /Scannow"

    Sorry it took so long to respond, I got snowed in...

  3. Anonymous
    December 6, 2010 at 7:22 pm

    Does it give you an error when you try to start it? Are there any other Services that are failing?

    • Fidgety_sam
      December 9, 2010 at 6:22 pm

      Thanks for responding. Print spooler is the only service that fails. I cannot even install a printer. Registry appears to be clean (Glary and SystemCare). When I check services it says it is running; when I try to print it says it is not running. When I try to stop it nothing happens; when I try to start it it says it is already running. It is a nice little knot. I appreciate any help or thoughts you can offer.

      • Anonymous
        December 10, 2010 at 4:15 pm

        This I think will help your problem.

        Here is a Video I did for this, I will reply with a real tutorial when my blog decides to work. :-)

        • Anonymous
          December 10, 2010 at 4:27 pm

          Tell Me if that video is any count, Quickly made it this morning.

        • Fidgety_sam
          December 10, 2010 at 6:14 pm

          The video is great! Thanks for taking the trouble. Really liked the music, BTW. Unfortunately, this did not solve the problem. When I restarted windows it said the reconfiguration had failed and was retracting changes. When I went back to windows settings the check mark was still there and the darned thing told me the print spooler was stopped when I tried to print.

        • Anonymous
          December 10, 2010 at 8:38 pm

          Hmm.... I will have to think this out more. This is a real brain teaser, I will ponder this over the weekend.

Ads by Google