Can you help me with a plugin installation on a wordpress blog?

Lewis July 27, 2010
Ads by Google

I have just set up WordPress on manually. I have got it working OK and have installed and activated a theme.

But I have a problem with plugins. Two plugins I have tried to install haven’t worked for me, here are the problems:

1.Plugin – WPTouch

I go to the dashboard,click plugins, add new, search ‘WPTouch’ click install. It unpacks etc. gets to installing and (I think) it freezes. The loading bar stops and it appears to be doing nothing. I have left it for a while but nothing happens.

2.Plugin – Meebo Bar

I want to have the Meebo bar on my site so, I went to the site clicked add new bar for a self hosted WP site, it gives me these instructions:

# Download the Meebo for WordPress plugin
# You now have two options: using the WordPress plugin uploader or unzipping the plugin yourself:

Using the Plugin Uploader

1. Sign in to your WordPress blog.
2. From the left-hand menu, select “Plugins > Add New”
3. Select the “Upload” link
4. Click “Choose File” and select the Meebo for WordPress plugin
5. On the following screen, enter the FTP credentials for uploading to your blog.

I get up to here and upload the .zip and get this message:

    Unable to create directory /home/a7072184/public_html/wp-content/uploads/2010/07. Is its parent directory writable by the server?

I don’t understand what I have to change, I have tried changing permissions but have not succeeded.

Please help me fix this!

  1. Lewis
    August 15, 2010 at 11:19 pm

    Thanks ibnow use them ways :) can you suggest any good plugins?

  2. Jack Cola
    August 1, 2010 at 2:41 am

    Free or cheap hosts have tighter security measures, so permissions and uploading files are much harder.

    I would suggest uploading the plug to wp-content/plugins, extracting the files, go into wordpress and just active it. i would upload through WordPress

  3. Ryan Dube
    July 28, 2010 at 2:00 pm

    Lewis - I've come across this often and correctly fixing permissions on wp-content fixes the issue. You need to be sure you're setting permissions correctly - 755 or higher. Try to avoid 777 if you can. Here is a great resource that may help you out as well:

  4. Josh Fox
    July 28, 2010 at 4:15 am

    Probably the easiest way to install plugins when the automated ways fail is to download the .zip file of the plugin, upzip it, and upload the extracted folder to the wp-content/plugins folder on the server using an FTP application like Filezilla. I have the same problems with my free hosting service, so I have to use Filezilla myself. Once the extracted folder is uploaded, you can activate it by going to Plugins from the admin dashboard.

    • Aibek
      August 1, 2010 at 7:40 am

      I agree with Josh, this method shouldn't fail you.