Why do permissions on the uploaded file in ComicPress not allow reading the file?

tomutwit March 18, 2012
Ads by Google

I’ve been trying to set up a webcomic on WordPress and ComicPress using MakeUseOf’s guide. I can do all the steps, with just a few little niggles (for instance, there is not Manager Config, there is only Config, and the First Run button does not appear) but at the end when I upload my file named
2012-03-16-this-is-hard.png which is just a test comic, I get this message:

The following files were not uploaded, or the permissions on the uploaded file do not allow reading the file. Check the permissions of both the target directory and the upload directory and try again: 2012-03-16-this-is-hard.png

This is absolutely killing me, especially because I did it on my friend’s WordPress sub-installation and it worked.

After having this error a few times I tried to reinstall, this time not installing CP from the Plugins Directory but literally uploading it via FTP as in MakeUseOf’s guide:

How to Create a WordPress-Powered Webcomic With ComicPress How to Create a WordPress-Powered Webcomic With ComicPress Read More

But now the site has completely destroyed itself, if you type in


You get a white screen.
So please help…
1. How to fix WP back to default and then
2. How to install CP properly.


  1. Frumph
    March 19, 2012 at 12:06 pm

    Make sure you have 4 directories in your wordpress root installation, comics comics-rss comics-archive and comics-mini, set the permissions on those directories to 777 (or 775) - the reason you're getting that error is because the httpd (http daemon) and the user are not in the same "group" so the daemon which is being run by the system does not have permission to access the appropriate directories that it needs for reading AND writing.    Setting the permissions properly on those directories will make it work.

    • Tom M
      March 19, 2012 at 5:28 pm

      thanks for replying personally! I must ask, how does it feel knowing you're responsible for like 70% of successful webcomickers?

    • tomutwit
      March 23, 2012 at 8:07 pm

      Have any idea how I might go about doing so?

      • Frumph
        March 25, 2012 at 7:59 pm

         Your FTP program you use is what you need for setting permissions, when you login to your site using your ftp program and you get the list of files in the directory, right-click the file/directory and it click 'properties' (most ftp programs are like this) - then you can see that in the properties of that file or directory it has permissions available, RWX (read write execute) setting it to 777 means that you're setting open permissions for everyone to read and write in that directory. (which is what you need for your hosting).

        • Tom M
          March 26, 2012 at 4:23 pm

          Thank you!! I will try it, and tell you if it works.