Why does password authentication fail when installing an app on my Mac?

56a5b7f2da7df6d9b878d034c76c0a35 March 6, 2012

I am running OS X 10.7.3. Whenever my Mac asks for my password, for example to install an app, it fails and does nothing. I’m entering the correct password and I’m using the admin account.

  1. Mike
    March 7, 2012 at 6:34 pm

    Open up System Preferences, go into Users & Groups and make sure that the account you are currently using is set to "Allow user to administrate this computer". You can also try changing your password there ~ maybe this helps.

    Also as previously suggested you may want to run Repair Permissions within Disk Utility (Applications/Utilities).One general step to solve troubles would be to (re)install the latest combo update however if your Mac doesn't accept your password this is out of the question.

    Last but not least you can follow this guide about removing the AppleSetupDone file.
    When creating a new user set the same username and shortname as the existing user. This will trigger a question whether you want to use the existing home folder for this user. Once you click yes you should get back into your user account with all files and settings and administrative access.

    * Backup, backup, backup. The above only works in a "perfect" world. You may lose all your user files and settings.

    • Adamcole
      April 4, 2012 at 11:08 am

      I'm getting this problem as well, I first noticed it when I tried to update Adobe Flash. The password is correct because if I type an incorrect password the box jiggles in the usual fashion to show its wrong, yet when I type in my correct password theres no movement, the box just disappears and I'm left with the original installer box asking if I want to install/cancel. I've just tried installing Firefox and it hasn't happened but maybe cos it asks you to drag the folder into the applications folder, rather than any installer steps. I've tried all the above to no avail...anyone else having this trouble? Its been going on maybe 3 months now.

      • Mike
        April 8, 2012 at 9:46 pm

        Not sure at which point your installation fails ~ does anything happen if you click install again? Does it ask for the admin password again?

        You could try installing things in Safe Mode.

        If that works I suggest to manually download and install the latest Combo Updater for your Mac OS X version [again, in safe mode].

        Before doing so you probably want to backup your user profile. If your system really is corrupt in such a strange matter things can go anywhere... 
        I have experienced "corrupt but booting" systems going completely dark (dead) during the reboot although Combo Updater finished without errors.

  2. Mulder
    March 7, 2012 at 4:40 am

    If your password authentication failed, it would not "do nothing"; it would tell you that your password was incorrect, at the very least. But if that same password has worked before, then something is wrong on your system.

    You should first open Keychain Access and choose 'Keychain First Aid' from the Keychain Access menu, then try reinstalling that app with your admin password. If it still fails then your Admin password keychain may be corrupt.

    Repair Permission and Repair Disk will not solve your problem, because they have nothing to do with it.

  3. Anonymous
    March 7, 2012 at 1:24 am

    How do you know the password you are typing is correct? Are you able to login with the password you are using, or use it anywhere else and it work? 

  4. Anonymous
    March 6, 2012 at 7:35 pm

    check that your privileges are set to your user name and not 'system'

    Mac OS X: Software installations require administrator password

    run Repair Disk Permissions, and Repair Disk

Ads by Google