Why does Orbit downlader not show the GetIt button for videos anymore?

Nadir Rashdi November 21, 2011

Please solve my problem! Orbit Downloader is not showing GetIt button anywhere. Not in Internet Explorer and not in Chrome as well.

  1. Stocksjody
    February 10, 2012 at 9:47 am


    Iv enabled the grab pro and the getit button still dosent pop up,

    Any suggestions ?

    • Anonymous
      February 10, 2012 at 3:33 pm

      Ok, Make sure that the Grab Pro and Octh Class is enabled in IE under managed addons (Under Tools)? When pulling up the Manage Addon make sure select All Addons under the Show drop down menu.

      To get the best response I would post a new question so more of us will see it.

      • Chauhansuraj84
        February 16, 2012 at 1:26 pm

        thanks  a lot...enabling this option really helped:)

  2. Ray
    November 25, 2011 at 5:38 pm

    I have also seen situations and times where it for some reason grabit simply quits working in Explorer.   After much fooling around I noticed something that might explain it.

    When it does not work, I usually had more than one window open and had closed the old one.  But the process for the closed window had not disappeared.  Once it was gone, the grabit worked again.   

    Also noticed if the particular page had too many simultaneous flash displays playing, it can get confused or slow and not react unless you wait and wait...

    Hope my experiences help...

    PS I have never seen it work in Chrome.   

    • Richard Carpenter
      November 25, 2011 at 5:45 pm

      It will not work in Chrome, the GetIt button is run by the Grab Toolbar. As far as I know, they have not made a extension for chrome. I am fairly sure Grab+ will detect them while using chrome, but I have never tried it. 

  3. Richard Carpenter
    November 22, 2011 at 8:47 pm

    This has happened to me when the grab toolbar is not enabled, Try enabling it IE by right clicking the toolbar and making sure Grab Pro is selected.

  4. Mjevolve
    November 21, 2011 at 8:16 pm

    hello .

    >try updating the Orbit to the latest version .

    >if it still doesnt work , uninstall it and clear out its traces with running CCleaner .
    and then do a clean install of the Orbits latest version .

    >after installation , make sure the options of browser monitoring , flash streaming etc are checked . and all the browsers you want it monitor are also checked .
    then make sure the extensions of files it should download are all ok and not corrupted or the fields are not empty .
    if so , ( although it wont be .) , just enter them manually .

    this should resolve your problem .

    if it doesnt , tell and we can try something else ....

Ads by Google