Why does my modem hang up every 3 to 5 minutes in Ubuntu?

Saptashwa Bandyopadhyay April 28, 2010

I have a dual-boot computer system with Windows XP and Ubuntu 9.10. Ubuntu is installed not within Windows, but it as a complete installation. After about every 5 minutes my modem hangs up. Till then everything is working fine on the net. What’s the problem? And my internet is working absolutely ok in XP for hours.

  1. Anonymous
    October 6, 2010 at 1:44 am

    Routers only usually last like a year before they roast themselves like a Christmas ham. Thats probably it

  2. Rahul Jain
    May 3, 2010 at 8:37 am

    I am not a person who has a knowledge about networking. But I too installed Ubuntu Karmic Koala version. When I called my ISP to help me create an internet connection, he said that Ubuntu has some PPPoE issues due to which I would get disconnected every five minutes.
    Also, he advised me to try some other version of linux like RedHat, or other OS which don't have this problem...

  3. Johnathan TheTool Lane
    May 1, 2010 at 8:17 pm

    IRQ18 may be over loaded. Do you have any log files to submit with your problem? Ubuntu logs are important for troubleshooting the problem. Also your ISP may be dropping the connection for various reasons, but this is usually rare.

    If IRQ conflict is the problem, the solution is probably to move the modem card to another PCI slot. Have you tried this?

    ADDED: It's probably not a problem in Windows, but that might be because Windows can't read the ext3 filesystem. It probably doesn't acknowledge one or two devices which would make associated IRQ conflicts unlikely.

    Let me know :D

    • Saptashwa
      May 2, 2010 at 5:24 am

      I'll try what you said and post the result later.

    • Saptashwa
      May 2, 2010 at 5:28 am

      Can you give me more details on how to fix the problem? Please? Thanks in advance.

    • Saptashwa
      May 2, 2010 at 5:38 am

      Btw I'm upgrading from Ubuntu 9.10 to 10.04 using the alternate install CD as the internet in Ubuntu is not functioning properly. Hope it helps and internet works fine in Lucid Lynx.

    • Saptashwa
      May 2, 2010 at 10:21 am

      Still the same. Could you please give step by step instructions on how to set up a adsl broadband modem connection? Thanks in advance.

      PS - Please give the instructions for Ubuntu 10.04. I've upgraded to it. Thanks again.

  4. Taty
    May 1, 2010 at 3:34 am

    Hi Saptashwa
    Make sure your modem is running with the correct drivers. Also, there might be some settings for your modem available under Ubuntu that aren't set correctly. Check the drivers first and let us know.

    • Saptashwa
      May 1, 2010 at 5:40 am

      Ummmm, I mean it works fine. But for only 3 to 5 minutes. Once it worked for 50 minutes. Until then everything loads and downloads.

Ads by Google