Why does my MiGear eBook reader not turn on?

rach December 14, 2011

My MiGear eBook reader is not working. It won’t turn on and I’ve tried to charge it over night, but it still wont work. I need help. Please help me!

  1. Tony
    February 11, 2012 at 11:16 pm

    Have you tried using a paperclip in the recessed RESET switch in the back?
    If that doesn't work, try this:

    Plug the MiGear into your PC via USB.
    Transfer a video file to it, e.g. a .AVI file.
    Unplug it.
    Watch the video for 5 minutes.
    Turn off the MiGear.
    Turn it on using the button. Did that work?

    That worked for me. My theory is that it won't turn on normally if it is a little "overcharged". 

  2. Shayne
    December 26, 2011 at 8:17 am

    Following are some tips that might be helpful for you, please do your own research to check that I'm right. (I'm an owner and still trying to sort out the using while charging issue.)
    Minimising Recharge Time
    Main Menu (M) – Settings (6) – Display Setting (1) – Light Time (1) – Set to 5 seconds (1)     Change back to Always On or 300 secs etc. as suits after charging.
    Changing Brightness to increase battery life
    M – 6   - 1 – Brightness (2) then setting as needed.
    Charging, please don’t use!
    It appears this message comes up because the system expects to be charged on a PC using the USB cable where there is some danger of data being transferred. Advice is to right click on drive in my computer and Eject Media or use task bar to do the same, apparently this just leaves power supply only and means device is safe to use. Utilizing an ac adaptor does the same thing.
    Covers that fit
    Big W sells a “Laser” faux leather cover for approx $12 that fits well.

  3. Shayne
    December 26, 2011 at 5:05 am

    You have to hold the power button for up to 5 seconds before the screen powers up.