Why does McAfee Security Center Real Time Scanning keep turning off?

Michael Dowling November 27, 2011
Ads by Google

I have McAfee Security Center version 11.0 and Windows 7 Home Premium. My ISP supplies my AV. Until a month ago that was F-Secure, which never gave me problems.

The problem is, I get popup messages warning me that Real Time Scanning is off and my computer is at risk. I click the “turn on” button and things are fine for a while, until it happens again, seemingly at random intervals.

I have followed all the suggestions at the McAfee Communities help forum and still have the problem, although it occurs less frequently than before. I am posting this in hopes that someone reading it has had the same issue and has found a solution.Thanks!

  1. Michael_dowling
    December 14, 2011 at 3:39 pm

    Hi Rhuth: No,I can run a full scan successfully with Mcafee.The last one only showed a PUP.I have resigned myself to living with the problem,as Real Time Scanning is actually still on when Mcafee pops up those warnings,and besides,the frequency is down to about 2 or 3 warnings a day.

  2. Rhuth
    December 13, 2011 at 2:26 pm

    i have the same problem. if i try to run a full scan of the pc to see if i have a virus an error occurs....so a virus protection software that is now disabled from running a virus scan......do you also have this?

  3. Elton Forrester
    December 4, 2011 at 1:52 pm

    Hi. Problems with the Real Time Scanning on your Mcafee.
    Well, when you use the safe mode that's on your pc, By Either using the F8 button during switching on or by going into Start menu-All Programs-Administration Tools-System Configuration, this also turns off/closes the Real Time Scanner thats on Mcafee. When switching the Safe Mode off, back to normal mode, the Real Time Scanner always works again and is back to Green how it should be with the Tick.
    Within the Configuration menu, you can also see if the Mcafee + other programs are enabled or Disabled. Maybe you should try this if it keeps on happening.
    As in the popup warnings that I assume are from Mcafee.
    Get the Mcafee screen up
    Go into Navigation
    Click on Imformation Allerts and untick the allerts that you dont want to appear.
    Maybe this could solve a problem or 2.

  4. Michael_dowling
    November 30, 2011 at 4:57 pm

    Thanks,I checked the last time I got the warning,and Real Time Scanning IS on! Now,how to stop the pop-up warnings?

    November 30, 2011 at 6:11 am

    Hello, have you actually made sure that McAfee Real Time Scanning is off?  Sometimes it happens that windows security center gives you this warning and if you check with your antivirus/firewall, you will notice that is is actually working.  It used to happen with one of my computers before when it had the bit defender security suite.

    Security center would say that my antivirus/antispyware was off.  I would open my bit defender program and check and everything would be running ok.  I just made sure that it was running good and when a was sure, I would just go to security center and disable notifications for the software mentioned. Of course, you could do this, once you are sure that your software is running.

  6. Anonymous
    November 28, 2011 at 5:11 pm

    Let us know if things fixed with you and Mcafee

  7. Mjevolve
    November 27, 2011 at 3:54 pm

    hello .

    first of all, are you sure you removed F-Secure and it is not running along side McAfee .?

    if its indeed uninstalled , please try these steps .

    >uninstall McAfee for the moment .

    >if you have uninstalled F-Secure already , even then i would still recommend running the F-Secure UnInstallation tool .
    here -- http://www.softpedia.com/get/Tweak/Uninstallers/F-Secure-Uninstallation-Tool.shtml

    download. read the instructions and run it .

    i say so , because F-Secure is one product that does not uninstall completely .
    and i have seen many a times , it leaves many things behind after a normal uninstall , and those entries/left over things can interfere in the working of other subsequent apps , esp other security softwares .

    so this tool will try to delete any thing related to F-Secure on the system .

    >then , also search your registry for entries related to F-Secure .
    start-accessories-run- and then type regedit.

    in the window that opens , click on Edit and then Find , and then  search for --
    F-Secure , and delete any entries you find .

    ( recommended - create a restore point before deleting registry entries .!! )

    >then run CCleaner , clean up anything it finds and then restart your system .

    > now do a new clean install for your McAfee product , and it should work fine now ...

    ( and also make sure there are no other security softwares running in real time along side McAfee ..!  )

    try and tell if it worked or more help needed ...

    • Mjevolve
      November 27, 2011 at 4:05 pm

      sorry for not noticing that you did mention, that you have uninstalled F-Secure . 
      but the moment i was typing my reply , your reply wasnt yet updated on this page on my side , and only after i posted my reply , did i saw your comment .

      either ways , i highly suspect the previous F-Secure installation to be the culprit .

      as i say , it has happened to me quite a few times with F-Secure .
      ( Norton dint worked after F-Secure , nor did Eset , on two different systems . 2 events i remember dealing recently ..) 

      only after i did a thorough clean up of entries esp in the registry and else where in the system , did the issue resolved .

      try as i mention . and also try finding entries with a little more powerful registry scanner . like RegCrawler ( Paid ) or RegSeeker ( Free ) http://fileforum.betanews.com/detail/RegSeeker/1035382760/1  

      try and see . and do tell what worked ... 

  8. Michael_dowling
    November 27, 2011 at 3:38 pm

    Hello,thanks for the suggestions.I did run a special F-secure uninstall utility provided by my ISP as the first step when I installed Mcafee. Running " services.misc",I noticed several McAfee services were set to "automatic-delayed".I changed them to plain "automatic". I ran the oas-disabled-fix.cmd again (got this from my ISP as well). Finally,I rebooted my computer.Unfortunately,as I was writing this,I got another warning from McAfee that Real Time Scanning was off.

    • Anonymous
      November 27, 2011 at 4:05 pm

      using the administrator account can solve poblems created during the install by a user in the administrator group? are you administrator?

      launch it and type F-secure and run so that to see any left over reg keys and delete them.

      Also do a search in windows explorer with F Secure and delete all left over files or you can use Everything to look for F secure

      Before unistal Mcafee be sure that you can redowload a fresh copy and your credentials will work.
      now uninstal Mcafee with revouninstaller free version reboot and reinstal again, you can try to uninstal Mcafee in windows safe mode. reboot and reinstal Mcafee and see if this will fix the problem.

      some regcleaners can remove some Mcafee reg keys? Have you used any and if so did they maked a registry backup and if yes try to restore them.

      Have you installed other applications after Mcafee?

      ERROR: Real-Time Scanning is off, Your Computer is at Risk

      • Michael_dowling
        November 27, 2011 at 5:42 pm

        Hi.I ran Regseeker,and it found nothing.When I ran Everything,it found 76 references to S-secure.I deleted all but one entry,which said I didn't have permission to delete.Could you tell me how to do this? Thanks.

  9. Anonymous
    November 27, 2011 at 10:12 am

    have you uninstalled completely  F-Secure?

    Click start – run then type services.msc, In the window that opens up check whether the start up type for all the McAfee programs are in started and Automatic. If not click on the particular service and change it to "Automatic" .

    go below link and scroll down to mail2eshakris reply
    right click on the link and choose save as once the file (oas-disabled-fix.cmd ) is downloaded click on it and proceed as described in the reply.

Ads by Google