Why can’t I see the MakeUseOf login page?

Joanne Striegler September 26, 2012
Whatsapp Pinterest

I have tried to register but was told I already had an account. So I tried to log in. But a login page did not surface. This really is frustrating and I just quit looking for an answer on your website.

Please please help!


  1. Calle Sweden
    October 2, 2012 at 2:33 pm

    Ensure you’re not running any Javascript blocking plugins such as NoScript, AdBlock, or Ghostery.

  2. Rayon
    October 1, 2012 at 6:37 am

    I had that problem only one time . I used ghostery , tracking and have no problem and that all for msn . you got to read these plugin , again . It will tell you don't have too many protecting to one search like chrome and firefox . narrow down those plugin and you should be fine . that goes the same of having too many anti-viruse - you only need two not ten , five , but two . having said early - read those plugin , again , use a fewer number of those wonderful blocker ! good luck !

  3. Nikhil Chandak
    September 27, 2012 at 2:31 pm

    u can see the makeuseof login page at


  4. Ahmed Khalil
    September 26, 2012 at 5:55 pm

    delete cookies and refresh

  5. Dimal Chandrasiri
    September 26, 2012 at 4:53 pm

    well I have the same issue. but I have a work around that always work for me. what I do if I cannot log in from my chrome, I simply log in from FireFox. firefox always display the login and after logging in, I logout from it. then try to login back from chrome and as a charm it allows me! :D funny though..

  6. bonioloff
    September 26, 2012 at 2:41 pm

    Try to use a fresh Firefox, Clear all data, and not using any plugin.
    I use a dedicated browser just to browsing in makeuseof.com :D

  7. muotechguy
    September 26, 2012 at 8:04 am

    I'll reply here instead of to your email you also sent me. It looks like you were a remnant user from when we used Disqus. I've deleted that account now; you should be able to login using the social buttons provided on the top bar. You have a facebook account, so you can use that.

    If you don't see those buttons next to the login link, it's because you're running some kind of evil plugin that breaks the internet: adblock, noscript, ghostery, do not track, no script...

  8. Tug Ricks
    September 26, 2012 at 7:35 am

    This occasionally happens to me. Try clearing your cookies/browser cache, and then restarting your browser. Also, do you have Ghostery/Adblock installed? They can sometimes cause things not to work properly.

    • HLJonnalagadda
      September 26, 2012 at 12:06 pm

      I face a similar issue. I do not use Adblock anymore but I still am not able to log out or comment from Chrome. I have to clear out my cache every time I have to comment.

Ads by Google