Why can my MacBook Pro no longer read my external hard drive?

Trixi Vengai August 20, 2012
Ads by Google

I have a USB 3.0 hard drive multi-port (toaster) with two hard drives in it, which read as 3 a one is partitioned, all formatted to exFat.

My new MacBook Pro could read the hard drives, but when I bumped the machine at all they would disconnect. After this the MacBook wouldn’t read the hard drives. A Pram reset worked, but then it happened again.

Installed a new USB 3.0 driver which Apple said should keep the hard drive from disconnecting so easily, but now the Mac Book is not reading the hard drives at all. Not in Disk Utility either. PC laptop can see them without issue. Pram reset doesn’t work. I’ve googled the hell out of this and am at a loss.

  1. Sashritha Peiris
    December 12, 2012 at 7:57 am

    try it on a windows. It might be a exFat error

  2. Alex Perkins
    October 9, 2012 at 5:20 pm

    Have you tried the other ports on it, that one could be faulty.

  3. Kavita
    October 6, 2012 at 11:23 am

    i think your hard drive is tempered...or still apple has not fixed the problem with usb3.0

  4. Eduardo Ceballos
    September 16, 2012 at 4:49 am

    I have the exact same problem, and It's doing it to my USB 3.0 Portable Hardrive no matter what kind of format I use (exFAT, FAT32, etc). It works at the beginning and then when I bump my computer or the hard drive even slighty it says it disconnected and then it wont show up when I plug it in again and again. I have to reformat it on a different computer for it to work again. I just opened my new macbook pro retina and its only doing this to my USB 3.0 HDD, I also have a USB 2.0 HDD that works just fine and this doesnt happen while using it.

  5. Christopher Webb-Orenstein
    September 13, 2012 at 9:22 pm

    Hi there,
    A few options I would suggest to troubleshoot this are:
    1. Check to make sure your USB ports are not damaged in anyway.
    2. Try using a different USB 3.0 chord
    3. Try attaching a different hard-drive with your USB 3.0 chord
    4. Try attaching a different hard-drive with a different USB 3.0 chord

    Hopefully one of these options will give you a better idea what the problem is.

  6. VictorGeis
    August 27, 2012 at 6:35 pm

    I'm on the side of Fredrick, it sounds like it could be the port. Try and see if any other drives do something similar when plugged into the port. Maybe its the cord itself too; try using a USB extension cord and see if you get any different results.

  7. Frederick Doe
    August 26, 2012 at 10:17 pm

    Does the USB port see anything else? It's possible that the port itself is physically damaged.

  8. ha14
    August 20, 2012 at 5:30 pm

    perform the pre SMC reset steps described by apple
    Intel-based Macs: Resetting the System Management Controller (SMC)

Ads by Google