Why won’t my Mac burn a CD?

David November 29, 2011

I have Mac OS X 10.5.8. I have tried to burn a CD several times the last two days and keep receiving the following message: “Burning the disc failed because communication to the disc drive failed. (error code 0x80020022)” How do I fix this?

  1. Yaspaulseraj
    November 30, 2011 at 9:04 pm

    have you try trowing it into fire.

  2. Anonymous
    November 30, 2011 at 11:32 am

    have you put the cd before you invited to? if yes then wait for the invitation.

    Delete Finder Preferences
    from terminal
    rm ~/Library/Preferences/com.apple.finder.plist

    November 30, 2011 at 7:36 am

    Hello, you are not the only one with this problem.  Read the following thread and try to do some of the steps mentioned there:


    • Mike
      November 30, 2011 at 6:27 pm

      I can confirm that it mostly is a matter of getting the right set of CD-Rs. Sometimes even a newer batch from the same vendor and type may be incompatible.

      Personally I can suggest TDK, MediaRange and Verbatim ~ they always worked for me. At best you buy a small package with 5 CDs or so and test drive them.

      Of course if the third-or-so batch still fails you may want to get your optical drive looked at by an Apple Authorized Service Provider or Distributor.