Why can I no longer use system restore on Windows 7?

Tom October 2, 2010
Ads by Google

I run a Windows 7 Ultimate 32-bit on my HP COMPAQ PRESARIO and I have been restoring my system successfully before. Now I have issues restoring.

I think it all started when I deleted the old catalog of restore points in the system via the disk management space on system protection. Since then I have tried to restore my system to an earlier date or dates even when I create a restore point or points by myself and this have been happening for a while now, but still it keeps telling me this:

System restore failed to replace the file (C:/Windows) with original copy from the restore point. An unspecified error occurred during System Restore.

  1. Anonymous
    October 5, 2010 at 5:11 pm

    Uninstal MSE and try again. If dont help then do the following.

    You may try rebuilding the Windows Management Instrumentation. If you are having errors with the Windows programs, rebuilding the folder the WMI contents are in, will let Windows repair the corrupt files causing the errors. Follow the step given below

    a) Click on Start

    b) In the search box type ‘cmd’

    c) Right click on the search result and click on "Run as Administrator"

    d) In the command prompt type in "net stop winmgmt". (This will stop the WMI so we can fix it.)

    e) Navigate to "C:WindowsSystem32wbem"

    f) Right click on the folder "Repository" and rename it to something like, "Repository_bad."

    g) Go back to the command prompt you used earlier and type in the command, "net start winmgmt".

    h) Re-register the WMI by typing the following command into the command prompt, "winmgmt /salvagerepository."

    i) Restart the computer and check if that helps.

    If you have the original cd of windows and the serial, then you can boot on it and try the upgrade function, because this will not hurt your files.

  2. Tom
    October 5, 2010 at 8:27 am

    I am still experiencing the problem. I deleted the old restore points, created a new one but still it keeps telling me the same error. I have not installed any ASUS tool or Kapersky. All I have is MSE which I have been using since and no problem.

    • Tina
      November 22, 2010 at 11:25 pm


      were you ever able to fix the system restore? What did the trick? We would love to know in case you found a solution!

  3. Anonymous
    October 3, 2010 at 6:56 am

    Is windows booting, or you cannot use your laptop?

    try sfc /scannow

    a. Click Start, All programs and then Accessories. Right Click Command Prompt and select Run as administrator.

    b. In the Command Prompt window type “sfc /scannow” (without quotes) and then press Enter.

    c. After the scan has completed, close the command prompt window, restart the computer and check for the issue.

  4. Mike
    October 3, 2010 at 6:52 am

    Other discussions [via google] pointed out that third party hardware and security programs/utilities can be the reason for this System Restore error. Users were asked to uninstall all ASUS Tools, Zone Alarm or even Kaspersky [on their official forum] and reinstall them after the restore.
    Maybe you installed some related software since your last successfull restore which is causing the error now.