Why can I no longer download MakeUseOf Guides?

Beatrice Abercrumbie April 26, 2011
Whatsapp Pinterest

I don’t know why I’m no longer able to download any of the guides. When I click on the link to download, I get the message: “transferring data from manuals.makeuseof.com.s3.amazonaws.com”. This message shows in the lower left hand corner of the screen while the rest of the page is white. A few seconds later this message goes black, the screen stays blank and nothing happens. I’ve downloaded, installed, and run malware, re-subscribed on the site; no change. What’s wrong?

  1. James Bruce
    April 27, 2011 at 6:16 am

    Beatrice, it sounds like your browser PDF reader is playing up - did you install any new PDF apps or anything?

    Try right clicking -> save link as insteal or just clicking the link. That should download it your pc rather than trying to read within your browser.

  2. Ergys Ura
    April 27, 2011 at 12:10 am

    have you tried re-installing your browsers and also try using browser integrated downloaders instead of external apps (if using such as IDM or DAP)

  3. Tina
    April 26, 2011 at 11:27 pm


    which browser are you using and where are you download from?

    I tried Chrome and Firefox, downloading both from the MakeUseOf Facebook page and the Download page with no problems.

    Maybe you need to upgrade your browser and/or its plugins.