How do I log into MakeUseOf with Chrome after disabling AdBlock?

David B February 14, 2014
Whatsapp Pinterest

I have many extensions running. Maybe one of them is the problem. I turned off FlashBlock and Adblock. I was able to log in through Firefox and Opera.

When I press the login button. It shows up a blank popup screen, where the login button is supposed to be.

Thanks for the help in advance.

  1. David B
    February 15, 2014 at 10:43 am

    The problem was Avast! Antivirus extension. I disabled some blocking features and it worked.

  2. Oron J
    February 14, 2014 at 9:32 pm

    Empty the cache (Tools=>Clear browsing data... , choose "...from: the beginning of time, Delete cookies..., Empty the cache" and click [Clear browsing]. Restart Chrome and try to log on again.

    • David B
      February 15, 2014 at 10:35 am

      Thanks for the answer.
      I have already tried clearing cache and cookies. It still doesn't work.
      I will elaborate a little bit.
      When I load the website and click "Login", It shows "loading the reward program".
      But a second later the sign disappears and no login screen appears. It is basically a blank pop-up screen, with the texture.

  3. Ben S
    February 14, 2014 at 8:20 pm

    What other extensions do you have enabled? I use many, including Disconnect and Ghostery, to stop tracking by social networks like Google and Facebook. These break a lot of stuff that MakeUseOf uses; do you use any of them?

    • David B
      February 15, 2014 at 10:41 am

      Thanks for the tip. You actually helped me find the answer.
      It was the Avast! Antivirus extension. I disabled some blocking features in the extension and it worked.