Why do my laptop’s charging indicators show charging even when not plugged in?

Vipul J August 20, 2014
Ads by Google

I’m running Windows 7 Pro on my ASUS K53SM-SX010D laptop. The laptop has been running fine for 2 years now. Two to three months back the power port of the laptop stopped working and the laptop wouldn’t charge at all, so I got that repaired.

Now I have a weird problem. My laptop is always charging. Yes. Even when I remove external power. Obviously battery drains without power but the sign is always “charging” and so is my charging LED indicator. And similarly when the battery is actually is out of juice and shuts down, I plug in the charger and there is no LED indicator for charging.

I switch it on anyhow, and boom the LED comes back on with charging status. This issue has started recently after I formatted my PC because of a previous networking issue I had posted here.

Now my question is, that is it remotely possible that this is an OS issue and should I reformat? Or is 100% a hardware fault?

Also extra info, probably unrelated, my page down & numpad enter key don’t work.

  1. Hovsep A
    August 20, 2014 at 7:56 am

    1) open device manager
    2) Under betteries Right-click Microsoft ACPI-Compliant Control Method Battery and select Uninstall (do not delete).
    3) Reboot

    • Vipul J
      August 20, 2014 at 2:07 pm

      Thanks for the help.
      I did as mentioned and after I rebooted, the same problem persists and in Device manager the Microsoft ACPI-Compliant Control Method Battery is also back.
      Any further suggestions?

    • Hovsep A
      August 20, 2014 at 2:24 pm

      try to reset the cmos battery and see if this will help you

    • Vipul J
      August 20, 2014 at 2:31 pm

      Is it possible without opening up the laptop? Because a quick google search shows hardware tinkering, which I'm really not well versed with. If it was a desktop I'd do it, but I don't even know how to go about unscrewing the back cover of a laptop.

    • Vipul J
      August 20, 2014 at 2:34 pm

      Also, I had configured my default power options to do nothing when I close the lid. I always did this planning on ASUS Power4Gear profiles, but this is the first time, I did it on Win 7 default profiles. Do you think that might be the issue?

    • Hovsep A
      August 20, 2014 at 4:00 pm

      How can I reset CMOS or BIOS settings?

      do a restore point before using it.

      you can try to dual boot your laptop to see if the problem persist or get solved, if solved then can be windows problem.

      ASUS Power4Gear can cause conflict with windows power performance, so you can try without ASUS Power4Gear profile.

      Fix broken desktop shortcuts and common system maintenance tasks

    • Vipul J
      August 24, 2014 at 8:22 am

      Hi, I tried removing the ASUS profile, and reset settings manually by going into the BIOS. No luck there.
      As for the killCMOS app, it is absolutely not getting downloaded. The ESET antivirus went haywire & when I stopped the protection, Chrome stopped it.
      Is it safe?

    • Hovsep A
      August 24, 2014 at 10:33 am

      it should be safe but it might not work on new hardware and BIOS, dont try it then and if you try do create a restore point and backup image windows in any case
      there is a command prompt here
      check if there is BIOS update then apply perhaps it can fix things.

    • Vipul J
      August 26, 2014 at 1:06 pm

      Hi. I tried all the ways I could do it on windows, but nothing helped. So I bought a set of those small screwdrivers and disassembled the laptop entirely. I removed the cell, left the laptop aside for 20 mins, and put everything back as it was. Luckily everything still works, but unfortunately the issue still exists.

      As I had mentioned "Two to three months back the power port of the laptop stopped working and the laptop wouldn’t charge at all, so I got that repaired.", do you think maybe the charging port is loose from that repair and maybe constantly touching the board, I don't know.

      Or what else can I do?

    • Hovsep A
      August 26, 2014 at 1:21 pm

      well the software do not fix the hardware, it can be kind of driver problem....also as you mentioned perhaps the charging port is not entirely fix you can show to few shops to get an idea what everyone will tell you. You can also format windows and reinstall, i guess you should be able to get to factory restore option in ASUS K53SM-SX010D laptop.

      How to Test a Laptop Battery

      you can check some battery software and see what they will tell you

    • Vipul J
      August 27, 2014 at 7:20 am

      Tried the batteryMon and as expected it shows A/C plug in regardless of whether I plug in or not.
      I guess I need to go to a repair shop after all.
      Thanks for all your efforts! :)

    • Hovsep A
      August 27, 2014 at 6:41 pm

      thanks for the reply, hope that everything will be fine with the laptop, but do charge the laptop there and see if it is fully working; also keep the batteryMon installed it can tell more?

Ads by Google