Why doesn’t my laptop’s BIOS recognize my hard drive?

Philippe Farah May 12, 2012

I have an HP laptop and suddenly the hard drive is no longer recognized by the BIOS and consequently by the computer. I tried another hard drive and the BIOS does not detect it either. Some people told me to update the BIOS, but I don’t know how since I cannot get a prompt. Is my motherboard bad? Please help!

  1. Mike
    May 21, 2012 at 8:22 pm

    I have the same problem on a Compaq CQ 60 that i just changed its HDD. I updated the bios and its still doesn't see it. But i can at any moment go to bios and change the boot options and then save it. It works fine and keeps this setting for some hours but if i turn it off over night, it takes me back to no HDD on the system unless i go through the process of changing the setting again. Its running W7 OS.

    May 15, 2012 at 1:58 pm

    Hello, have you by any chance checked the same harddrives in a different computer? Usually when a harddrive is not recognized in BIOS, the drive is dead. If you checked them in another computer, you would know for sure if they are dead or not.

  3. Dustin Thompson
    May 13, 2012 at 7:06 pm

    I agree with James & Oron, Disk controller has died most likely.
    Just a shot in the dark here, but, have you tries to boot to a external USB hard drive?
    If you can get to the BIOS, change the boot order to boot to USB first.Assuming you have an OS on the drive.

    I don't really know where to find it, but if you can get "PC Check" onto a cd or DVD, then boot to that you can test all your hardware.

  4. James Bruce
    May 13, 2012 at 6:30 am

    Updating the BIOS wont help; it was workign before. Probably the disk controller has broken, but try Oron's advice to replace the battery. Either way your warranty will be invalidated, but then I'm guessing it's out of warranty. Sadly, replacing the H/D controller may be too costly to be economical.

  5. Oron
    May 12, 2012 at 10:37 pm

    It's unlikely to be an "old BIOS" as the disc was previously recognised. It's more likely to be either a corrupt CMOS settings (possibly caused by dead battery), or a faulty controller/motherboard.
    I would suggest taking out the battery for a few minutes (it's a button battery, usually CR2016 or CR2032), then replacing it with a new one (make sure to note which way the + goes!).
    If that doesn't work, you could try fitting another hard disc controller, but you may need a local expert/technician to help you with that.

  6. ha14
    May 12, 2012 at 9:20 pm

    update BIOS

    or in BIOS disable AHCI, or SATA Native Mode

    try to reset cmos battery?

Ads by Google