Why does iTunes stop working when I try to sync my iPod Touch?

collegegal October 17, 2011

I have a Dell laptop running Windows Vista. I’m trying to sync my iPod Touch. It runs OK for several minutes, then error box says iTunes has stopped working. Did a restart, no change.

Apple store told me iPod fine, advised to uninstall iTunes, then download it again from Apple website. Did that, still no joy: “iTunes has stopped working. Windows is trying to solve the problem.” (ha) Advice please!

    October 18, 2011 at 4:34 am

    Hello, you might want to read what is said in the following link.  Make sure to read the comments too:


  2. Mike
    October 17, 2011 at 8:25 pm

    It will be hard to find out what is actually causing the halt.

    First of all I suggest to try another USB port to make sure there is no hardware fault and it will also reinstall the iPod driver ~ it could also be the Dock cable itself but for now I don't think it's necessary to get a new one.

    The next step probably is to check your system files via the command prompt.
    1. click Start and type "cmd" in the search box
    2. right-click the command prompt result and select "Run as administrator"
    3. in the command prompt type sfc /scannow

    This command will check all your system files and make sure none is damages. You may need your Vista DVD to fully run this check.

    Feel free to report back with your results.

    • collegegal
      October 18, 2011 at 7:10 pm

      Mike I have been tearing my hair out for days over this, have tried every solution offered to me then you hit the nail on the head with the one thing I didnt think of - I tried the other USB port, and the sync went off fine, no hiccups at all.
      Thank you, thank you, thank you! XXX
      Computers? aaaaggghh!!

      • Mike
        October 18, 2011 at 9:20 pm

        glad I could help...

        As for the problematic USB port:
        It doesn't necessarily have to be a hardware defect but you can test this by connecting a USB Stick or something to it.

        My guess is you had a corrupt iPod USB driver which was fixed via the iTunes reinstallation but not updated for the USB port you previously used.