Is my external hard drive dead and if so how do I recover the data?

Jeff Brown March 16, 2013
Ads by Google

I have a WesternDigital 2TB external hard drive that isn’t showing up as a lettered drive. It will show up under Computer > Other but no letter and no access, though it does show the free space which is correct from the last time I used it.

I also see it when plugged into my router’s USB slot, though still no access (but available free space is shown). I have tried on both computers in the house. I pulled the case (saw that suggestion on another MakeUseOf question) and found a burn/crud spot right by C18, C19, U6 area and another in the opposite corner R90, C32 area.

I would like to know how to fix this or at least recover my data! Thanks in advance.

  1. somu1795
    March 25, 2013 at 10:44 am

    just use an linux distro to open and repair the harddisk or to backup the data....

  2. Jeff Brown
    March 19, 2013 at 10:07 pm

    I don't know how to update this info but here it is. I have removed the top circuit board to use a SATA/USB connector. I have found the bottom board with burnt marks as well. I do have pics an screenshots but do not know how to add these.

    First of all, I do not know Linux.

    Secondly, my drive shows up in Device manager but I cannot initialize it.

    It shows up in Pandora Recovery but is grayed out and unaccessable

    It does not show up in BIOS. I don't know how far to dig into it so it may/may not be there.

    • ha14
      March 22, 2013 at 2:19 pm

      1) Right-click on “My Computer” then Click on “Manage”
      2) Double-click “Disk Management” You will probably see hard Disk
      3) Right-click in the left portion of that drive box hard Disk
      4) Click “Initialize” and “OK” in the next dialog box. Wait few seconds and it should now say “Online” in the box.
      5) If there is no assigned drive letter, right click on the big space of your WD hard drive then choose Assign drive letter or Change Driver Letter and Path

      1. Go to run and type cmd then right click on it and choose run as administrator
      2. type DISKPART and hit enter
      3. type : LIST DISK. This will show you all the connected disk with the offline one.
      4. Now select the offline disk using the next command SELECT DISK wheredisk_no is the offline disk number which you can get from step 3 result.
      5. Now you have selected the offline disk. Now enter command ONLINE DISK.

  3. Paul Pruitt
    March 19, 2013 at 8:07 pm

    Boot from a DOS disk and try to run Chkdsk on the drive. I just read the amazing MakeUseOf article on a MicroSD recovery, recommended by Chinmay Sarupria, that uses the command. Who knows, maybe it will work with your drive...

    Here's the article: //

    So if it is the E: drive which is your external one, the command is: Chkdsk e: /r

  4. Prashant Mirjankar
    March 18, 2013 at 11:55 am

    From what you have described i feel like you havenot yet partitioned your HD and so no letter denoting you drive. partition it and then look in my computer for the letter denotion

  5. Zamira
    March 18, 2013 at 7:21 am

    If you can see it on your computer, you can try a third party software like Recuva, MiniTool data recovery to try to recover your lost data, or your have to take it to the restore place, which will cost much., while a third party software will cost less.

  6. EL
    March 18, 2013 at 6:16 am

    It might be a good idea to take it to a professional data recovery place. Sometimes, by playing around you can make it worse. Been there, done that.

  7. Rama moorthy
    March 17, 2013 at 2:35 pm

    May be your HD will work on Ubuntu or other Linux distros .. try ..

    • dragonmouth
      March 19, 2013 at 3:30 pm

      Good advice exxcept for one detail - Jeff may not know Linux. Even used from LiveCD, Ubuntu or other Linux distro are not easy to run for someone who only knows Windows.

    • Rama moorthy
      March 19, 2013 at 5:03 pm

      yes , I agree you dragonmmouth , maybe Jeff don't know Linux .. But the Linux are not so complicated to use like before ..

    • Rama moorthy
      March 19, 2013 at 5:04 pm

      Hey Jeff try formatting your HD from boot ,Using any HD tools.

    • dragonmouth
      March 19, 2013 at 9:21 pm

      Linux may not be so complicated when one knows it. Neither is BSD, Unix, MVS. VS/9 or OS-1100 when one has worked with them. For someone seeing even the most user-friendly Linux distro for the first time, it can be very difficult.

  8. Pooky Joralyn
    March 17, 2013 at 1:29 pm

    If you say you can still see it in Computer, then why not go to Computer Management and assign the drive letter from there?

  9. Jan Fritsch
    March 17, 2013 at 3:07 am

    First of these numbers really mean nothing ~ it's a circuit board: C are capacitors, R are resistors, U are usually IC chips (integrated circuits) and they are simply numbered randomly, from top to bottom, left to right, placing within the circuit. Also "burned" is usually hard to see unless it's a huge capacitors like you have on a motherboard. At this small sizes what you see is usually a mixture of flux, grease, dirt and dust.

    As for the problem I suggest to first follow ha14 comment. If it does show up within diskpart all you (should) have to do is manually assign a drive letter. If that doesn't work Jims suggestion to take the hard drive out of it's external casing and directly connect it to the computer is the next step.

  10. Oron Joffe
    March 16, 2013 at 5:06 pm

    Apart from the good advice to try and connect it to the PC internally, and to map the drive using the "Computer Management" console, you could try using data recovery software such as "ADRC Data recovery tools", "Pandora Recovery" or "Easyus Partition Recovery", all of which are free.

  11. Nitesh Badala
    March 16, 2013 at 12:17 pm

    won't able to access any data from your HD then might be possible that your HD is dead.
    if able to access some of data and some of not then your data might be currepted due to virus. go through this ling and find recovery softwares for your platform

  12. ha14
    March 16, 2013 at 10:00 am

    re-assemble the hard drive, check again if windows will recognize and assign a letter

    1) Start > Run and type cmd
    2) type--> diskpart
    3) type--> list volume

    see if your hard drive is there

  13. Alan Wade
    March 16, 2013 at 7:09 am

    Before you write it off try assigning a drive letter to it through Computer management or by using one of the many hard drive apps available.
    Its worth a shot and you may well recover your data.

  14. Hanly Jue
    March 16, 2013 at 5:23 am

    No matter the files on external hard disk are deleted, formatted or lost, don't save new data into it and for your 2TB external hard drive, you have to take it the professional data recovery company to solve it, or you can also use some data recovery software, you can read this article:

    • Jeff
      March 16, 2013 at 3:31 pm


  15. Jim Chambers
    March 16, 2013 at 2:40 am

    From your description, I assume this damage is on the Sata to USB interface board and not on the HDD's circuit board. Try installing the drive in your computer using a Sata data cable and a Sata power connector to see if your drive is OK. If it is, you can purchase another external drive case to install it in.

    • Jeff
      March 16, 2013 at 3:31 pm

      Thanks for replying to my problem. What specs would I need to go by? Do I have to stick with WD or can I get one from any manufacturer?

    • Jim Chambers
      March 17, 2013 at 8:26 pm

      You can get an external drive case from any manufacturer. go by are drive case width - 2.5 or 3.5 inch - and interface type - probably SATA II or III. A computer store can advise you.

Ads by Google