Why does iPod touch push notification not work on my wireless network?

Martinus Tara June 13, 2010
Ads by Google

I got an iPod touch earlier this year. I also runs a wireless network in my house using Linksys WAP54G access point.

I noticed that the push notification on the app on my iPod was not working (eg. Mail, Facebook, Yahoo! Messenger, etc). I thought there is something wrong with the hardware/software. I did reset, hard and soft, but still it doesn’t push any new messages.

Yesterday, I was at a restaurant running a wireless network for customers, and IT WORKS! All mails, chat messages, and everything else related to the push works, simply works. I got back home, and it doesnt work! I wonder what would be the problem.

So far I’m using my wireless network without problems. I can browse, chat, streams, and all with my MacBook and MacMini perfectly. What could be wrong?

FYI, I set my wireless with WEP encryption. Somebody help me!

  1. Emma
    December 14, 2011 at 12:57 am

    Thank you so much Joy! It works. :)

  2. Ekta020498
    May 2, 2011 at 6:29 pm

    Same problem mine works sometimes, ans sometimes it doesnt .weird

  3. stella
    February 26, 2011 at 8:27 pm

    this is the same problem with my ipod touch too.... wonder y this happens...?

  4. Joy
    December 22, 2010 at 3:41 am

    Chance your DNS to, it works for me

    • Daly
      July 7, 2011 at 8:44 pm

      This worked for me!
      Thanx :))

    • Cheryl How
      October 15, 2011 at 9:14 pm


    • Godfather423
      November 15, 2011 at 4:46 pm

      Thank u so much. This worked like a charm. And omg I got so many notification.

    • Emma
      December 14, 2011 at 12:56 am

      Thank you so much!! I've been trying to figure out the problem for ages!! It works!

    • Lennart
      January 11, 2012 at 3:10 pm

      Thank you soooooooo much :D I searched about a couple of hours and now you did it :P Thanks a lot...

    • Maranwe_linz
      February 11, 2012 at 3:46 am

      Thank you!!! Brilliant job

      • Edwardrattliff
        February 18, 2012 at 12:26 am

        How. Many 8's

    • Farouk
      March 2, 2012 at 2:47 pm

      You're one hella of a guy man! Thank you!

  5. Zee thelight
    October 28, 2010 at 7:11 am

    Your router is probably blocking port 5223.
    Google apple support for details.

  6. Tnt0517
    September 27, 2010 at 6:01 pm

    My does that sometimes too but I don't think anything is wrong with it but mine works when I'm at home too but sometimes it don't weird sometimes

  7. Tina
    July 2, 2010 at 7:24 pm


    did you solve the issues your iPod push?

  8. Jasjeev Singh Anand
    June 23, 2010 at 2:46 pm
  9. Saqib Saud
    June 18, 2010 at 7:47 am

    is your iPod Jailbreaked?

    • Martinus
      June 20, 2010 at 3:56 pm

      nope. OS 3.

    • Latif
      February 27, 2011 at 7:18 pm

      I don't get noftication on my iPod touch should I jailbreak my iPod touch

Ads by Google