How can I get my iPhone out of DFU Mode?

OscaR January 10, 2011

iPhone4 (16GB), I jailbreak by limera1n successful, but in iPhone limera1n not appear and I test by redsnow by click pwned DFU mode (black screen). I call restore but I can’t. I use tinyumbrella, now my phone can’t get out of DFU mode. Anyone can help?

  1. Israel
    May 4, 2012 at 10:55 am

    my iphone 3gs is stuck on black screen after i restored it cant get out of pwned dfu mode ant suggestions???

    • Susendeep Dutta
      May 6, 2012 at 2:50 am

      Did you tried Mike's suggestions present below this page?Many people have got their issue solved by implementing his suggestion.

  2. Shoaib
    March 24, 2012 at 2:26 pm

    Hi thanks mike i did the same and my iphone is working thanks a lot

  3. R Rajenbhat
    February 19, 2012 at 3:51 pm

    Hey I selected reset media and file in my iPhone got stucked unable to do anything. Only an apple logo coming on screen with waiting mark..wat to do?

  4. Sam
    January 2, 2012 at 1:00 am

    got saved by Mike! thx dude!

  5. Guest
    November 8, 2011 at 8:32 pm

    Mike you have a dick like einstein

  6. Nancywf1983
    November 1, 2011 at 11:04 am

    Need real help send me a message with your problem and I'll make sure you get your apple divice fix free cus I'm not a cunt like tuna tina face hahahaah

  7. Asia
    October 16, 2011 at 10:53 pm

    Well me being stupid i tried to jailbreak my ipod well it was working until it was in DFU mode and it all of a sudden got stuck on the restore screen i tried taking it off i even tried to update it after that nothing happend it still was stuck on that same screen i don't know what to do it will not go off of that please help me!

    • Tina
      October 17, 2011 at 7:24 pm


      try the solutions provided in response to the question above and to the questions found here: DFU Mode

      If none of these work, feel free to ask a new question. Good luck!

  8. eye riss
    October 1, 2011 at 1:15 am

    I bought an iphone 4, 4.3.5 locked to at&t. i tried to jailbrake it with redsnow and restored it to 4.3.3 with custom firmware from snowbreeze. everything went smoothly, no errors but now my phone is not responding. I can't reboot it or get out of DFU mode. Well i am not sure what is wrong with it, the screen is black, i cant turn it on tried everything but when i keep the home button pressed for a few seconds it makes noses. Anyway have a clue what is wrong with it? help please. thank you

    • Tina
      October 8, 2011 at 8:53 am

      Eye riss,

      if the solutions above do not work for you, I recommend that you submit a new question.

      • Nancywg1983
        November 1, 2011 at 10:59 am

        TINA SHUT YOUR FAT FACE UP!!! Your no help we all knows this. Stop trying to act like your somebody lol

  9. Frankopatrny
    September 30, 2011 at 4:11 am

    YOur alot of help Tina...get a new job

    • Tina
      September 30, 2011 at 7:17 pm

      So you never make mistakes?

      • John Jarvin
        November 10, 2011 at 5:12 am

        I don't mean to be rude Tina, but you are kind of a useless waste of space who likes to cut corners when it comes to doing your job. Im pretty sure eighty percent of the responses I have read from you included something about asking a new question. Its really annoying and the repetitiveness is starting to make me wonder if you are human at all. You sound like a goddamn robot.

        • Tina
          November 10, 2011 at 9:19 am


          the main purpose of my work here is to help people getting their tech issues solved. This doesn't mean that I answer all of the questions myself, although I do respond to some if I happen to know the answer. We do have many experienced contributors, staff, volunteers, and random visitors like yourself, in other words people with various professional backgrounds, who, as a collective, do a far better job at solving tech issues than myself. Hence, I try to make sure questions get those people's face time.

          Having managed this forum for close to two years, I know that questions within a comment thread hardly ever receive a response. Thus I started recommending people to ask a new question. Getting your question on the MakeUseOf Answers front page is the best way to receive a solution.

    • Nancywf1983
      November 1, 2011 at 10:56 am

      Hahaha for reals what a bitch with no knowledge on shit just plain annoying remarks no help why so ever

  10. gkk
    September 27, 2011 at 8:14 pm

    Hi did u find a solution for the problem?
     I am also having the same problem for the last few days.

  11. Rony
    September 20, 2011 at 7:48 pm

    i have an iphone 4 running on 4.2.1,while i was simply restarting my springboard ,it freezed on the apple logo.Holding the sleep button didn't help, so i held both sleep and home button.the screen went off so i turned it back on, and i found the itunes + cable screen. I tought i accidently entered recovery mode, but using ''tinyumbrella'' didn't kick it out..and trust me i tried every thing, and used all the tips(holding both buttons), and i know i can restore it, but i'm looking for a way to keep all the data :/ i took it to this guy..nd he told me that i WAS in dfu mode not in recovery, even with the itunes logo,..thats why i couldn't kick it out :/..nd he said i had no choice but to restore and upgrade(noot what i'm planniing to do)

    soo, is anyone familiar with this kind of dfu mode (without black screen)?..
    And pleeazzee doo tell if there's a way to get out of it without restoring or smthn.


    • Tina
      September 22, 2011 at 7:31 pm


      this sounds like a question we have not had before. In case you don't receive an answer in this comment thread, feel free to ask a new question.

  12. D3M0
    September 20, 2011 at 4:21 am


     Please help me... I jailbroke my iphone 4 with greenpoison on 4.2.1. I used it for some time and then started acting up like self reboot. So I decided to reformat and reset setting in the options of the iphone itself not itunes. After that my phone got stuck on startup (apple logo with spinner) everytime. So then I tried to restore via itunes but got the 10xx errors. I used Ireb and tiny umbrella to restore. I get the 1013 error with official firmware no matter what methods I try. So I used snowbreeze to make  custom ipsw. Tried that and selected with itunes using ireb and tiny umbrella again and itunes completed the restore but it goes back to DFU (black screen) I can not get it out of the pwned blackscreen even after a successful restore. Please help me out. Thank you and I appreciate any help. Sucks to have a phone and not be able to use it

    • Tina
      September 20, 2011 at 6:48 pm


      the above question is rather old and you are unlikely to receive a fresh reply in this comment thread. You will increase your chances to find a solution by asking a new question.

      • D3M0
        September 21, 2011 at 3:26 am

        Thanks Tina

        • Tina
          September 21, 2011 at 9:00 pm

          Hm, reading this comment I realize that I didn't connect the dots when I moderated comments earlier today. If you do not find a working solution in the other questions I linked to, which I clearly should have linked to in my first response to you above, then please reply to the 'rejection' email I sent you and I will manually re-publish your question. Sorry for the frustration!

  13. Talal
    August 18, 2011 at 2:10 am

    All ok nw.All i did was click restore and update without selecting a file,directly updating fr apple server.

  14. Sheroze Salman
    August 9, 2011 at 4:09 pm

    i had the same prob. but i fixed it.follow these steps to get out:1. go to "C:WINDOWSsystem32driversetc" there will be a "hosts" file, open it with notepad and delete all those lines containing (also delete the ip address before it)2.Connect your device.3. then go to itunes (without running any hacking software e.g: tinyumbrella, etc.) and restore on restore and update , and after the process you will be fine.

  15. Sheroze Salman
    August 9, 2011 at 4:08 pm

    i had the same prob. but i fixed it.

    follow these steps to get out:

    1. go to "C:WINDOWSsystem32driversetc" there will be a "hosts" file, open it with notepad and delete all those lines containing (also delete the ip address before it)

    2.Connect your device.

    3. then go to itunes (without running any hacking software e.g: tinyumbrella, etc.) and restore it.

    click on restore and update , and after the process you will be fine.

    • Sudra Ashish
      August 20, 2011 at 11:39 am

      Hi Sheroze ,

                           I haveing same problem . And i have follow steps given by you. Now its showing emergency call screen. Now can you please suggest what to do ? I have no orignal sim card. I comes to know from resources i need to wait fro next version. Is there any way i just use iPhone as a iPod. Please suggest me.


      • Tina
        August 21, 2011 at 4:28 pm


        if you do not receive an answer here, I recommend to ask a new question.

    • Anonymous
      October 6, 2011 at 9:02 pm

      i do the same but always get 3194 error - no matter how host file looks like!:(((

    • awesomeman
      February 21, 2012 at 5:28 am


  16. Talal
    August 5, 2011 at 4:44 pm

    Help!!! My ipod touch 4gis stuck on dfu.i was on 4.1 when i used limera1n to jb.all was ok.but then i wanted to update to 4.3.3  so i put the ipod in to dfu and now i can't get it out.HELP!

    • Aibek
      August 6, 2011 at 7:05 am

      I am with Tina, best would be if you ask it as anew question.

  17. Aboxer3
    August 5, 2011 at 10:51 am

    Tina Shut Up!

  18. Gautam
    August 2, 2011 at 3:41 am


    • Tina
      August 3, 2011 at 1:20 pm

      Why are you screaming?

      • Nancywf1983
        November 1, 2011 at 10:49 am

        Your comments to ppl are so FUCKN annoying get a life stop telling ppl your mindless mean comments

  19. Oneill366
    July 21, 2011 at 6:56 pm

    Same here. Tried to restore to 4.3.3 firmware, in the end (after full install proces) got the 1013 error and iphone stayd in DFU mode. No option for tinyumbrella to kick it out - i tried, same with fixrecovery43. Tried many times. Only option is to restore again by itunes to oryginal (updated - latest) firmware. Tried any times again, still same thing... HELP PLEASE

    May 19, 2011 at 2:29 am


    • Tina
      May 19, 2011 at 2:47 am


      did you try all of the tips above?

      I think you should submit a new question. Please specify what you did to your iPhone before it got stuck in DFU mode, e.g. did you try to jailbreak it and how? Any other details can only be helpful, please add them!

    • Cooolthud
      September 20, 2011 at 2:51 am

      use RedSnow 0.9.8b7b. Use the downloaded firmware, then msg goes to ipsw success. Then go to next and check boot device option alone and then next. Do it for 3 or 4 times, ur iphone will start. It worked for me as well. 

      • Tina
        September 20, 2011 at 6:47 pm


        the above question is rather old, so you are unlikely to receive a reply in this comment thread. You will increase your chances to find a solution by asking a new question.

  21. eli
    January 26, 2011 at 11:17 am

    I tried to erase all data from my iphone, and it didn't start back on! I tried to restore using tinyumbrella and same firmware I have on my iphone (4.1), and still doesn't work. I tried different types of redsn0w up to 0.9.6rc8 and snowbreeze 2.1 to create custom ipsw, and still no luck!

    • Tina
      January 26, 2011 at 4:53 pm


      I recommend that you ask a new question to get a specific answer for your issue.

      Please refrain from writing in all upper case. It is the text equivalent of yelling, i.e. it's very rude.

      • snowbreeze 2.3b3
        May 5, 2011 at 5:51 pm

        asking the question more accurately ... it is not making any sense

      • Nancywf1983
        November 1, 2011 at 11:07 am


  22. James Bruce
    January 11, 2011 at 3:08 pm

    You will need to use tinyumbrella again to kick it out of DFU mode. You shouldnt need to have used to kick into DFU, but it will save your ass now you are stuck. After kicking out, you can restore and try again.

    In general, dont mix your jailbreaks. Stick with one that others have written will work. Limerain does appear, but sometimes you need to reset - also, did you check the next homescreen? It gets installed to your second home screen by default, so even if you cant see it on the first screen, it may be on the second screen...

  23. Anonymous
    January 11, 2011 at 2:40 pm

    To get out of the DFU mode or out of Recovery mode (for example after a jailbreak that fails), simply disconnect your device from your computer, and press and hold the "Home" and "Power" buttons for ten seconds. Then you can boot the iPhone normally.

    Choose a specific restore, firmware to click on the button "Restore iPhone" in iTunes while pressing the ALT key to appear window to select a firmware.

    Just click DFU button in PwnageTool and go by advices... It will PWN your iPhone and patch iTunes so you can restore a custom firmware

    This new mode will enable all the windows users to restore the custom iOS IPWS firmware. It means it will work just like the PwnageTool which does the same type of job on Mac machines (but PwnageTool also cooks the custom iOS firmware).

    • Littlecaptfish
      December 31, 2011 at 9:21 am

      Dude I was stuck after a failed jailbreak and iTunes kept saying "we detected an iPhone in recovery mode" and showing like 5 different iPhones but your tip helped soooo much thank you. I'm going to restore my phone anyway to make sure it's cleaned out

    • Gabriel Buchdahl
      April 3, 2012 at 10:40 am

      Oh my finggod you saved my life I was JBing my friends phone and I think I thought That I bricked it. THX!

  24. Mike
    January 11, 2011 at 11:19 am

    Are you stuck in DFU mode (black screen) or Recovery Mode (iTunes Logo + Cable)?

    First thing I would try:
    (1) connect the iPhone via the cable with your computer
    (2) hold down the Sleep/Wake + Home button for ~10 seconds until the iPhone reboots
    (2) after hearing the "USB device disconnect" sound press the Sleep/Wake button

    also worth a try:
    (1) hold down the Sleep/Wake for 5 seconds (do not release it after those)
    (2) keep holding Sleep/Wake and press the Home button for 10 seconds
    (3) release the Sleep/Wake button but keep Home pressed until the Apple Logo appears (or ~30 seconds have pased)

    other than that:
    - restore the official Firmware via iTunes
    - reinstall iTunes and then try to restore the Firmware

    • Nawazish_ali99
      December 6, 2011 at 9:22 am


    • zamius11
      December 12, 2011 at 9:04 pm

      wow thanks this happened to me so i did this and it worked you rock

Ads by Google