Why do I have to install Ubuntu in safe mode for it to work properly?

SAHIL May 21, 2010
Ads by Google

I have installed Ubuntu many times, but the problem I face is that it hangs within 2-3 minutes after logging into the PC. So I searched the net and finally installed Ubuntu in safe mode. Now it works fine.

However, my question is, why can’t I install Ubuntu normally like I do for other operating systems like Fedora or Windows?
Why does Ubuntu often hang immediately after logging into the computer when not installed in safe mode?
What’s the difference between normal and safe mode? Do I have to compromise over some features in safe mode?
One thing I also notice is that after installing in safe mode I can’t jump from basic interface to advance interface option.

I am a big fan of Ubuntu, but don’t know why it happens. I have tried this on more than four computers, but same thing happens again and again. Is it all about the graphics card or what?

Please reply!

  1. Brian
    April 11, 2011 at 9:39 am

    I installed avg for ubuntu 9.4 (I think that's it) and now It can barely load desktop- It becomes unusuable piece of junk.

  2. Anonymous
    May 21, 2010 at 11:37 pm

    Hi SAHIL,

    I never have this problem (even with low spec computers) and it's a bit difficult to know the problem without knowing more detail about your computer specs. But if this happens to many different computers, I think the culprit is the installer. Have you tried other versions of Ubuntu installer (or download another one)?

    • Sahil
      May 22, 2010 at 7:41 am

      @thurana the 8th version of ubuntu installs without any problem but the problem starts coming after i uprade to 9th version of ubuntu...Due to which i had to reinstall ubuntu 9 in safe mode.....
      & now i am running 10th version in safe mode....as in normal mode it freezes within seconds...& whats the difference between safe & normal mode of ubuntu ??
      no the installer is not the culprit i have installed from different original cd's of ubuntu 9....
      I have Compaq SR 5060IL Desktop pc with 2.25 GB ram,160Gb Hard disk, Core2duo processor..@1.80Ghz

      Name Compaq FP1707 on Intel 82945G Express Chipset Family
      Current Resolution 1024x768 pixels
      Work Resolution 1024x738 pixels
      State enabled, primary, output devices support
      Monitor Width 1024
      Monitor Height 768
      Monitor Bpp 32 bits per pixel
      Monitor Frequency 60 Hz
      Device \.DISPLAY1Monitor0
      Intel(R) 82945G Express Chipset Family
      Memory 224 MB
      Memory type 2
      Driver version

      Manufacturer ECS
      Model Livermore
      Chipset Vendor Intel
      Chipset Model i945G
      Chipset Revision A2
      Southbridge Vendor Intel
      Southbridge Model 82801GB (ICH7/R)
      Southbridge Revision A1
      Brand American Megatrends Inc.
      Version 5.16
      Date 07/18/2007

      Intel Core 2 Duo E4300
      Cores 2
      Threads 2
      Name Intel Core 2 Duo E4300
      Code Name Conroe
      Package Socket 775 LGA
      Technology 65nm
      Specification Intel(R) Core(TM)2 CPU 4300 @ 1.80GHz
      Family 6
      Extended Family 6
      Model F
      Extended Model F
      Stepping 2
      Revision L2
      Instructions MMX, SSE, SSE2, SSE3, SSSE3, EM64T
      Bus Speed 200.0 MHz
      Rated Bus Speed 800.0 MHz
      Stock Core Speed 1800 MHz
      Stock Bus Speed 200 MHz
      Average Temperature 63 °C
      L1 Data Cache Size 2 x 32 KBytes
      L1 Instructions Cache Size2 x 32 KBytes
      L2 Unified Cache Size 2048 KBytes
      Core 0
      Core Speed 1200.1 MHz
      Multiplier x 6.0
      Bus Speed 200.0 MHz
      Rated Bus Speed 800.0 MHz
      Temperature 63 °C
      Thread 1
      APIC ID 0
      Core 1
      Core Speed 1800.2 MHz
      Multiplier x 9.0
      Bus Speed 200.0 MHz
      Rated Bus Speed 800.0 MHz
      Temperature 62 °C
      Thread 1
      APIC ID 1
      Type DDR2
      Size 2304 MBytes
      Channels # Dual
      DRAM Frequency 266.7 MHz
      CAS# Latency (CL) 4 clocks
      RAS# to CAS# Delay (tRCD) 4 clocks
      RAS# Precharge (tRP) 4 clocks
      Cycle Time (tRAS) 12 clocks
      Bank Cycle Time (tR?) 16 clocks
      Number Of SPD Modules 2
      Slot #1
      Type DDR2
      Size 256 MBytes
      Manufacturer Hyundai Electronics
      Max Bandwidth PC2-5300 (333 MHz)
      Part Number HYMP532U64CP6-Y5
      Serial Number 04008008
      Week/year 11 / 07
      SPD Ext. EPP
      JEDEC #3
      Frequency 333.3 MHz
      CAS# Latency 5.0
      RAS# To CAS# 6
      RAS# Precharge 6
      tRAS 16
      tRC 21
      Voltage 1.800 V
      JEDEC #2
      Frequency 266.7 MHz
      CAS# Latency 4.0
      RAS# To CAS# 4
      RAS# Precharge 4
      tRAS 12
      tRC 16
      Voltage 1.800 V
      JEDEC #1
      Frequency 200.0 MHz
      CAS# Latency 3.0
      RAS# To CAS# 3
      RAS# Precharge 3
      tRAS 9
      tRC 12
      Voltage 1.800 V
      Slot #2
      Type DDR2
      Size 2048 MBytes
      Manufacturer Kingston
      Max Bandwidth PC2-6400 (400 MHz)
      Part Number
      Serial Number 67243DD2
      Week/year 03 / 10
      SPD Ext. EPP
      JEDEC #3
      Frequency 400.0 MHz
      CAS# Latency 6.0
      RAS# To CAS# 6
      RAS# Precharge 6
      tRAS 18
      tRC 24
      Voltage 1.800 V
      JEDEC #2
      Frequency 333.3 MHz
      CAS# Latency 5.0
      RAS# To CAS# 6
      RAS# Precharge 6
      tRAS 16
      tRC 21
      Voltage 1.800 V
      JEDEC #1
      Frequency 266.7 MHz
      CAS# Latency 4.0
      RAS# To CAS# 4
      RAS# Precharge 4
      tRAS 12
      tRC 16
      Voltage 1.800 V

      • Aibek
        May 23, 2010 at 1:34 pm


        I am not an Ubuntu users but in regard to the difference between safe and normal mode I can syat in safe mode the OS loads only the essentials. That is to say it only loads the components necessary for Ubuntu to function, most of the "addons" and drivers aren't loaded during the safe mode. Looking at your problem I assume it must must be an issue with one of your drivers.

        In your case I would try removing/updating video, audio, networking, drivers one by one and see if it fixes the problem.

        • Anonymous
          May 23, 2010 at 1:51 pm

          Hi Sahil,

          Adding to Aibek's response, I also think that hardware is not the
          problem. I've installed Ubuntu in lower spec compies without problem.

          My best guess is that something wrong when you upgrade from 8 to 9.
          This might be in the form of leftovers drivers that incompatible with
          newer version of Ubuntu.

          I would suggest you try to format the drive and re-install from zero.
          If my guess is right, things would go smoothly. Cross your fingers. :)