How can I install Android onto my Yoshima MID M70003 7-inch Android 1.6 internet tablet?

Annette August 28, 2011

I have just acquired a Yoshima MID M70003 7-inch Android 1.6 Internet Tablet that powers up, but shows a blank screen. How do I load Android on it? Thanks!

  1. Harshal
    March 10, 2012 at 6:54 am

    i have a M70003 7 inch tab with 2.2 froyo OS but its having some buggs it hangs showing LOADING screen after it boots. plz help me format it.

  2. Kermbo
    September 1, 2011 at 3:58 pm

    I formatted the micro SD to fat32, loaded the chip with the folder, put it in the tablet and turned it on.
    I could see that it was turned on because of the green light indicator.
    Now I am ready to try the ROMs.

    • Kermbo
      September 1, 2011 at 5:39 pm

      I tried the 1.7.4 from media fire... No luck.
      Rapidshare will not let me download the original 1.7.3.

      I will try the other links.
      Thank you for helping.

      • Kermbo
        September 1, 2011 at 10:25 pm

        The Tai language version pictures show it's the same one but the link for the firmware was broken. Same with the last android 1.6 link... No luck so far.
        Suggestions appreciated.

        • Anonymous
          September 2, 2011 at 9:08 am

          Android 1.6 shorten URL

          Thai link reom

        • Kermbo
          September 2, 2011 at 11:10 pm

          I tried all the links, no luck.
          I purchased a USB connector and tried it in the PC... Not recognized. The pc didn't see it.
          The green led light comes on, but no vibrations.
          I asked the person who had it before me and was told:
          It was working perfectly he was trying to do a youtube mod tutorial and downloaded the new software onto an sd card and ran the android off of the sd card and he turned it off one day and forgot to put the sd card back in when it booted all the software was deleted.

          What shall I try now?
          Thanks for your help.

        • Kermbo
          September 3, 2011 at 12:32 am

          It doesn't seem to respond at all. Is there a way to reload the factory software again? Could I fix anything by taking it apart?
          Thanks again.

        • Anonymous
          September 4, 2011 at 2:08 pm

          Does it charge? if no battery then no boot?

          1. brick2.unplug the reset button for 10 sec. there should be a reset button?4.get in power and set in memory stick with your working firmware remember you need a full battery otherwise wont work firmware upgrade, now if do not charge and pc do not recognize then must be a hardware problem?

        • Kermbo
          September 4, 2011 at 8:37 pm

          It doesn't respond to the firmware on the micro SD card. I've tried all the ones suggested. The green led light is on, so I think the battery is good.
          What pc software do I need to tell me if the tablet is recognized?

        • Anonymous
          September 5, 2011 at 5:35 pm

          Well possible for scrypting reasons, you need a scrypt to launch the firmware, dont know how to do that.

          have you tried this one

          1) Extract and Copy the folder "scripts" in a MicroSD card.2).  connect the power supply and insert the MicroSD card slot.3). Turn Android. Start the system recovery.4). Remove the MicroSD only when prompted.

 Android 1.6/Seriale EVD00506 - EVD99999/script_V2.1.rar

          Concerning softwares, well the driver normally is inside Yoshima, when connected they will Say HELLO to each other.there is Unknown Device Identifier 

          You can install Zentimo

 will list devices

        • Kermbo
          September 5, 2011 at 10:40 pm

          Thank you I will try.

  3. Kermbo
    August 29, 2011 at 6:28 pm

    Thank you for your help. I will try.
    I am a newbie.
    How do I do a hard reset?

    • Anonymous
      August 30, 2011 at 6:07 am

      Not sure may be Power+Menu+Back

          m70003 tablet disassembly

      • Kermbo
        August 31, 2011 at 11:47 pm

        Thank you for helping me.
        The hard reset didn't work but the green light indicating power is on.

        How do I format the micro SD to fat38?


  4. Anonymous
    August 29, 2011 at 3:15 pm

    Have you tried a hard reset?

    When you connect to pc is it recognized?

    If its not thenpossibly you cant do things with it. SO concerning ROMS you need the ones suitable with the included memory on your tablet, check this site (you will need to registrate)

Ads by Google