HTC Desire malfunctioning

Anonymous September 26, 2013
Ads by Google

My girlfriend and I are into our phone plan just over the two year term. We bought the same phone at the same time and are experiencing the same problem: They shut down for days with no service. Then the date comes up as Jan 6 1980, but it does say limited service, I’m assuming this might mean emergency service.

I have tried everything including emailing HTC and Telus, they both try and help but neither can fix the problem. I went as far as telling them I believe it’s a conspiracy to get people to buy a new phone.

I don’t think I’m wrong. Unless someone can help me I am going to give up on the smartphones and return to the dumb phones, you know: The cell phones that only make and receive calls!

I am cancelling my phone plan as soon as you get back to me.

  1. Susendeep D
    November 1, 2013 at 5:26 am

    Have you tried hard resetting your phone ?

    If it still doesn't helps,ask Telus to give a replacement phone.If they refuse,then ask for money refund and switch to another smartphone.

    If you get a bitter experience in one brand then that doesn't means that you'll get the same in others too.If you like to have a phone which has good after sales service,then why not have a look at Apple,Samsung or any other brands which you are confident provides better service in Canada.

  2. Jan F
    September 26, 2013 at 3:06 am

    January 6 1980 00:00 UTC , is the start of week zero for the GPS timekeeping service.

    I can think of a few options that happen here:

    Your device completely loses power and therefor it's current time and date setting. To ensure it can resync with the GPS time service the system resets to week zero. The time will not resync until your device has a connection to your providers network.

    Another option is that your device is set to get the time through the mentioned time service. Somehow at some point it loses the signal to your provider (e.g. dead spot at your home) and resets the time to week zero to ensure it can resync with the time service next time it has a connection.

    Now, I honestly don't know about GSM authentication and stuff but one technical problem I sometimes come across is that servers cancel the authentication if the time gap between client and server is too big (e.g. ActiveSync).

    So what may happen here is that your provider is blocking access because of the wrong time on your device while at the same time, your device doesn't get the correct time until it is connected to your providers network.

    One thing you should try if that "blackout" happens again is to set the correct date and time on your device and see if will reconnect to the providers network right after that.