How to unbrick your trashed WRT54G Linksys router?

Fred B July 28, 2013

While running the Firmware Upgrade Utility, I get an error “Incorrect/No File name Transfer Abort!” What does that mean and where do I go from here.

  1. Fred B
    July 29, 2013 at 7:26 pm

    Solved the problem. Had to create a static ip address. Once I did that it went right through

    • Jan F
      July 29, 2013 at 11:55 pm

      guess I replied seconds too late... glad you find a (easy) solution

  2. Jan F
    July 29, 2013 at 12:35 pm

    Where did you download the firmware file from and did you make changes to it's name? Usually the official firmware with the default name should not cause any of this issue.

    When downloading firmware make sure it is not only compatible for your model (WRT54G) but also for the revision of your hardware. The revision can be found next to the Model No. on the back side of the router.

    If all fails I suggest the following guide

    • Fred B
      July 29, 2013 at 5:16 pm

      The above guide is what I used. All went well until I got to the step to run the TFTP to install the upgraded file. That is when I get the error. I have downloaded the file as stated in the above guide dd-wrt.v24-12548_NEWD_micro.bin that didn't work. So I went to DD-WRT and downloaded there file dd-wrt.v24_micro_generic.bin and that didn't work. Same error for both.
      Both files were downloaded to my computer, I didn't change the names, and all I had to do was to direct the TFTP where to find it.

    • Jan F
      July 29, 2013 at 11:52 pm

      Does your router actually work i.e. you can access the web interface or is it truly bricked?

      If the GUI still works I would rather follow the instructions outlined by DD-WRT if you click on the Additional Information link during the firmware download instead of one of the many possible options on "recover-flashing".

      First start usually is to perform a 30-30-30 reset:
      While the router is powered on press reset
      after 30 seconds keep reset pressed and unplug the power connector
      after another 30 second replug the power connect
      wait for another 30 seconds before letting finally letting go of the reset button

      Give it another 60 seconds to (try) booting and then unplug and replug the power once more. If the firmware on the device is not corrupt it should be booting up normally with factory settings.

  3. Oron J
    July 29, 2013 at 12:25 pm

    Does the router work apart from upgrading the firmware, or is it totally bricked?

  4. Bruce E
    July 28, 2013 at 11:29 pm

    The file that you specified containing the updated firmware does not exist. The router can't find the file to perform the update. Check the filename and try again.

    If you are attempting to pull it from the web, it is basically the same issue. It can't find the necessary file to do the update. See if you can manually download the file and apply it locally.

Ads by Google