How to reset the missing WiFi connections on Ubuntu 12.10 64-bit?

Jacques Piché April 5, 2013

I’ve just set up my laptop with Ubuntu 12.10 64-bit. The Ethernet hardwire connection works OK, but I can’t get the WiFi networks.

I’ve searched to web, tried various fixes, nothing seems to work. Any suggestions or fixes?


Acer Aspire 4752, Intel® Core™ i3-2350M CPU @ 2.30GHz × 4, 6 GB RAM, 750GB HD

Core 3.5.0-26-generic, Gnome 3.6.0


  1. Jeffrey Wilson
    June 7, 2013 at 10:29 am

    Go to system settings then network on the left hand side look for wired,wireless and
    network proxy click on wireless on the right hand side network name arrow. If
    system loaded wireless driver
    If that does not work connect your wired either net then go through the setup
    I just told you about, connect wireless, unhook the wired it will be automatic after that.
    Then update your system. By typing sudo apt-get update && sudo apt-get upgrade.

  2. Zoran Filipovi?
    April 6, 2013 at 9:09 am

    I was have same problem. (you probably have Broadcom wi-fi card)

    sudo apt-get update
    sudo apt-get install firmware-b43-installer
    sudo apt-get remove bcmwl-kernel-source
    sudo reboot


    Go to settings manager > Additional drivers
    and search for propietary BCM driver there.

  3. ha14
    April 5, 2013 at 6:54 pm
  4. Bruce Epper
    April 5, 2013 at 3:39 pm

    "I’ve searched to web, tried various fixes, nothing seems to work."

    What have you tried? ndiswrapper? specific driver downloads from support sites?

    • Jacques
      April 5, 2013 at 3:44 pm

      Like many, I'm new, didn't keep trak of w5 but mostly Ubuntu help forums with all kinds of direct terminal coding etc...

      sorry for the lack of info.

    • Jacques
      April 5, 2013 at 4:04 pm

      As a biginner I've more or less tried many of the Unbuntu Forum fixes. That is enter code into the terminal and got halfways but it always jams and says it doesn't recognise this or that command line.

      I should document my every move. And no, never tried ndswapper.

Ads by Google